#fdio-csit: csit weekly 161026

Meeting started by mackonstan at 14:00:46 UTC (full logs).

Meeting summary

  1. : Inputs from FD.io projects - VPP (mackonstan, 14:03:25)
    1. Damjan providing update - new features: snat, security groups (mackonstan, 14:04:09)
    2. Maciek, Dave proposal - use the new make test infra, once merged with initial baseline tests, to execute per patch verify jobs for functional tests. (mackonstan, 14:12:51)
    3. use that as a main functional verification test framework going framework, incl. as an acceptance criteria for any new VPP node code (mackonstan, 14:13:35)
    4. Dave Wallace and Jan Gelety to provide oversight of make test framework and tests, and updates on vpp and csit calls (mackonstan, 14:21:30)
    5. Dave Wallace and Jan Gelety also agreed to review all patches into vpp make test, and +1 once kosher (mackonstan, 14:22:01)

  2. DPDK+VPP focused pre-integration testing. (mackonstan, 14:24:14)
    1. some work in the background - some progress. (mackonstan, 14:24:51)

  3. TLDK - no update. (mackonstan, 14:24:59)
  4. FD.io CSIT operational status - VIRL testing jobs - csit-vpp, vpp-csit. (mackonstan, 14:25:33)
    1. issues with vpp restart - brute force solution - https://gerrit.fd.io/r/#/c/3572/ (mackonstan, 14:26:30)
    2. 3572 is short-term and going into csit oper branch now (mackonstan, 14:27:36)
    3. proper fix is to increase http://dut_setup.sh/ execution timeout to 100s + (mackonstan, 14:30:18)
    4. this is due to as of ubuntu16.04 we're using systemd to drive vpp restart, and systemd has 90sec timeout (mackonstan, 14:31:39)
    5. brute force solution cherry-picked to oper-161024 branch: https://gerrit.fd.io/r/#/c/3598/ (jgelety, 14:31:59)

  5. Perf testing jobs - csit-vpp, vpp-csit. (mackonstan, 14:41:11)
    1. Jan reporting occasionally qemu report error after parsing output of /proc/memory for hugepages variables (mackonstan, 14:42:16)

  6. Performance tests (mackonstan, 14:48:19)
    1. dpdk rls baseline - work in progress (mackonstan, 14:48:40)
    2. trending baseline tests - https://jenkins.fd.io/view/csit/job/csit-vpp-perf-master-long/plot/RFC2544%3ANDR/ (mackonstan, 14:50:34)
    3. multi-core - non-repeatable results - needs investigation - Peter, Maciek to lead, all others to chip in (mackonstan, 14:52:12)

  7. Functional tests - vpp make test framework (mackonstan, 14:54:51)
    1. initial test infra and sample test cases patches - to be merged after rebase and code-review (mackonstan, 15:00:17)
    2. https://gerrit.fd.io/r/#/c/3345/ (mackonstan, 15:00:22)
    3. Functional tests - csit virl (mackonstan, 15:00:30)

  8. Functional tests - csit virl (mackonstan, 15:00:41)
    1. all tests that need driver functionality stay in csit virl functional e.g. vhost, SPAN, dpdk, af_packet, tuntap. (mackonstan, 15:01:38)
    2. need to update jira (mackonstan, 15:03:15)

  9. CSIT HC tests (mackonstan, 15:04:02)
    1. Samuel relaying request from OPNFV/FDS team to test HC+VPP running on Centos (mackonstan, 15:05:18)
    2. this requires onboarding of Centos 7.2 into VIRL, so that HC CSIT tests described at links below can be executed in the environment desired for FDS (mackonstan, 15:06:36)
    3. https://wiki.fd.io/view/CSIT/Honeycomb/Summary (mackonstan, 15:06:51)
    4. ACTION: Samuel to email description to csit-dev of what's needed from VIRL Centos VM to conduct HC tests (mackonstan, 15:07:35)
    5. let's cover it from now on as part of HC project update at the beginning of csit calls (mackonstan, 15:08:00)


Meeting ended at 15:08:20 UTC (full logs).

Action items

  1. Samuel to email description to csit-dev of what's needed from VIRL Centos VM to conduct HC tests


People present (lines said)

  1. mackonstan (36)
  2. collabot (4)
  3. jgelety (1)


Generated by MeetBot 0.1.4.