#fdio-csit: csit weekly 161221

Meeting started by mackonstan at 15:00:52 UTC (full logs).

Meeting summary

  1. Agenda bashing (mackonstan, 15:01:14)
    1. Jan Gelety (jgelety1, 15:02:12)
    2. Peter Mikus (pmikus, 15:02:19)
    3. Matej Klotton (mklotton1, 15:02:51)

  2. Inputs from FD.io projects (mackonstan, 15:10:14)
  3. vpp (mackonstan, 15:10:25)
  4. HoneyComb (mackonstan, 15:10:38)
  5. TLDK (mackonstan, 15:10:52)
    1. pmikus - reviews done, bootstraps merged, perf tests looking good +1ed, missing the actual job. pmikus to send status summary, highlight open action re jjb definition. (mackonstan, 15:12:36)

  6. dpdk-testpmd separate test - same status as for TLDK. (mackonstan, 15:13:01)
    1. pmikus - dpdk-testpmd separate test - same status as for TLDK. (mackonstan, 15:13:18)

  7. TSC - Sending embassies to neighboring projects CSITs (mackonstan, 15:13:37)
  8. Request for CSIT to share an update on the CSIT activities and what your priorities are from CSIT perspective for 2017 (mackonstan, 15:15:42)
    1. mackonstan - will work on CSIT readout for LF board, will have draft for review on the csit weekly call in January (mackonstan, 15:18:23)
    2. mackonstan - request to confirm the level of IT support in place for csit perf lab setup (mackonstan, 15:18:48)

  9. FD.io CSIT operational status (mackonstan, 15:21:58)
    1. most if not all vpp-csit-verify-virl jobs failing today due to infra issues … (mackonstan, 15:24:41)
    2. edwarnicke - issue with image building subsystem - fix applied at 14:50 utc: (mackonstan, 15:25:53)
    3. https://gerrit.fd.io/r/#/c/4451/ <- CSIT image fix (edwarnicke, 15:26:16)
    4. https://gerrit.fd.io/r/#/c/4451/ <- Jenkins image fix (edwarnicke, 15:26:35)

  10. vpp1701 and csit1701 readiness (mackonstan, 15:27:02)
  11. CSIT proposed actions: (mackonstan, 15:35:42)
    1. stick to using csit master branch to test vpp stable/1701, create csit stable/1701 in January (mackonstan, 15:36:17)

  12. csit1701 release plan (mackonstan, 15:38:44)
  13. deliverables: (mackonstan, 15:40:47)
    1. generic: csit-perf, csit-func, contributions to vpp-make-test, csit bug fixes, sphinx rtd docs (mackonstan, 15:41:06)
    2. specific perf: more NICs, vhost, crypto-SW, crypto-HW(?), dpdk16.11 testpmd standalone, TLDK(?) (mackonstan, 15:41:26)
    3. specific func virl: crypto, NAT, SPAN, IPFIX, CentOS (mackonstan, 15:41:40)
    4. sgmonroy - crypto test update - some delay, but code should be published in gerrit today 21-Dec (mackonstan, 15:42:12)
    5. ACTION: mackonstan - send email to LF infra team (Konstantiin) to request crypto HW card placement in fd.io csit performance testbed tb3. (mackonstan, 15:46:45)

  14. Test environment infra topics (mackonstan, 15:49:24)
  15. vhost NDR results still low per csit1609 report note - CPU jitter fixes with CFS settings - status (mackonstan, 15:49:38)
    1. - pmikus - all work completed, and trending graphs are reflecting thput perf as per manual tests (mackonstan, 15:49:58)

  16. Adding Centos - func VIRL (mackonstan, 15:50:41)
    1. dwallacelf, pmikus - thferbert reported on vpp call yday that this is still wip. no known blockers. eta is tbc. (mackonstan, 15:51:16)

  17. optimizing VPP environment build infrastructure for testing (mackonstan, 15:51:34)
    1. consider using a shared Packer infra for CSIT, VPP, ci-management projects (mackonstan, 15:52:05)
    2. ACTION: dwallacelf - make a proposal for a shared Packer infra (mackonstan, 15:55:39)

  18. Performance tests (mackonstan, 15:57:51)
  19. trending baseline tests - one-core, multi-core (mackonstan, 15:58:26)
    1. • trending plots must be cleaned up as current plugin generated views are impossible to read (mackonstan, 15:58:34)
    2. edwarnicke - great if individual graphs linked via specific urls (mackonstan, 15:58:54)

  20. vhost use cases (mackonstan, 16:08:42)
    1. mackonstan - wiki page updated with proposed list of priority vhost test cases (mackonstan, 16:09:05)
    2. https://wiki.fd.io/view/CSIT/vhostuser_test_scenarios (mackonstan, 16:09:13)
    3. mackonstan - note this is still work in progress, as more discussion is taking place on csit-dev thread (mackonstan, 16:09:35)
    4. https://lists.fd.io/pipermail/csit-dev/2016-November/001192.html (mackonstan, 16:09:44)
    5. https://lists.fd.io/pipermail/csit-dev/2016-December/001274.html (mackonstan, 16:11:12)

  21. CSIT perf test case renaming proposal to align with use cases (mackonstan, 16:12:16)
    1. mackonstan - proposal to normalize naming for all csit perf and functional test cases, driven by growing number of test cases and test topology combinations, including vhost use cases per fd.io csit consultation (mackonstan, 16:13:33)
    2. - idea is to encode test topologies and functions using tree notation with physical ports and NIC on the left (underlay), followed by outer most frame header, then other stacked headers up to the header processed by vSwitch-VPP, then VPP forwarding function, then encap on vhost interface, number of vhost interfaces, number of VMs. (mackonstan, 16:14:19)
    3. see description at the wiki link below (mackonstan, 16:14:33)
    4. https://wiki.fd.io/view/CSIT/csit-perf-tc-naming-change (mackonstan, 16:14:40)
    5. gerrit patch tracking this is #3856 (mackonstan, 16:15:49)
    6. https://gerrit.fd.io/r/#/c/3856/ (mackonstan, 16:15:52)

  22. next csit call 4-Jan-2017 - skipping next week as most people offline during Xmas and NY week. (mackonstan, 16:16:58)
    1. Happy Christmas and Happy New Year to Everyone ! (mackonstan, 16:17:13)


Meeting ended at 16:17:17 UTC (full logs).

Action items

  1. mackonstan - send email to LF infra team (Konstantiin) to request crypto HW card placement in fd.io csit performance testbed tb3.
  2. dwallacelf - make a proposal for a shared Packer infra


Action items, by person

  1. mackonstan
    1. mackonstan - send email to LF infra team (Konstantiin) to request crypto HW card placement in fd.io csit performance testbed tb3.


People present (lines said)

  1. mackonstan (55)
  2. edwarnicke (4)
  3. collabot (4)
  4. pmikus (1)
  5. jgelety1 (1)
  6. mklotton1 (1)


Generated by MeetBot 0.1.4.