#fdio-csit: csit weekly 170111

Meeting started by mackonstan at 15:05:24 UTC (full logs).

Meeting summary

    1. Dave Wallace (dwallacelf, 15:05:27)
    2. Jan Gelety (jgelety, 15:05:30)
    3. Samuel Elias (selias, 15:05:38)
    4. Sergio Gonzalez Monroy (sgmonroy, 15:05:40)
    5. Tibor Frank (tifrank, 15:05:56)
    6. Tom Herbert (tfherbert, 15:06:01)

  1. VPP project inputs (mackonstan, 15:07:13)
    1. new email thread to resolve issue with inclusion of cryptodev libraries in csit (mackonstan, 15:08:16)
    2. Sergio, Damjan, Jan+Peter - drive this to conclusion (mackonstan, 15:10:56)
    3. VPP17.01 on target for rls on 18-Jan. (mackonstan, 15:13:06)

  2. HoneyComb inputs (mackonstan, 15:13:22)
    1. no inputs (mackonstan, 15:13:25)

  3. TLDK (mackonstan, 15:13:35)
    1. no inputs on a call - mackonstan to ask ray kinsella to provide summary readout (mackonstan, 15:15:09)

  4. FD.io CSIT operational status (mackonstan, 15:16:04)
    1. all good (mackonstan, 15:16:42)

  5. vpp1701 and csit1701 readiness (mackonstan, 15:16:51)
  6. DPDK CryptoDev - csit-perf, csit-func - dependency on incl. external libraries (mackonstan, 15:19:06)
  7. SNAT44 - make test - need to check if there, or remove. (mackonstan, 15:20:05)
  8. DPDK16.11 standalone - testpmd tests are running on x520 - remove "?" :) (mackonstan, 15:20:36)
  9. SPAN? (mackonstan, 15:21:25)
    1. ACTION: jgelety - to check status in csit-virl (mackonstan, 15:21:38)

  10. IPFIX? (mackonstan, 15:21:47)
    1. ACTION:  jgelety - to check status in csit-virl (mackonstan, 15:21:56)

  11. Centos tests (mackonstan, 15:22:09)
    1. Submitted ci-man patch new series. (tfherbert, 15:23:02)
    2. working on csit patch for parallel repositories for centos. (tfherbert, 15:23:19)

  12. csit branch creation: rls1701, use this gerrit patch (mackonstan, 15:28:34)
    1. https://gerrit.fd.io/r/#/c/4448/ (mackonstan, 15:28:41)

  13. csit1701 report data (mackonstan, 15:29:04)
    1. use Peter's script to generate the report (mackonstan, 15:30:49)

  14. Test environment infra topics (mackonstan, 15:32:26)
    1. next series of ci-man patch waiting for review. -- Fin al step working on csit patch to access parallel nexus repo to ubuntu for centos as recommended by Jan. Not sure of Nexus repo name for Centos. (tfherbert, 15:32:59)

  15. Adding Centos - func VIRL - Thomas F. Herbert (mackonstan, 15:32:59)
    1. I took out wekly doc verify job from ci-man patch based on Jan's review for now. (tfherbert, 15:36:23)
    2. is that a new ci-man patch then? (tfherbert, 15:36:36)
    3. +1 - don't think we need a separate csit branch (mackonstan, 15:38:37)
    4. Need help understanding how to implement meta-test as described by Dave? (tfherbert, 15:39:46)
    5. ACTION: can we work this out offline. (tfherbert, 15:40:10)

  16. CSIT test case renaming proposal to align with use cases (mackonstan, 15:43:03)
    1. https://wiki.fd.io/view/CSIT/csit-perf-tc-naming-change (mackonstan, 15:43:17)

  17. Performance tests - adding cryptodev tests: ip4 - onboarding wip (mackonstan, 15:43:44)
    1. Sergio - current results look bogus - likely due to broken build process i.e. no inclusion of external libraries (mackonstan, 15:44:17)
    2. ACTION: sgmonroy, Peter, Kirill, Maciek - connect offline to clarify the status, and work out resolution (mackonstan, 15:45:52)

  18. DPDK perf baseline in CSIT - testpmd in host user-mode (mackonstan, 15:46:24)
    1.  DPDK16.11 standalone - testpmd tests are running on x520 (mackonstan, 15:46:44)
    2. need to add xl710 (mackonstan, 15:46:53)
    3. and add other nics - x710, vic1227, vic1385 (mackonstan, 15:47:07)
    4. ACTION: Peter, testpmd team (Anna) (mackonstan, 15:47:27)

  19. online docs (mackonstan, 15:48:13)
    1. posting on LF FD.io CSIT project site - need to posted to nexus, gerrit patch for ci-mgmt in place (mackonstan, 15:48:36)
    2. https://gerrit.fd.io/r/#/c/4598/ (tifrank, 15:48:46)
    3. ACTION: edwrnicke - to merge this patch (mackonstan, 15:48:49)
    4. ACTION: edwarnicke - pls merge this patch https://gerrit.fd.io/r/#/c/4598/ (mackonstan, 15:49:08)

  20. new csit-perf tests (mackonstan, 15:49:39)
    1. vxlan, vxlan-vhost tests (mackonstan, 15:49:49)

  21. Functional tests - csit virl (mackonstan, 15:50:51)
    1. vxlan+l2bd, vxlan-vhost tests (mackonstan, 15:51:16)
    2. https://gerrit.fd.io/r/#/c/4603/ (jgelety, 15:51:24)

  22. CSIT test case renaming proposal to align with use cases (mackonstan, 15:55:04)
    1. agreed to update just filenames, no splitting of TCs into separate files (mackonstan, 15:55:31)
    2. in csit1701 report include full mapping (mackonstan, 15:55:40)
    3. update the wiki to reflect that: https://wiki.fd.io/view/CSIT/csit-perf-tc-naming-change (mackonstan, 15:55:58)
    4. https://wiki.fd.io/view/CSIT/csit-perf-tc-naming-change (mackonstan, 15:56:01)
    5. ACTION: jgelety, mackonstan - to execute this ASAP (mackonstan, 15:56:15)

  23. Use case tests (mackonstan, 15:56:30)
    1. top-level use cases added as new TCs into csit-func virl and csit-perf (mackonstan, 15:57:10)
    2. need to work on the next set of TCs with contributors to vhost use case discussion and csit (mackonstan, 15:57:30)

  24. Functional tests - vpp make test framework (mackonstan, 15:58:07)
    1. still not part of vpp verify job (mackonstan, 15:59:02)
    2. and it was not discussed on vpp call yday :( (mackonstan, 15:59:11)

  25. vhost use cases (mackonstan, 16:01:31)
    1. finalize the consensus on vhost test cases (mackonstan, 16:01:50)
    2. https://wiki.fd.io/view/CSIT/vhostuser_test_scenarios (mackonstan, 16:02:01)
    3. complete the review on email thread (mackonstan, 16:02:07)
    4. translate agreed vhost TCs into csit jira (mackonstan, 16:02:23)
    5. ACTION: mackonstan ping into email thread - refer to wiki link (mackonstan, 16:02:41)
    6. +1 on Jira (tfherbert, 16:02:46)

  26. Centos next steps (mackonstan, 16:03:26)
    1. ACTION: We have agreement on pursuing discusion on next steps in email. (tfherbert, 16:04:02)
    2. tfherbert to provide inputs in irc or email to csit-dev (mackonstan, 16:04:15)


Meeting ended at 16:04:24 UTC (full logs).

Action items

  1. jgelety - to check status in csit-virl
  2.  jgelety - to check status in csit-virl
  3. can we work this out offline.
  4. sgmonroy, Peter, Kirill, Maciek - connect offline to clarify the status, and work out resolution
  5. Peter, testpmd team (Anna)
  6. edwrnicke - to merge this patch
  7. edwarnicke - pls merge this patch https://gerrit.fd.io/r/#/c/4598/
  8. jgelety, mackonstan - to execute this ASAP
  9. mackonstan ping into email thread - refer to wiki link
  10. We have agreement on pursuing discusion on next steps in email.


Action items, by person

  1. jgelety
    1. jgelety - to check status in csit-virl
    2.  jgelety - to check status in csit-virl
    3. jgelety, mackonstan - to execute this ASAP
  2. mackonstan
    1. jgelety, mackonstan - to execute this ASAP
    2. mackonstan ping into email thread - refer to wiki link
  3. sgmonroy
    1. sgmonroy, Peter, Kirill, Maciek - connect offline to clarify the status, and work out resolution
  4. UNASSIGNED
    1. can we work this out offline.
    2. Peter, testpmd team (Anna)
    3. edwrnicke - to merge this patch
    4. edwarnicke - pls merge this patch https://gerrit.fd.io/r/#/c/4598/
    5. We have agreement on pursuing discusion on next steps in email.


People present (lines said)

  1. mackonstan (67)
  2. tfherbert (11)
  3. collabot (4)
  4. tifrank (4)
  5. jgelety (2)
  6. sgmonroy (1)
  7. dwallacelf (1)
  8. selias (1)


Generated by MeetBot 0.1.4.