#fdio-csit: csit-weekly-170222
Meeting started by mackonstan1 at 15:01:53 UTC
(full logs).
Meeting summary
- 
  - Samuel Elias (selias,
    15:04:11)
 
 
- agenda bashing (mackonstan1, 15:04:15)
  - Sergio Gonzalez Monroy (sgmonroy,
    15:04:16)
 
  - Tibor Frank (tifrank,
    15:04:25)
 
  - Dave Wallace (dwallacelf,
    15:04:28)
 
  - Tom Herbert (tfherbert,
    15:04:32)
 
 
- Inputs from LF and FD.io projects (mackonstan1, 15:04:35)
 
- vpp (mackonstan1, 15:04:53)
  - https://wiki.fd.io/view/Projects/vpp/Release_Plans/Release_Plan_17.04
    (mackonstan1,
    15:06:12)
 
  - Jan Gelety (jgelety,
    15:06:33)
 
  - mackonstan1/Maciek - suggested to discuss the
    plan and test coverage on one of the next vpp calls (mackonstan1,
    15:06:44)
 
  - Peter Mikus (pmikus,
    15:06:47)
 
 
- HoneyComb (mackonstan1, 15:07:04)
 
- FD.io CSIT operational status (mackonstan1, 15:08:20)
  - Nighlty job not working. LF ticket opened
    [FD.io Helpdesk #37116] (pmikus,
    15:10:57)
 
 
- csit1701 - followups (mackonstan1, 15:11:29)
  - need to track progress on resolving the issues
    listed in the csit rls1701 report (mackonstan1,
    15:12:50)
 
  - perf issues - Peter, Maciek to follow
    (mackonstan1,
    15:14:14)
 
  - https://docs.fd.io/csit/rls1701/report/vpp_performance_tests/csit_release_notes.html#known-issues
    (mackonstan1,
    15:14:16)
 
  - func issues - Jan, Maciek to follow
    (mackonstan1,
    15:14:40)
 
  - https://docs.fd.io/csit/rls1701/report/vpp_performance_tests/csit_release_notes.html#known-issues
    (mackonstan1,
    15:14:43)
 
  - HoneyComb issues - Sam, Maciek to follow
    (mackonstan1,
    15:15:26)
 
  - https://docs.fd.io/csit/rls1701/report/vpp_performance_tests/csit_release_notes.html#known-issues
    (mackonstan1,
    15:15:28)
 
  - perf Tests to be Added - Cryptodev (mackonstan1,
    15:16:18)
 
  - Sergio confirmed some issues with cryptodev
    device binding to igb_uio - patch on the way, hopefully in couple of
    days (mackonstan1,
    15:17:40)
 
  - Tibor, Sergio continuing to work on thsi
    (mackonstan1,
    15:19:20)
 
  - perf Tests to be Added - SNAT44 (mackonstan1,
    15:20:29)
 
  - Peter update - currently on hold - waiting for
    update from vpp-dev re code update (mackonstan1,
    15:20:49)
 
  - perf Tests to be Added - Additional NICs
    (mackonstan1,
    15:21:17)
 
  - Peter update - weekly review calls with testpmd
    team in place - Anna, Waterman (mackonstan1,
    15:22:09)
 
  - Peter update - xl710 and x710 testpmd tests are
    faiiing - 2nd interface is always down - testpmd can't bring it up -
    reproduced with dpdk16.09, 16.11, 17.02 (mackonstan1,
    15:24:15)
 
  - func Tests to be Added - Centos (mackonstan1,
    15:26:09)
 
  - Jan update - bootstrap files updated
    (mackonstan1,
    15:26:45)
 
  - Qemu patch https://gerrit.fd.io/r/#/c/5411/
    (pmikus,
    15:28:36)
 
  - #5411 changes to QemuUtil do not work for perf
    phy environment (mackonstan1,
    15:31:41)
 
  - can't merge #5411 as it will break all perf phy
    vhost tests (mackonstan1,
    15:32:54)
 
 
- Test environment infra topics (mackonstan1, 15:34:09)
  - need to schedule installation of additional
    crypto HW cards into tb1,2. tb3 has the cards installed.
    (mackonstan1,
    15:36:37)
 
  - 8 cards total have been received - 8 x Walnut
    Hill Singles Quick-Assist Technology (QAT) (mackonstan1,
    15:37:24)
 
  - "lspci -vv" to get cards revision ….
    (mackonstan1,
    15:39:17)
 
  - need to verify capacity of these cards
    (mackonstan1,
    15:39:30)
 
 
- Performance tests (mackonstan1, 15:39:49)
  - Cryptodev lspci output in "IPsec Multi-Tunnel
    performance test suite" on csit-dev mailer (pmikus,
    15:40:48)
 
  - obvious candidates: enabling hyperthreading,
    snat, vhost usability list (mackonstan1,
    15:41:12)
 
 
- 1.	VPP functional tests - virl (mackonstan1, 15:42:31)
 
- VPP functional tests - virl (mackonstan1, 15:42:39)
  - obvious candidates: vhost usability list
    (mackonstan1,
    15:43:58)
 
  - need to added centos to performance
    tests (mackonstan1,
    15:46:01)
 
 
- vhost use cases (mackonstan1, 15:47:29)
  - follow up with email to contributors to reawake
    and finalize the list of vhost use cases for csit  rls 1704 and
    beyond (mackonstan1,
    15:47:58)
 
  - ACTION: tfherbert -
    send email csit-dev re vhost use cases for csit  rls 1704 and
    beyond (mackonstan1,
    15:48:48)
 
  - https://docs.fd.io/vpp/17.01/vpp_make_test/html/
    (tifrank,
    15:50:35)
 
 
- CSIT online docs (mackonstan1, 15:50:49)
  - https://docs.fd.io/vpp/17.01/vpp_make_test/html/
    (mackonstan1,
    15:51:07)
 
  - https://docs.fd.io/vpp/17.04/vpp_make_test/html/
    (mackonstan1,
    15:51:49)
 
 
Meeting ended at 15:56:00 UTC
(full logs).
Action items
  - tfherbert - send email csit-dev re vhost use cases for csit  rls 1704 and beyond
 
Action items, by person
  -  tfherbert 
    - tfherbert - send email csit-dev re vhost use cases for csit  rls 1704 and beyond
 
  
 
People present (lines said)
  - mackonstan1 (47)
 
  - pmikus (4)
 
  - collabot` (4)
 
  - selias (2)
 
  - tifrank (2)
 
  - tfherbert (1)
 
  - sgmonroy (1)
 
  - dwallacelf (1)
 
  - jgelety (1)
 
Generated by MeetBot 0.1.4.