#fdio-csit: VPP_Device Test Env. Design

Meeting started by mackonstan at 14:03:21 UTC (full logs).

Meeting summary

    1. call details https://zoom.us/j/921421203 (mackonstan, 14:03:40)
    2. Peter Mikus (pmikus1, 14:03:42)
    3. Sirshak Das (Sirshak, 14:06:51)
    4. Ed Kern (snergster, 14:06:53)

  1. new lab status (mackonstan, 14:12:56)
    1. LLD is updated on wiki (mackonstan, 14:13:04)
    2. https://wiki.fd.io/view/CSIT/fdio_csit_lab_ext_lld_draft (mackonstan, 14:13:20)
    3. Xeon testbeds are uptodate, Arm testbeds need updating (mackonstan, 14:16:27)
    4. ACTION: Sirshak to update “Testbeds_Type_Breakdown” for Arm. (mackonstan, 14:16:40)
    5. https://github.com/kata-containers/runtime (Sirshak, 14:30:37)
    6. re point 6. and 7. in proposed VPP_Device design - need to try nested VM-in-container, container-in-container (mackonstan, 14:33:43)
    7. ACTION: once 1-node testbeds are up, Ed to try nested VM-in-container, container-in-container (mackonstan, 14:34:31)
    8. back to VFs (mackonstan, 14:39:19)
    9. Peter: Need to work out the way to expose VFs to containers and a scheme (mackonstan, 14:39:23)
    10. Need to work out the way to expose VFs to containers and a scheme for deterministic mapping of VFs (coupled with dot1q tag on a wire) and SUT_container and TG_container. (mackonstan, 14:39:56)
    11. for more notes from the call see design tracking email on csit-dev: (mackonstan, 15:05:09)
    12. https://lists.fd.io/g/csit-dev/message/2807 (mackonstan, 15:06:02)


Meeting ended at 15:06:05 UTC (full logs).

Action items

  1. Sirshak to update “Testbeds_Type_Breakdown” for Arm.
  2. once 1-node testbeds are up, Ed to try nested VM-in-container, container-in-container


Action items, by person

  1. Sirshak
    1. Sirshak to update “Testbeds_Type_Breakdown” for Arm.


People present (lines said)

  1. mackonstan (19)
  2. collabot_ (5)
  3. Sirshak (2)
  4. snergster (1)
  5. pmikus1 (1)


Generated by MeetBot 0.1.4.