#fdio-csit: FD.io CSIT project meeting

Meeting started by mackonstan at 14:00:46 UTC (full logs).

Meeting summary

    1. Vratko Polak (vrpolak, 14:01:00)
    2. Tibor Frank (tifrank, 14:01:13)

  1. agenda bashing (mackonstan, 14:01:48)
    1. Dave Wallace (dwallacelf, 14:01:55)
    2. Jan Gelety (jgelety, 14:02:28)

  2. FD.io CSIT physical labs (mackonstan, 14:03:03)
    1. no issues with Xeon, ARM, Denverton testbed (mackonstan, 14:03:41)
    2. CLX machines - Peter - onboarded, and ready for service, initial dry run performance tests are running (mackonstan, 14:04:54)
    3. Peter - will send links to completed jenkins job lobs (mackonstan, 14:05:33)

  3. Inputs from LFN and FD.io projects - VPP (mackonstan, 14:06:03)
    1. Dave - v19.08.1 scheduled to be published (mackonstan, 14:06:48)
    2. Andrew - centos jobs were failing (mackonstan, 14:07:32)
    3. Andrew - memif zero-copy is now verifying, and should go in (mackonstan, 14:07:51)
    4. Andrew - v19.08.1 is special, one patch that changed API checksum, 2nd patch api types confusion also changing API checksum, plan is to put v19.08 artefacts into deferred directory in packagecloud (mackonstan, 14:10:28)
    5. Andrew - more cherry-picks coming to v19.08.1 (mackonstan, 14:12:17)
    6. Andrew - currently ~100 outstanding master patches to go into stable/1908 (mackonstan, 14:14:43)
    7. Andrew, Dave - how do we go about testing this (mackonstan, 14:15:11)
    8. Discussion - proposal to run trending jobs on stable/1908 (mackonstan, 14:22:11)
    9. ACTION: Maciek - propose the frequency of trending jobs on stable/1908, push patch to the job_specs file (mackonstan, 14:25:33)
    10. https://git.fd.io/csit/tree/docs/job_specs/perf_tests_job_specs.md#n90 (mackonstan, 14:25:36)

  4. Inputs from LFN and FD.io projects - TSC (mackonstan, 14:30:20)
    1. Vratko - new webpage approved (conditionally), to be enabled in production soon, Nexus issues to be resolved - Vanessa made a proposal (mackonstan, 14:31:12)

  5. Releases (mackonstan, 14:31:31)
    1. rls1908 latest .38 maintenance version to be published shortly (mackonstan, 14:32:41)
    2. https://docs.fd.io/csit/rls1908/report/ (mackonstan, 14:32:51)
    3. reconfig tests are experimental and we expect movement with results - to be run by vpp-dev (mackonstan, 14:39:14)
    4. https://docs.fd.io/csit/rls1908/report/vpp_performance_tests/reconf_tests/vnf_service_chains_reconf.html (mackonstan, 14:39:23)
    5. open issues - acl perf regression - Andrew looking at it (mackonstan, 14:40:44)
    6. open issues - acl perf regression - Andrew looking at it, with Vratko confirmed that reverting specific patch brings back the performance (mackonstan, 14:41:13)
    7. open issues - l2bd regression - OPEN (mackonstan, 14:41:25)
    8. CSIT-1908.1 report - what tests to run (mackonstan, 14:43:16)
    9. Maciek - proposal - usual baseline set + memif tests (due to "memif: always enable zero-copy when creating memif using AP" (mackonstan, 14:45:40)

  6. CSIT-2001 plan (mackonstan, 14:47:11)
  7. Operational status (mackonstan, 14:47:57)
    1. LF infra - Nexus issues - EdK - IT team/Vanessa adding faster disks to address connectivity outages (mackonstan, 14:48:41)
    2. https://jira.linuxfoundation.org/servicedesk/customer/portal/2/IT-17595 (mackonstan, 14:49:35)

  8. Centos CI (mackonstan, 14:53:02)
    1. Peter - problem with running container in Centos. Need help from Thomas F. Herbert, need to ping him. (mackonstan, 14:53:46)

  9. VPP code performance (mackonstan, 14:56:45)
    1. some tests failing - 3 known issues apply - resolution WIP (mackonstan, 14:57:12)

  10. Developments (mackonstan, 14:57:32)
    1. VAT to PAPI - Jan - only policer left - some incompatibility between VAT and PAPI - resolving with Ole (mackonstan, 14:58:06)
    2. PAPI scale test - Vratko - still WIP - changes improve the situation but tests still failing (mackonstan, 14:58:43)
    3. CSIT migration to Python 3+ - Jan - proposal by eow (mackonstan, 15:00:06)


Meeting ended at 15:00:32 UTC (full logs).

Action items

  1. Maciek - propose the frequency of trending jobs on stable/1908, push patch to the job_specs file


People present (lines said)

  1. mackonstan (43)
  2. collabot` (4)
  3. vrpolak (1)
  4. dwallacelf (1)
  5. jgelety (1)
  6. tifrank (1)


Generated by MeetBot 0.1.4.