#fdio-csit: FD.io CSIT project meeting

Meeting started by vrpolak at 14:52:11 UTC (full logs).

Meeting summary

    1. HELP: chair (vrpolak, 14:52:47)
    2. Vratko Polak. (vrpolak, 15:02:38)
    3. Dave Wallace (dwallacelf, 15:04:01)

  1. Agenda bashing (mackonstan, 15:04:52)
  2. VPP updates (mackonstan, 15:08:46)
    1. Dave: v19.04.3 published, need to plan for maintenance testing. (mackonstan, 15:09:10)
    2. Maciek: Jan generated a summary of all lab infra resources used for 19.08.1 maintenance testing. Partially processed it, will send readout to csit-dev. (mackonstan, 15:09:16)
    3. DaveW: v19.08.2 - no plan yet (mackonstan, 15:09:34)

  3. TSC updates (mackonstan, 15:09:58)
    1. Maciek: on the last call discussed issues with Nexus storage backend, Vanessa proposed live t/shooting session. So far issue hasn't reappeared since last Thursday, so keep monitoring. (mackonstan, 15:16:03)
    2. Maciek: Ray continues to lead the resolution of Scapy licensing issues. (mackonstan, 15:16:24)

  4. HC (mackonstan, 15:16:59)
    1. Maciek: on one of the last few calls we have agreed to remove HC test code from CSIT repo, as it's out of sync with CSIT-1908 and VPP v19.08. Raising it here again, to capture what exactly needs to be done and who will do it. (mackonstan, 15:18:06)
    2. ACTION: Maciek, Peter, Vratko: push a patch capturing all required changes. (mackonstan, 15:20:10)

  5. Releases CSIT-2001 (mackonstan, 15:21:20)
    1. wiki updated (mackonstan, 15:21:25)
    2. https://wiki.fd.io/view/CSIT/csit2001_plan (mackonstan, 15:21:33)

  6. Releases CSIT-1908 (mackonstan, 15:22:11)
    1. Maciek: need to track status of open issues - will send email on csit-dev + vpp-dev with current status and ask for comments. (mackonstan, 15:22:39)

  7. Operational status (mackonstan, 15:23:00)
    1. Upgrades last week - seem to have gone smoothly (mackonstan, 15:23:25)
    2. API test coverage - Vratko - yaml file capturing the delta updated (mackonstan, 15:25:34)
    3. File with comments on API coverage us up-to-date: resources/api/vpp/supported_crcs.yaml (vrpolak, 15:25:55)
    4. Vratko: many tests failing in 2n-tsh, due to timing, CSIT w/a to skip papi checks (show ver, … ) as these are failing by making vpp crash. Not easily reproducible. Looking to nail it and run it by vpp-dev (mackonstan, 15:28:22)

  8. VPP code performance (vrpolak, 15:29:22)
    1. trending e-mails contain occasional regression, Vratko thinks they are just noise. (vrpolak, 15:30:57)

  9. Developments (vrpolak, 15:31:45)
    1. Vratko works on suite generator. (vrpolak, 15:33:43)
    2. No big news on other developments. (vrpolak, 15:33:58)


Meeting ended at 15:34:30 UTC (full logs).

Action items

  1. Maciek, Peter, Vratko: push a patch capturing all required changes.


People present (lines said)

  1. mackonstan (24)
  2. vrpolak (11)
  3. collabot (4)
  4. dwallacelf (1)


Generated by MeetBot 0.1.4.