#fdio-csit: FD.io CSIT project meeting

Meeting started by mackonstan at 15:01:58 UTC (full logs).

Meeting summary

    1. Jan Gelety (jgelety, 15:02:48)

  1. Agenda bashing (mackonstan, 15:02:53)
    1. Tibor Frank (tifrank, 15:03:49)

  2. FD.io CSIT physical labs (mackonstan, 15:04:04)
    1. Peter: faulty SSDs replaced. (mackonstan, 15:05:05)

  3. Inputs from LFN and FD.io projects (mackonstan, 15:05:18)
    1. VPP: requirement to regularly test stable/1908 (LTS release), weekly tests with the same set as daily trending on master (mackonstan, 15:14:00)
    2. Dave Wallace (dwallacelf, 15:14:14)
    3. ACTION: Jan/Maciek: push patch with update job_specs to this effect (also update the spec with current state of affairs for trending tests - daily, weekly) (mackonstan, 15:14:45)
    4. https://git.fd.io/csit/tree/docs/job_specs/perf_tests_job_specs.md (mackonstan, 15:14:48)
    5. Dave W: no updates on 1908.2 (mackonstan, 15:16:21)

  4. Releases CSIT-1908 (mackonstan, 15:16:59)
  5. Release CSIT-2001 (mackonstan, 15:18:35)
  6. Operational status (mackonstan, 15:19:00)
    1. Peter: servers losing mgmt ip addresses - see ticket (mackonstan, 15:22:36)

  7. Operational status (mackonstan, 15:23:43)
    1. vpp-csit-device tests not voting (mackonstan, 15:24:12)
    2. Vratko: two blockers for enabling voting: i) 10%-20% failure rate of AVF tests; ii) no process for failing tests, needs to be added (Vratko to do for CSIT-2001). (mackonstan, 15:32:35)
    3. Centos tests in vpp_device - not running today, work needed to get them to work (mackonstan, 15:35:32)

  8. VPP code performance (mackonstan, 15:36:32)
    1. daily trending failures: (mackonstan, 15:36:42)
    2. l2patch tests - vpp ticket open (mackonstan, 15:37:17)
    3. gbp - csit issue - fixed now (mackonstan, 15:37:43)
    4. ipsec - see latest patch from Neale breaking the tests (mackonstan, 15:38:07)
    5. srv6proxy - failing due to memif issue, to be investigated (mackonstan, 15:38:45)
    6. 3n-tsh - lots of tests failing - Vratko - will run auto-bisect to find the bad patch (mackonstan, 15:42:30)

  9. Migrating to Python 3.x (mackonstan, 15:43:13)
    1. Jan update: proposal is in final review, plan is to freeze branch next week and do the migration in one go (mackonstan, 15:43:43)
    2. main proposal (mackonstan, 15:44:29)
    3. https://gerrit.fd.io/r/c/csit/+/22638 (mackonstan, 15:44:31)
    4. infra patch (mackonstan, 15:44:40)
    5. https://gerrit.fd.io/r/c/csit/+/23207 (mackonstan, 15:45:50)
    6. Jan will send email summary with the current split of work (mackonstan, 15:51:20)

  10. Deprecating tests: HoneyComb, DMM, NSH_SFC, TLDK, Ligato (mackonstan, 15:52:30)
    1. Peter: pushed patches for HoneyComb, Ligato (mackonstan, 15:53:11)
    2. Vratko: will push patch for removing TLDK (mackonstan, 15:53:49)
    3. Jan/Tibor: will take care of patches to remove DMM and NSH_SFC (mackonstan, 15:54:32)

  11. New tests (mackonstan, 15:55:05)
    1. Improving API functional test coverage - Nidhy: adding tests for ACL LIST APIs. (mackonstan, 15:58:39)


Meeting ended at 16:00:29 UTC (full logs).

Action items

  1. Jan/Maciek: push patch with update job_specs to this effect (also update the spec with current state of affairs for trending tests - daily, weekly)


People present (lines said)

  1. mackonstan (39)
  2. collabot (4)
  3. tifrank (1)
  4. jgelety (1)
  5. dwallacelf (1)


Generated by MeetBot 0.1.4.