#fdio-csit: FD.io CSIT project meeting

Meeting started by mackonstan at 14:58:32 UTC (full logs).

Meeting summary

    1. Vratko Polak. (vrpolak, 14:58:43)
    2. Tibor Frank (tifrank, 14:58:51)
    3. Peter Mikus (pmikus, 14:59:31)
    4. Jan Gelety (jgelety, 15:00:05)

  1. Agenda bashing (mackonstan, 15:00:25)
    1. Dave Wallace (dwallacelf, 15:01:33)
    2. Juraj Linkeš (jlinkes, 15:03:10)

  2. Physical labs, testbeds (mackonstan, 15:03:14)
    1. Peter: fixed memory on one of the vpp device testbeds. (mackonstan, 15:04:29)

  3. Inputs from projects - VPP (mackonstan, 15:05:08)
  4. TSC (mackonstan, 15:05:34)
    1. Vratko: ongoing discussion about developer centric meeting, preference for collocating with another data plane centric event (mackonstan, 15:06:08)

  5. CNCF CNF Testbed (mackonstan, 15:06:19)
    1. Peter: CNF Testbed project is working on some papers about deployment guidelines; some progress with NSM integration with VPP; looking to standardise on unprivileged container with VPP that is now supported, work to be scheduled. (mackonstan, 15:08:36)

  6. Releases CSIT-1908 maintenance (mackonstan, 15:09:22)
    1. still need to execute on last week action Maciek/Jan took re LTS weekly trending tests (mackonstan, 15:10:46)
    2. will be captured in a patch modifying this spec: (mackonstan, 15:11:16)
    3. https://git.fd.io/csit/tree/docs/job_specs/perf_tests_job_specs.md (mackonstan, 15:11:18)
    4. ACTION: Maciek: need to revise known open issues from csit-1908 and report (mackonstan, 15:12:19)
    5. need for an interim rc0 20.01 report generation with data to get a report like view for vpp and csit (mackonstan, 15:15:12)
    6. looking to do this post python 3 migration, and before xmas, i.e. 1st or 2nd week of December (mackonstan, 15:15:39)

  7. Operations (mackonstan, 15:15:52)
    1. Centos CI - Peter - working on it with Ed, making progress. Will require updating to python 3. Additional cost of maintaining Centos. (mackonstan, 15:17:52)
    2. Peter: suggest to have a broader discussion at FD.io level about ongoing Centos maintenance. (mackonstan, 15:18:41)

  8. VPP code performance (mackonstan, 15:19:13)
    1. reviewing latest summary email report "[csit-report] Failed tests as of 2019-11-19 02:00:07 UTC #email" on csit-report. (mackonstan, 15:24:49)

  9. Developments (mackonstan, 15:28:26)
    1. Migration to Python 3.x - Jan reporting (mackonstan, 15:30:53)
    2. Python libraries are 70% complete, expecting dev complete by Friday AM, testing starts then (mackonstan, 15:31:24)
    3. PAL - Tibor - on target for completion by eow (mackonstan, 15:32:04)
    4. optimistic scenario - unfreeze csit master on Monday 25-Nov, less optimistic few days later (mackonstan, 15:33:17)
    5. Peter: removed HC, Ligato. (mackonstan, 15:35:40)
    6. Tibor: removing DMM, NSH_SFC. (mackonstan, 15:35:59)
    7. Vratko: looking to remove TLDK. (mackonstan, 15:37:04)

  10. Performance trending and analytics (mackonstan, 15:40:35)
    1. Tibor: refreshed trending pages aligned with report test coverage and graph presentation, results available in html in cisco lab sandbox and in code form in fd.io gerrit (mackonstan, 15:43:25)

  11. New tests (mackonstan, 15:44:00)
    1. Vratko: updated suite generator, supports now multiple drivers per nic, need to update test selectors for daily trending and for report (mackonstan, 15:45:17)
    2. ACTION: Jan/Vratko/Maciek update the tag expression files and and job specs files (mackonstan, 15:46:08)
    3. Nidhy: adding more tests for vpp-device to increase API coverage (mackonstan, 15:48:22)


Meeting ended at 15:49:37 UTC (full logs).

Action items

  1. Maciek: need to revise known open issues from csit-1908 and report
  2. Jan/Vratko/Maciek update the tag expression files and and job specs files


People present (lines said)

  1. mackonstan (37)
  2. collabot (4)
  3. pmikus (1)
  4. vrpolak (1)
  5. jgelety (1)
  6. dwallacelf (1)
  7. jlinkes (1)
  8. tifrank (1)


Generated by MeetBot 0.1.4.