#fdio-csit: FD.io CSIT project meeting

Meeting started by mackonstan at 15:00:52 UTC (full logs).

Meeting summary

    1. Jan Gelety (jgelety, 15:01:14)
    2. Tibor Frank (tifrank, 15:01:16)
    3. Vratko Polak. (vrpolak, 15:01:17)

  1. Agenda bashing (mackonstan, 15:01:38)
  2. Physical labs, testbeds (mackonstan, 15:03:14)
    1. Ed - vpp-csit-api-crc job failures for not API changing patches. Vratko following up on it. (mackonstan, 15:10:56)
    2. https://gerrit.fd.io/r/c/vpp/+/22698 <-- This got fake +1 due to naginator, and merge broke crc checks. (vrpolak, 15:12:42)
    3. Peter - re 19.08 LTS tests - issue with re-provisioning the testbeds, as the execution environment has changed e.g. moved from Python 2.7 to 3.x. (mackonstan, 15:14:59)
    4. Peter - will start email thread on csit-dev (mackonstan, 15:17:56)

  3. Inputs from projects (mackonstan, 15:23:23)
    1. TSC - Vratko reporting - lab access discussion, fd.io dev event co-located with dpdk dev event in Bordeaux in Sep/Oct. (mackonstan, 15:25:17)

  4. Release CSIT-2001 (mackonstan, 15:25:30)
    1. Jan - testing - finished performance selected for repeatibility on 2n-dnv (10/10), 3n-dnv (10/10), tsh (8/10), 2n-clx (5/10, 3 running ETA Fri). (mackonstan, 15:28:35)
    2. Jan - testing - complete set of performance tests: 2n-clx number of AVF xxv710 tests are failing (link down on TRex) and RDMA cx553a 9000B tests failing (due to TRex crash). (mackonstan, 15:31:23)
    3. Jan - testing - 2n-clx AVF xxv710 tests failures (link down on TRex) are observed for ip4 tests only (mackonstan, 15:34:02)
    4. Report content & generation - Tibor - update re latest working version on master, added test data, bug fixes. (mackonstan, 15:38:55)
    5. Report - Tibor - hoststack tests static content and rendering code in gerrit under review, reconfig and soak tests need 2n-skx testbeds (will be available after ucode issue is resolved). (mackonstan, 15:40:38)
    6. Skx tests - Maciek - based on the discussion on this call, we are shooting to release 2n-skx and 3n-skx test results by 11-Mar, 2 weeks from now, following investigation with Intel. (mackonstan, 15:45:02)

  5. Release CSIT-1908 (mackonstan, 15:45:20)
    1. CSIT needs to test VPP stable/1908 - dependency on resolving the environment dependencies as noted earlier on this call by Peter. (mackonstan, 15:46:34)
    2. CSIT-1908 maintenance should have a list of tests specified ahead of time, should be aligned with 19.08.1. (mackonstan, 15:48:13)
    3. ACTION: Jan, Maciek to review the 19.08.1 test list, and produce a list for 19.08.2 (mackonstan, 15:48:39)

  6. Operations (mackonstan, 15:49:03)
    1. Peter - we would need to upgrade all skx machines to specific BIOS version once ucode issue resolution and recommendation comes from Intel. This takes a day to notify Vexxhost on-site team, and a day to upgrade all machines (14 skx hosts). (mackonstan, 15:50:47)
    2. Govind - kernel -72 includes spectre-meltdown fixes but no performance micro-code updates. Recommendation is to move. Peter and Juraj will coordinate the kernel upgrade. (mackonstan, 15:55:08)

  7. VPP code performance (mackonstan, 15:55:18)
    1. Peter - number of issues with AVF initialisation, investigating. (mackonstan, 15:58:04)
    2. Vratko - investigating stdev increase observed for vhost tests due to different vhost rxq to worker placement. (mackonstan, 16:00:21)


Meeting ended at 16:01:26 UTC (full logs).

Action items

  1. Jan, Maciek to review the 19.08.1 test list, and produce a list for 19.08.2


People present (lines said)

  1. mackonstan (26)
  2. collabot` (3)
  3. vrpolak (2)
  4. tifrank (1)
  5. jgelety (1)


Generated by MeetBot 0.1.4.