#fdio-meeting: TSC Weekly Meeting

Meeting started by edwarnicke at 16:01:00 UTC (full logs).

Meeting summary

  1. Rollcall (edwarnicke, 16:01:05)
    1. edwarnicke (edwarnicke, 16:01:07)
    2. joelhalpern (joelhalpern, 16:01:22)
    3. Dave Barach voting present... (:-)... (DaveBarach, 16:02:41)
    4. https://wiki.fd.io/view/TSC#Agenda <- Agenda (edwarnicke, 16:02:56)

  2. Agenda Bashing (edwarnicke, 16:05:11)
    1. DaveBarach suggests talking about initial Release (edwarnicke, 16:06:32)

  3. Mature Release Process Mechanics (edwarnicke, 16:07:08)
    1. ACTION: EAW to fix release template table formatting (DaveBarach, 16:12:49)
    2. add to future agenda setting up security response team and process (edwarnicke, 16:15:34)
    3. (Venky, 16:17:01)
    4. projects encouraged to invite TSC to per-project release reviews (DaveBarach, 16:18:00)
    5. Venky (Venky, 16:18:12)
    6. there is another meeting named fdio-meeting that I hope people don't join by mistake (Venky, 16:19:10)
    7. VOTE: Voted on "to accept the Mature Release Process details:https://wiki.fd.io/view/Mature_Release_Process ?" Results are, +1: 4 (edwarnicke, 16:21:44)
    8. AGREED: to accept https://wiki.fd.io/view/Mature_Release_Process (edwarnicke, 16:21:56)

  4. Release conversation (edwarnicke, 16:23:48)
    1. DaveBarach opines that we want to solidify our CSIT ( Continuous System and Integration Testing) up first, and get our packages for upstream right before VPP releases (edwarnicke, 16:24:38)
    2. DaveBarach suggests spinning releases 4-6 weeks behind DPDK (edwarnicke, 16:25:08)
    3. DPDK releases are now Year.Month , next two are 16.04 and 16.07 (keith_wiles, 16:25:55)
    4. https://wiki.fd.io/view/VPP/Meeting#2016-02-23 <- Meeting minutes for VPP meeting where Releases were discussed (edwarnicke, 16:25:56)
    5. DaveBarach mentioned setting things up to consume DPDK RCs (edwarnicke, 16:26:14)
    6. Venky suggests looking at baseline performance to look for regressions (edwarnicke, 16:26:39)
    7. DaveBarach and Venky discuss mempool details (edwarnicke, 16:27:45)
    8. Venky mentions support for external mempools, functions that get called on allocate/deallocate (edwarnicke, 16:28:12)
    9. Venky mentions a stacking mempool instead of a ring mempool (edwarnicke, 16:28:34)


Meeting ended at 16:29:56 UTC (full logs).

Action items

  1. EAW to fix release template table formatting


People present (lines said)

  1. edwarnicke (29)
  2. collabot` (10)
  3. Venky (4)
  4. DaveBarach (4)
  5. keith_wiles (3)
  6. joelhalpern (2)
  7. dfarrell07 (1)


Generated by MeetBot 0.1.4.