#fdio-meeting: 161207 TWS vHost user test scenarios for CSIT

Meeting started by mackonstan at 17:06:47 UTC (full logs).

Meeting summary

    1. ppfister (ppfister, 17:07:34)
    2. bmcfall (BillyM, 17:07:59)
    3. mackonstan - updating wiki page to reflect the discussion and consensus on TWS call (mackonstan, 17:11:35)
    4. https://wiki.fd.io/view/CSIT/vhostuser_test_scenarios (mackonstan, 17:11:45)
    5. Alec_ Alec Hothan (mackonstan, 17:12:06)
    6. Alec walking thru three main points raised on [csit-dev] to reflect most common OpenStack NFV deployments (mackonstan, 17:12:59)
    7. https://lists.fd.io/pipermail/csit-dev/2016-November/001259.html (mackonstan, 17:14:41)

  1. 2p1nic vs 1p1nic (mackonstan, 17:14:54)
    1. Alec - proposal to add 1p1nic topologies (mackonstan, 17:15:08)
    2. OpenStack ML2/VPP/VLAN will use dot1q-l2bdbase-eth-2vhost-1vm (mackonstan, 17:15:18)
    3. OpenStack ML2/VPP/VLAN will use dot1q-l2bdbase-eth-2vhost-1vm (mackonstan, 17:15:22)
    4. adding following baseline topologies (mackonstan, 17:21:17)
    5. 1p1nic-dot1q-l2bdbase-eth-2vhost-1vm (mackonstan, 17:21:28)
    6. *** 1p1nic-ethip4vxlan-l2bdbase-eth-2vhost-1vm (mackonstan, 17:22:06)
    7. scale topology cases: 2p1nic-ethip4vxlan-l2bdscale-<n>flows-eth-<m>vhost-<o>vm-parallel (mackonstan, 18:11:21)
    8. ACTION: All - to agree on the most applicable combinations of <n>, <m>,<o> (mackonstan, 18:11:43)
    9. scale topology cases: 2p1nic-ethip4vxlan-l2bdscale-<n>flows-eth-<m>vhost-<o>vm-chain (mackonstan, 18:12:04)
    10. ACTION: All - to agree on the most applicable combinations of <n>, <m>,<o> for VM chains (mackonstan, 18:12:33)
    11. ACTION: Irene_ - working on optimizing and tuning testpmd in VM to work with 2vCPUs - 1vCPU for main testpmd app, and 1vCPU for pmd threads. Expecting progress on this next week, will send email to [csit-dev]. (mackonstan, 18:13:19)
    12. need to standardize on testpmd startup parameters (mackonstan, 18:13:48)
    13. ACTION: Irene: will send list of parameters optimized for using vpmd with virtio, and script examples (mackonstan, 18:13:57)
    14. review and update (nested) VM image building for vhost tests - starting point being existing CSIT VM image building: Ubuntu, Centos (mackonstan, 18:14:43)
    15. ACTION: team of volunteers (?): Carsten, PMikus, Alec, Thomas, Irene, Maciek (mackonstan, 18:14:53)
    16. Thomas - For baselining the system - Replace VPP with 2x testpmd for xconnecting 2x Phy-to-Vhost (mackonstan, 18:15:23)
    17. requires a new DPDK patch for enabling vhost in testpmd - <add-link> (mackonstan, 18:15:35)
    18. Irene currently testing manually in Intel labs - can help with onboarding into CSIT. (mackonstan, 18:16:21)
    19. All agreed to cover remaining open points and details over email thread on csit-dev. No need for another TWS call. Will be tracking progress and coordinating using CSIT comms means: csit-dev@lists.fd.io, #fdio-csit, CSIT weekly calls every Wednesday. Maybe another technical TWS call in January per Thomas suggestion. (mackonstan, 18:18:28)
    20. current consensus captured on this wiki page that got updated during this TWS meeting: (mackonstan, 18:19:00)
    21. https://wiki.fd.io/view/CSIT/vhostuser_test_scenarios (mackonstan, 18:19:08)
    22. https://lists.fd.io/pipermail/csit-dev/ (mackonstan, 18:19:33)
    23. https://wiki.fd.io/view/IRC (mackonstan, 18:19:42)
    24. https://wiki.fd.io/view/CSIT/Meeting (mackonstan, 18:19:58)
    25. thanks to All for contributions: Alec Hothan, Billy McFall, Irene Liew, Pierre Pfister, Thomas F Herbert, Maciek Konstantynowicz. (mackonstan, 18:21:07)


Meeting ended at 18:21:10 UTC (full logs).

Action items

  1. All - to agree on the most applicable combinations of <n>, <m>,<o>
  2. All - to agree on the most applicable combinations of <n>, <m>,<o> for VM chains
  3. Irene_ - working on optimizing and tuning testpmd in VM to work with 2vCPUs - 1vCPU for main testpmd app, and 1vCPU for pmd threads. Expecting progress on this next week, will send email to [csit-dev].
  4. Irene: will send list of parameters optimized for using vpmd with virtio, and script examples
  5. team of volunteers (?): Carsten, PMikus, Alec, Thomas, Irene, Maciek


People present (lines said)

  1. mackonstan (34)
  2. collabot` (4)
  3. BillyM (1)
  4. ppfister (1)


Generated by MeetBot 0.1.4.