#fdio-vpp: VPP

Meeting started by alagalah at 15:02:14 UTC (full logs).

Meeting summary

    1. alagalah #link https://www.youtube.com/watch?v=StTqXEQ2l-Y (alagalah, 15:02:21)

  1. CSIT (alagalah, 15:02:29)
    1. mackonstan1 states that he needs min. 3 CSIT Perf Runs to get results cIST needs (alagalah, 15:02:53)
    2. this will take 3 days (target Thu) barring infra incident (alagalah, 15:03:13)
    3. draft 16.09 CSIT perf report should be available weds-thurs (DaveBarach, 15:03:13)
    4. DaveBarach asks for diff between 16.06 v 16.09 performance (alagalah, 15:04:16)
    5. mackonstan1 16.09 for IPv6 from 8-10Mpps to 10-12 Mpps core XL520 but don't have XL710 ... (alagalah, 15:05:05)
    6. CPU not that relevant as its comparative on same baseline... but normally one would quote the CPU specs (alagalah, 15:05:25)

  2. Honeycomb (alagalah, 15:06:06)
    1. marek gradzki reports that infra issues they were experiencing yesterday appear to have alleviated... so can plan for release tomorrow... needs NSH JAR (alagalah, 15:06:45)
    2. edwarnicke NSH_SFC 16.09 JAR is being pushed into the repo (LF Infra). (alagalah, 15:07:04)
    3. thanks to Ed for a variety of infra work (DaveBarach, 15:08:06)
    4. hongjun will be testing nsh/sfc artifacts (DaveBarach, 15:09:12)
    5. work w/ honeycomb on l2 integration (DaveBarach, 15:10:58)
    6. demo app gui pushed [thanks to Arris] (DaveBarach, 15:12:28)

  3. TLDK (alagalah, 15:14:40)
    1. edwarnicke reports patches coming soon, project is moving forward (alagalah, 15:14:54)

  4. DPDK Deb packaging (alagalah, 15:15:04)
    1. edwarnicke folks are contributing but I must admit I missed the comment completely (alagalah, 15:15:19)

  5. re-hash of Pierre's work with vhost-user (alagalah, 15:15:33)
    1. ray asks about more context as the DPDK folks are also testing (alagalah, 15:15:45)
    2. deb_dpdk project is setting up jenkins jobs for verify and merge (edwarnicke, 15:15:53)
    3. dmarion reports that they are testing and optimising the exiting vpp vhost implementation (alagalah, 15:16:11)
    4. ray reports that some DPDK folks are testing/coding to modify DPDK vhost-user with a goal of deprecating VPP vhost-user (alagalah, 15:16:45)
    5. ray asks if there can be a meeting regarding the direction of VPP and DPDK vhost-user to co-ordinate resource efforts (alagalah, 15:17:36)
    6. DaveBarach points out that converged effort makes sense, but need to ensure that there's communication. ie last release vhost-user implementation in DPDK was a bit of a surprise. Ray agrees, lesson learned, and we should now co-ordinate... (alagalah, 15:19:14)
    7. Agreed that there should be a more co-ordinated effort. (alagalah, 15:19:34)
    8. but ultimately we agree that we should converge to upstream DPDK providing vhost-user, don't we? (tfherbert, 15:21:27)
    9. ACTION: DaveBarach and ray to organise a follow up call re: vhost-user in VPP and DPDK (alagalah, 15:23:00)

  6. FIB2.0 (alagalah, 15:26:39)
    1. Neale making progress on API changes to things relying on existing FIB... but he is traveling on business next week ... (alagalah, 15:27:07)
    2. dmarion says his preference this patch goes in sooner rather than later (not clear as to who needs this in now?) but ... (alagalah, 15:27:43)
    3. DaveBarach suggests that we have a follow up meeting or make a decision as to merge before Neale goes on biz travel... or after.... (alagalah, 15:28:12)
    4. Decided that patch will be merged after short-perf-run (alagalah, 15:32:31)

  7. fdio mini-summit (alagalah, 15:47:26)
    1. Chrisy is going... that is all... carry on :) (alagalah, 15:47:37)
    2. Register soon! (alagalah, 15:47:40)

  8. Release NEXT (alagalah, 15:49:46)
    1. dmarion is release manager for "17.01" ... discussing 16.12 v 17.01 (alagalah, 15:50:07)
    2. general discussion last week was 17.01 makes more sense from a risk perspective than 16.12 since DPDK 16.11 is a target dependency... and there is typical Christmas slowdown/shutdown (alagalah, 15:50:37)
    3. https://wiki.fd.io/view/Projects/vpp/Release_Plans/Release_Plan_17.01 Proposed Release Plan (alagalah, 15:51:02)

  9. Docs (alagalah, 15:53:05)
    1. https://docs.fd.io/vpp/16.09/ Docs (alagalah, 15:54:11)


Meeting ended at 16:02:36 UTC (full logs).

Action items

  1. DaveBarach and ray to organise a follow up call re: vhost-user in VPP and DPDK


Action items, by person

  1. DaveBarach
    1. DaveBarach and ray to organise a follow up call re: vhost-user in VPP and DPDK


People present (lines said)

  1. alagalah (48)
  2. DaveBarach (12)
  3. collabot (4)
  4. Chrisy (1)
  5. edwarnicke (1)
  6. tfherbert (1)


Generated by MeetBot 0.1.4.