#fdio-vpp: fdio vpp

Meeting started by DaveBarach at 14:59:53 UTC (full logs).

Meeting summary

    1. Dave Wallace (dwallacelf, 15:00:18)

  1. Maciek reporting on CSIT (DaveBarach, 15:01:41)
    1. in the process of upgrading to Ubuntu 16.04 (DaveBarach, 15:01:54)
    2. hoping to switch to 16.04 to production tomorrow (DaveBarach, 15:02:31)
    3. operating at reduced capacity due to upgrade, patience requested (DaveBarach, 15:02:56)
    4. unit test framework draft in Gerrit (damjan reporting) (DaveBarach, 15:03:45)
    5. TFHerbert (tfherbert, 15:03:46)
    6. doxygen issues w/ Python code (DaveBarach, 15:04:24)
    7. looking for agreement on how to document tests (DaveBarach, 15:05:16)
    8. Chris says "doxygen wasn't designed for Python" (DaveBarach, 15:05:36)
    9. looks like Sphinx is the cool kid for Python API documentation (edwarnicke, 15:09:10)
    10. and there are some rumblings about getting Sphinx and doxygen to play nice (edwarnicke, 15:09:28)
    11. Take discussion to the "discuss" list. (DaveBarach, 15:09:56)
    12. dpdk uses Sphinx (DaveBarach, 15:10:25)

  2. Marek Gradzki on Honeycomb (DaveBarach, 15:10:43)
    1. infra issues largely resolved (DaveBarach, 15:11:21)
    2. snat support in review (DaveBarach, 15:11:26)

  3. Keith Burns NSH/SFC report (DaveBarach, 15:11:48)
    1. trying to move the project call (DaveBarach, 15:12:01)
    2. Classifier discussions, would like to tie into vpp policy epic (DaveBarach, 15:12:21)
    3. multiple policy efforts, would like to unify as best we can (DaveBarach, 15:12:44)
    4. need to sort out CSIT (DaveBarach, 15:12:59)

  4. Florin reports on ONE-LISP (DaveBarach, 15:13:12)
    1. fixing APIs for HC (DaveBarach, 15:13:20)
    2. ODL integration in process, should complete soon (DaveBarach, 15:13:46)
    3. integration more complicated than originally anticipated (DaveBarach, 15:14:04)
    4. no sandbox report this week (DaveBarach, 15:14:22)

  5. Keith Wiles reporting on TLDK (DaveBarach, 15:14:39)
    1. code push this week, meeting tomorrow at normal time (DaveBarach, 15:14:50)

  6. Ed reporting on DPDK packaging (DaveBarach, 15:15:20)
    1. polishing packages (DaveBarach, 15:15:32)

  7. RPM packaging Tom Herbert reporting (DaveBarach, 15:16:06)
    1. working on vpp packaging for CentOS (DaveBarach, 15:16:20)
    2. various changes required to upstream, mostly minor by the sound of it (DaveBarach, 15:17:08)
    3. need source RPM, diffs, build-from-scratch from .gzip file (DaveBarach, 15:18:34)

  8. LF infra status, Ed reporting (DaveBarach, 15:20:29)
    1. ssh timeouts resolved by turning on tcp keepalives (DaveBarach, 15:22:55)
    2. ed monitoring job queues (DaveBarach, 15:22:56)
    3. Honeycomb merge job failures under investigation (DaveBarach, 15:22:57)

  9. Damjan on 17.01 release planning (DaveBarach, 15:23:03)
    1. ACTION: dbarach to update doc wiki on minor poit (DaveBarach, 15:24:02)
    2. new global functions, CLI commands, VLIB_CONFIG_FUNCTIONs all need doc strings (DaveBarach, 15:26:09)
    3. Chris working on straightening out Coverity run (DaveBarach, 15:28:28)

  10. Consumability (DaveBarach, 15:31:40)
    1. Ed trying to switch to more automated infra monitoring (DaveBarach, 15:32:06)
    2. if you remove fd.io jjb and +1 verify a patch, the merge job report won't happen (DaveBarach, 15:33:13)


Meeting ended at 15:34:24 UTC (full logs).

Action items

  1. dbarach to update doc wiki on minor poit


People present (lines said)

  1. DaveBarach (44)
  2. collabot (3)
  3. edwarnicke (2)
  4. tfherbert (1)
  5. dwallacelf (1)


Generated by MeetBot 0.1.4.