#fdio-vpp: fdio vpp

Meeting started by DaveBarach at 16:00:57 UTC (full logs).

Meeting summary

    1. Tom Herbert (tfherbert, 16:01:11)

  1. Jan G reporting on CSIT (DaveBarach, 16:03:47)
    1. working on "make test" (DaveBarach, 16:03:55)

  2. Marek Gradzki on Honeycomb (DaveBarach, 16:05:37)
    1. API freeze last week (DaveBarach, 16:05:43)
    2. RC1 in ~2 weeks (DaveBarach, 16:05:49)
    3. ACL plugin support should be there (DaveBarach, 16:05:58)
    4. Ed describing honeycomb branch pull in general (DaveBarach, 16:08:40)
    5. ACTION: marek to ping Ed Warnicke offline (DaveBarach, 16:08:48)
    6. ACTION: Damjan to work with Ed on vpp RC1 throttle pull mechanics (DaveBarach, 16:10:32)

  3. no NSH/SFC report (DaveBarach, 16:11:30)
  4. Florin reports on ONE-LISP (DaveBarach, 16:11:41)
    1. not much to report, bugfixes, everything OK (DaveBarach, 16:11:48)

  5. sandbox no report Pierre not on call (DaveBarach, 16:12:02)
  6. TLDK Dave B reporting (DaveBarach, 16:12:32)
  7. DPDK packaging Tom H reporting (DaveBarach, 16:18:52)
    1. working on CentOS virl image (DaveBarach, 16:19:03)
    2. work out details w.r.t. patches, what happens in fd.io repo vs. CentOS repo (DaveBarach, 16:19:32)
    3. hope to resolve questions by 1/1 (DaveBarach, 16:19:43)

  8. Ed reporting on LF infra (DaveBarach, 16:20:15)
    1. switchover to packer took longer than expected (DaveBarach, 16:20:48)
    2. things actually have gone smoothly, back working now (DaveBarach, 16:22:32)

  9. Damjan on 17.01 release planning (DaveBarach, 16:23:28)
    1. everything on track for the RC1 pull (DaveBarach, 16:26:09)
    2. backlog of commits to go into master after the release throttle pull (DaveBarach, 16:26:29)
    3. ACTION: Jan G to work with Damjan on csit for 17.01 release throttle (DaveBarach, 16:29:28)
    4. Damjan describes MAINTAINERS file approach (DaveBarach, 16:30:51)
    5. area experts to provide +1 prior to patch merge (DaveBarach, 16:31:09)
    6. https://wiki.fd.io/view/VPP/Committers/SMEs (DaveBarach, 16:35:55)
    7. ACTION: Damjan to email dev list on MAINTANERS file or other scheme to endure timely patch reviews (DaveBarach, 16:41:09)

  10. "make test" (DaveBarach, 16:41:44)
    1. stability changes required (DaveBarach, 16:41:56)
    2. tests tripping over ipv6 / MLD packets (DaveBarach, 16:42:10)
    3. Klement: describing issues (DaveBarach, 16:42:54)
    4. MPLS when pg started, clear trace can crash vpp due to timing (DaveBarach, 16:43:35)
    5. discussion about %s vs %v => garbage characters in output (DaveBarach, 16:45:29)

  11. Vagrant status, Ed reporting (DaveBarach, 16:46:31)
    1. ongoing problems (DaveBarach, 16:46:44)
    2. real requirement: rapid onboarding (DaveBarach, 16:46:59)
    3. Vagrant works badly on windows, OK on Macs, not really useful on Linux (DaveBarach, 16:47:23)
    4. Ray observes that even prebuilt OVAs, boxes aren't a panacea (DaveBarach, 16:49:53)
    5. Tom H observes Vagrant is an 80% solution (DaveBarach, 16:51:13)
    6. Tom suggests a TWS call to discuss alternatives (DaveBarach, 16:52:11)
    7. Dave Wallace sent email: summary.. Packer seems like a reasonable way to generate a reproducible environment (DaveBarach, 16:53:04)
    8. Tom H observes that the learning-curve for Packer is non-zero (DaveBarach, 16:54:01)
    9. DaveBarach suggests picking one environment and supporting it (DaveBarach, 16:55:42)
    10. https://wiki.fd.io/view/VPP/Pulling,_Building,_Running,_Hacking_and_Pushing_VPP_Code (DaveBarach, 17:00:07)
    11. Dave Wallace suggest using packer to generate template images (DaveBarach, 17:01:41)
    12. Ed mentions that ci-management already has a working packer setup for vpp (DaveBarach, 17:02:21)
    13. multiple folks +1 on leveraging the ci-managment packer setup (DaveBarach, 17:03:11)
    14. AGREED: to figure out how to leverage the ci-management packer setup (DaveBarach, 17:05:11)
    15. ACTION: Dave Wallace to investigate (DaveBarach, 17:05:40)
    16. ACTION: Damjan to ping people to finish cleaning up Coverity warnings (DaveBarach, 17:07:48)
    17. ACTION: Marek to check outstanding Coverity warnings in java code (DaveBarach, 17:08:32)


Meeting ended at 17:09:51 UTC (full logs).

Action items

  1. marek to ping Ed Warnicke offline
  2. Damjan to work with Ed on vpp RC1 throttle pull mechanics
  3. Jan G to work with Damjan on csit for 17.01 release throttle
  4. Damjan to email dev list on MAINTANERS file or other scheme to endure timely patch reviews
  5. Dave Wallace to investigate
  6. Damjan to ping people to finish cleaning up Coverity warnings
  7. Marek to check outstanding Coverity warnings in java code


People present (lines said)

  1. DaveBarach (56)
  2. collabot (3)
  3. mortderire (1)
  4. tfherbert (1)


Generated by MeetBot 0.1.4.