#fdio-vpp: fdio vpp

Meeting started by DaveBarach at 14:55:27 UTC (full logs).

Meeting summary

  1. host stack (Florin reporting) (DaveBarach, 15:02:18)
  2. ONE-LISP (DaveBarach, 15:03:02)
    1. fixing routing issues (DaveBarach, 15:03:13)
    2. added LISP neighbor discovery (DaveBarach, 15:03:21)

  3. TCP stack (DaveBarach, 15:03:28)
    1. horizontal perf-scale improvements (DaveBarach, 15:03:36)
    2. stable at 10M connections on a dual-core (or greater) server (DaveBarach, 15:03:54)
    3. improving preallocated pool/segment handling (DaveBarach, 15:04:22)
    4. syn burst sent in aggregated frames, etc. (DaveBarach, 15:04:46)

  4. Release 17.10 (Florin reported) (DaveBarach, 15:07:38)
    1. past API freeze, pls do not merge changes without committer vote (DaveBarach, 15:07:51)
    2. RC1 throttle pull next Weds (DaveBarach, 15:08:16)

  5. infrastructure status (DaveBarach, 15:11:29)
    1. now using 4-core minions, may switch to 8-core jenkins minions (DaveBarach, 15:13:33)
    2. Automatic change detection, draft patch in for 17.07 (Jong_, 15:19:44)
    3. add suffix to api message names, e.g. "_v1,""_v2", etc. (DaveBarach, 15:21:06)
    4. Ray K suggests messages output w/ client library linked against old messages (DaveBarach, 15:25:54)
    5. question whether we can deprecate APIs from the POV of downstream distros (DaveBarach, 15:34:14)
    6. Tom H: API stabiliity a big issue for RedHat (DaveBarach, 15:34:46)
    7. ACTION: Tom H to consult within RH and report (DaveBarach, 15:35:43)
    8. Ray K upstream LTS distro locked in APIs (DaveBarach, 15:36:28)
    9. Jerome mentions Honeycomb APIs are super-stable, built over binary APIs (DaveBarach, 15:37:26)
    10. Chris L: we need to get a lot better at documenting API changes (DaveBarach, 15:38:24)
    11. Jerome: example: netconf ACL model far more stable than native API (DaveBarach, 15:39:48)

  6. 17.10 release contents (tom h) (DaveBarach, 15:42:32)
    1. Fedora patch shouldn't break anything (ssl dependency) (DaveBarach, 15:43:26)
    2. openssl 1.1 patch (DaveBarach, 15:44:46)
    3. second patch: bug in specfile w/ simple workaround (DaveBarach, 15:46:09)
    4. very close to zero (Jong_, 15:48:09)
    5. really good turnout (DaveBarach, 15:50:06)
    6. lots on interest in containers (DaveBarach, 15:50:25)
    7. nice talk by hongjun at networking mini-summit (DaveBarach, 15:51:55)
    8. using vpp to accelerate kube-proxy (DaveBarach, 15:52:08)


Meeting ended at 15:55:40 UTC (full logs).

Action items

  1. Tom H to consult within RH and report


People present (lines said)

  1. DaveBarach (34)
  2. Jong_ (7)
  3. collabot (3)


Generated by MeetBot 0.1.4.