#fdio-vpp: fdio-vpp

Meeting started by DaveBarach at 15:02:03 UTC (full logs).

Meeting summary

  1. maciek reporting on csit (DaveBarach, 15:03:25)
    1. dpdk 18.02 perf regression (2-3%) (DaveBarach, 15:04:42)
    2. x710 i40e not affected (DaveBarach, 15:05:02)
    3. x520 is affected (DaveBarach, 15:05:56)
    4. ACTION: dbarach to construct patch w/ gtpu plugin init routine commented out (DaveBarach, 15:09:38)
    5. https://lists.fd.io/g/csit-dev/message/2505 (mackonstan, 15:11:11)

  2. keith on host stack (DaveBarach, 15:11:21)
    1. envoy integration winding down, demo soon (DaveBarach, 15:11:33)
    2. DaveBarach florinc got Embed TLS and now Open SSL going. 0.8Gbps (alagalah, 15:13:05)
    3. working with Intel on acceleration (alagalah, 15:13:12)
    4. working on ipv6 test for host stack (DaveBarach, 15:13:27)
    5. test detects absence / presence of iperf3 to decide whether to run or not (DaveBarach, 15:14:30)

  3. 18.01 Dave Wallace reporting (DaveBarach, 15:16:08)
    1. 10-12 patches added, might be worth 18.01.02 (DaveBarach, 15:16:23)
    2. AGREED: dave wallace to kick off 18.01.02 release before the 18.04 RC1 throttle pull (DaveBarach, 15:18:30)

  4. infra status (Ed Kern) (DaveBarach, 15:20:36)
    1. automatic retry can +1 patch when one of the retries fails (DaveBarach, 15:22:03)
    2. cant seem to enter build failure causes (DaveBarach, 15:26:01)
    3. OpenSUSE verify jobs maybe renamed to OpenSUSE release specific names (alagalah, 15:29:46)
    4. note that Ubuntu-1804 comes with gcc-7, which manages to generate aligned avx2 instrs when they won't work (DaveBarach, 15:33:08)
    5. separate arm cluster needed for test (DaveBarach, 15:34:43)

  5. Billy on export compliance (DaveBarach, 15:38:41)
    1. primarily concentrating on ikev2, ipsec (DaveBarach, 15:38:58)
    2. still working on it (DaveBarach, 15:39:04)
    3. DaveBarach pushed patch to fix some, but will follow up with edwarnicke for feedback (alagalah, 15:40:03)
    4. targeting RH rel 7.4 (DaveBarach, 15:41:48)
    5. DaveBarach Found that GCC 7 doesn't seem to handle vec align very well.. (alagalah, 15:44:56)
    6. DaveBarach the distributed version of clang in 18.04 works fine, and perhaps it might be the impetus to move to clang default support (alagalah, 15:45:42)
    7. AGREED: mbedtls plugin to be disabled in 18.04 (DaveBarach, 15:51:40)
    8. ACTION: Ed Kern to send email to Tina T re: arm h/w, jenkins job merges (DaveBarach, 15:53:12)


Meeting ended at 15:53:16 UTC (full logs).

Action items

  1. dbarach to construct patch w/ gtpu plugin init routine commented out
  2. Ed Kern to send email to Tina T re: arm h/w, jenkins job merges


People present (lines said)

  1. DaveBarach (25)
  2. alagalah (12)
  3. collabot` (3)
  4. mackonstan (2)


Generated by MeetBot 0.1.4.