#fdio-vpp: fdio-vpp

Meeting started by DaveBarach at 16:03:00 UTC (full logs).

Meeting summary

    1. CSIT-1901 release complete (mackonstan, 16:03:28)
    2. VPP-19.01 tests collecting data for report are running (mackonstan, 16:03:37)
    3. three known issues being worked on (mackonstan, 16:03:49)
    4. i) VPP IPSec AES-GCM cipher broken, issue with dpdk ipsec backend (openssl ciphers work fine) (mackonstan, 16:04:05)
    5. ii) link bonding tests sporadically fail due to VPP crash, under investigation (mackonstan, 16:04:27)
    6. iii) VM vhost tests fail sporadically due to QEMU bug, workaround being applied (mackonstan, 16:04:46)
    7. otherwise good :) (mackonstan, 16:05:27)

  1. Honeycomb (Michal) (DaveBarach, 16:06:39)
    1. release is tomorrow, waiting for article upload (DaveBarach, 16:06:53)

  2. Host Stack (Florin) (DaveBarach, 16:07:17)
    1. experimental support for multi-thread applications (DaveBarach, 16:07:28)
    2. threads which share sessions, that is. (DaveBarach, 16:07:52)
    3. passive listener support (for ngingx), start session, listen in main worker, then fork (DaveBarach, 16:08:19)
    4. and collect the session (DaveBarach, 16:08:46)
    5. "spring cleanup" underway; transport now session soon. Please yell if e.g. compile build-breaks occur (DaveBarach, 16:09:20)
    6. renaming things, this is the right time for the cleanup (DaveBarach, 16:09:33)

  3. Documentation (John D reporting) (DaveBarach, 16:10:10)
    1. main page, landing page prototypes look good, waiting on the LF to do a (marketing) walkthrough (DaveBarach, 16:10:35)
    2. ACTION: John D. to give go-live date at next meeting (DaveBarach, 16:10:57)

  4. ARM-64 / aarch64 (Tina T reporting) (DaveBarach, 16:11:58)
    1. Happy Lunar New Year! (DaveBarach, 16:12:16)
    2. memcpy optimization, iperf3 perf w/ host stack (DaveBarach, 16:12:36)
    3. ip4 quad-loop under investigation (DaveBarach, 16:12:47)
    4. focus on arch-specific vectorization work (DaveBarach, 16:13:17)
    5. 128-byte cache-line size investigations (DaveBarach, 16:13:58)
    6. making 128-byte cache line size packages (DaveBarach, 16:14:21)
    7. svm fifo experiments to see if relaxed memory order will help (DaveBarach, 16:15:10)

  5. 19.01 Release (Andrew Y) (DaveBarach, 16:18:06)
    1. upstream python packages released at the same moment, good for some confusion (DaveBarach, 16:18:50)
    2. LF folks clock out earlier than expected for the PST time zone (DaveBarach, 16:19:19)
    3. ACTION: Dave Wallace to be Release Mgr for 19.04 (DaveBarach, 16:23:49)


Meeting ended at 16:25:14 UTC (full logs).

Action items

  1. John D. to give go-live date at next meeting
  2. Dave Wallace to be Release Mgr for 19.04


People present (lines said)

  1. DaveBarach (26)
  2. mackonstan (8)
  3. collabot` (3)


Generated by MeetBot 0.1.4.