#fdio-vpp: fdio-vpp

Meeting started by DaveBarach at 14:59:53 UTC (full logs).

Meeting summary

  1. CSIT (Maciek reporting) (DaveBarach, 15:00:17)
    1. Maciek (mackonstan, 15:00:18)
    2. Lots of infra work (mackonstan, 15:02:13)
    3. Continuing work on VAT to PAPI migration, going OKay (~70% complete) (mackonstan, 15:02:51)
    4. Unfortunately PAPI not fit-for-purpose for scale tests, so have to stick to VAT for time being (mackonstan, 15:03:13)
    5. Moving to remote PAPI (PAPI over remote socket) next week (needed for performance: avoiding json and other "wordy" serialization) (mackonstan, 15:03:58)
    6. Aligning performance and functional-device python libraries for seamless test portability, needed for VIRL turn-off (mackonstan, 15:04:31)
    7. VPP-CSIT CI alignment on master: CSIT VPP API gating (aka "VPP API flag day") job should be coming alive in next couple of weeks (mackonstan, 15:05:13)
    8. Re vpp-csit-verify-device-master jobs voting status: need stable PAPI before this can be entertained (mackonstan, 15:05:31)
    9. Trending tests back in working (mackonstan, 15:05:47)
    10. Performance tests: (mackonstan, 15:05:59)
    11. baremetal IPsec up to 60k tunnels (almost working), same for VPP-in-containers with scale-out (mackonstan, 15:06:13)
    12. dotq+vxlan+vhost+manyVMs NF density tests (mackonstan, 15:06:27)
    13. arm and denverton performance tests are going production (mackonstan, 15:06:46)
    14. other great news, we finally got TRex code with HDRhistogram for granular per-packet latency measurements (mackonstan, 15:06:52)
    15. CSIT-1908 plan wiki updated (mackonstan, 15:07:26)
    16. https://wiki.fd.io/view/CSIT/csit1908_plan (mackonstan, 15:07:32)

  2. Sweetcomb (Yohan Pipereau reporting) (DaveBarach, 15:08:32)
    1. trying to leverage vom (DaveBarach, 15:08:43)
    2. support srv6 in VOM -> land support in sweetcomb (DaveBarach, 15:09:13)
    3. open question openconfig vs or in addition to IETF yang models (DaveBarach, 15:09:56)

  3. Host Stack (Florin reporting) (DaveBarach, 15:10:07)
    1. good number of commits (DaveBarach, 15:10:19)
    2. TCP corner-case fixes (DaveBarach, 15:10:24)
    3. new congestion control APIs (DaveBarach, 15:10:37)
    4. multiple chunk SVM fifo support improved, including new tests (DaveBarach, 15:11:02)
    5. SCTP moved to a plugin, disabled by default (DaveBarach, 15:11:18)
    6. SCTP not maintained (DaveBarach, 15:11:29)
    7. could consider moving other transports to plugins (DaveBarach, 15:12:17)

  4. Documentation / main website (John DeNisco reporting) (DaveBarach, 15:13:00)
    1. trying to involve LFN / LF marketing (DaveBarach, 15:13:12)
    2. would like to start a biweekly meeting to gain momentum (DaveBarach, 15:13:26)
    3. need to point DNS names at the new site (DaveBarach, 15:14:02)

  5. AARCH64 (Hoppapa reporting) (DaveBarach, 15:16:18)
    1. lock tuneup benchmarks in progress (DaveBarach, 15:16:32)
    2. working on l3fwd path dual-looping (DaveBarach, 15:16:54)

  6. 19.04 release (Dave Wallace) (DaveBarach, 15:17:15)
    1. 19.01 final maintenance release in progress (DaveBarach, 15:18:29)
    2. 7/17 close-date for 19.01.3 (DaveBarach, 15:18:52)
    3. several patches since 19.04.1 (DaveBarach, 15:19:10)
    4. shall we try to do a 19.04.2 in July? (DaveBarach, 15:19:32)
    5. 7/24 suggested date (DaveBarach, 15:19:43)
    6. AGREED: 19.04.2 to be frozen on 7/24 (DaveBarach, 15:20:00)

  7. 19.08 (Andrew Y reporting) (DaveBarach, 15:20:39)
    1. in 20.01 commit msg metadata will help cross-reference release notes (DaveBarach, 15:22:32)

  8. Upcoming API changes (Dave W) (DaveBarach, 15:23:17)
  9. Infra (Ed Kern reporting) (DaveBarach, 15:28:44)
    1. one hard drive failure (DaveBarach, 15:28:57)
    2. no feedback from LF w.r.t. debug logs, memory leaks making Jenkins slow (DaveBarach, 15:29:27)
    3. discussion about parallel pcap file creation (DaveBarach, 15:31:51)

  10. libmemif most likely moved to "extras" package in 19.04 (DaveBarach, 15:35:35)
  11. Zoom meeting security issues (DaveBarach, 15:36:36)
    1. ACTION: ping the LF after some google searching (DaveBarach, 15:36:53)


Meeting ended at 15:37:26 UTC (full logs).

Action items

  1. ping the LF after some google searching


People present (lines said)

  1. DaveBarach (39)
  2. mackonstan (16)
  3. collabot` (3)


Generated by MeetBot 0.1.4.