#onap-int: integration weekly meeting 10/07/2019

Meeting started by morgan_orange at 13:06:23 UTC (full logs).

Meeting summary

  1. participants (morgan_orange, 13:06:28)
    1. Yang (morgan_orange, 13:06:35)
    2. Brian (morgan_orange, 13:06:37)
    3. Daniel Rose (morgan_orange, 13:06:41)
    4. Gary (morgan_orange, 13:06:46)
    5. joey Zhou (morgan_orange, 13:06:51)
    6. Kezystof Kuzmicki (morgan_orange, 13:07:08)
    7. Lei Shi (morgan_orange, 13:07:13)
    8. Marco (morgan_orange, 13:07:16)
    9. Paul Ionu Vaduva (morgan_orange, 13:07:22)

  2. Quick update (morgan_orange, 13:07:30)
    1. release officially announced (morgan_orange, 13:08:12)
    2. still some issues tracked in the daily "war room" meeting (morgan_orange, 13:08:27)
    3. different behavior detected on Orange lab (Dublin daily chain) (morgan_orange, 13:09:02)
    4. probelm at startup components are waiting other components, it seems that there are some race conditions (morgan_orange, 13:09:23)
    5. investigation on installation shall be done, helm charts shall be reviewed and components shall manage more properly their dependency (morgan_orange, 13:11:28)
    6. orchestration at installation is needed - timers are not enough (morgan_orange, 13:13:04)
    7. helm is maybe not enough for the the job (morgan_orange, 13:16:52)

  3. El Alto integration tasks (morgan_orange, 13:17:02)
    1. priority 1 don't break the build (sanity daily run) (morgan_orange, 13:17:22)
    2. extending gating to component (morgan_orange, 13:18:24)
    3. risk reported to TSC and PTL ..everybody agree during DDF, no decisions taken so far (morgan_orange, 13:23:01)
    4. discussions on the gating on SO (morgan_orange, 13:23:39)
    5. Brian suggest we could give a try on one tenant of the windriver lab. SO shall be deployed on an ONAP using fixed versions for the other components (morgan_orange, 13:24:23)
    6. a subset of the components is needed (not all the modules) (morgan_orange, 13:24:49)
    7. ACTION: Yang evaluate SO gating in windriver lab (morgan_orange, 13:27:52)
    8. ACTION: morgan_orange xcheck with Sylvain on creating a chain for SO to windriver lab (morgan_orange, 13:28:30)
    9. SB00 installed with latest Dublin (morgan_orange, 13:29:35)
    10. last run of Dublin on Orange lab => healthcheck almost all OK but impossible to onboard/instantiate, investigation in progress (morgan_orange, 13:31:42)
    11. ONAP deployment with smaller footprint (morgan_orange, 13:32:02)
    12. Bell Canada tried to divide by 2 the resource usages => aciton on OOM team (morgan_orange, 13:32:25)
    13. on windriver lab, Yang suggest to setup quotas to avoid resources starvation few eeks before the release as already experienced (morgan_orange, 13:33:04)
    14. Yang suggests also to deploy a sharable ONAP to save resources (morgan_orange, 13:33:56)
    15. several projects could use shared components e.g. 1 AAF for N tenants (morgan_orange, 13:37:44)
    16. lab improvement => question raised to TSC - 50 K to upgrade lab capabilities (morgan_orange, 13:39:07)
    17. lab is already under constraints (no more Memory slot / free ports on switches,..) (morgan_orange, 13:39:34)
    18. ~ 3 servers + 1 switch should be compatible with the budget (morgan_orange, 13:40:06)
    19. other option would be to use another lab (morgan_orange, 13:40:32)
    20. Marco indicates that an upgrade of the lab could be a temp victory as, it is constantly growing, we risk to reach new resources frontiers in 2 or 3 releases (morgan_orange, 13:41:12)
    21. morgan_orange mentions that some resources had been purchased by LF for OPNFV - they had to support 5 Openstack installers in //, there are only 1 or 2 and muche less projects. It should be possible to recover resources if they are not used (morgan_orange, 13:44:20)
    22. Marco shares ecomp experience. system was smaller and simpler. (morgan_orange, 13:50:47)
    23. help deploy everything in the same namespace => could multi namespaces avoid that a component change breaks the whole cluster (morgan_orange, 13:51:40)
    24. other El Alto topic testsuite code improvement, CSIT code improvement, Use case Automation, Performance benchmark ... to be discussed offline (morgan_orange, 13:52:46)

  4. Integration lab resource (put quota on tenants after we can provide shared infrastructure for project teams to test module deployment) (morgan_orange, 13:53:37)
    1. discussed in the previous section (morgan_orange, 13:53:44)

  5. Benchmark planninBenchmark planning for EI Alto (China Telecom) (morgan_orange, 13:54:04)
    1. China Telecom performed performance tests on Beijing (morgan_orange, 13:54:27)
    2. Brian and integration team provided support (morgan_orange, 13:55:10)
    3. suggestion to move to Dublin (morgan_orange, 13:55:33)
    4. they use the vFW use case to assess performance (morgan_orange, 13:59:50)
    5. ACTION: Lei Shi create a wiki page for performance tests (referenced from integration page) (morgan_orange, 14:00:22)

  6. AoB (morgan_orange, 14:00:43)
    1. OOM stagging branch => no more manifest (morgan_orange, 14:03:34)
    2. tooling: https://gitlab.com/Orange-OpenSource/lfn/onap/python-onapsdk idea is to replace https://gitlab.com/Orange-OpenSource/lfn/onap/onap-tests (morgan_orange, 14:04:48)


Meeting ended at 14:05:39 UTC (full logs).

Action items

  1. Yang evaluate SO gating in windriver lab
  2. morgan_orange xcheck with Sylvain on creating a chain for SO to windriver lab
  3. Lei Shi create a wiki page for performance tests (referenced from integration page)


Action items, by person

  1. morgan_orange
    1. morgan_orange xcheck with Sylvain on creating a chain for SO to windriver lab
  2. UNASSIGNED
    1. Yang evaluate SO gating in windriver lab
    2. Lei Shi create a wiki page for performance tests (referenced from integration page)


People present (lines said)

  1. morgan_orange (56)
  2. collabot` (3)


Generated by MeetBot 0.1.4.