#onap-int: weekly integration meeting 13/11/2019

Meeting started by morgan_orange at 14:00:06 UTC (full logs).

Meeting summary

  1. action points follow-up (morgan_orange, 14:00:15)
    1. AP1: Brian sync with Pam to finalize oparent / policy team (test) (morgan_orange, 14:00:29)
    2. in progress, NBI team merged the use of 3.x.x and did not get error (morgan_orange, 14:03:50)
    3. ready to be merged (morgan_orange, 14:04:01)
    4. someone mentioned a difficulty to find an alpine jdk11. jdk13 would be available => could be added to oparent (morgan_orange, 14:05:37)
    5. AP2: Morgan get status on NBI issue (morgan_orange, 14:06:14)
    6. fixe provided and tested. The End to End test triggereing VNF instantiation trhough NBI was successfull on Daily Master over the week end (morgan_orange, 14:06:57)
    7. AP3: morgan_orange sync with Dan for the python3 migration status, what is missing => we could already remove the python2.7 target of python-test-utils (morgan_orange, 14:07:30)
    8. done by mail (morgan_orange, 14:07:35)
    9. Once https://gerrit.onap.org/r/#/c/testsuite/+/97660/ would be finalized the migration epic would be OK (morgan_orange, 14:07:42)

  2. admin (morgan_orange, 14:08:01)
    1. JIRA cleaning (morgan_orange, 14:08:07)
    2. https://wiki.onap.org/display/DW/Frankfurt+integration (morgan_orange, 14:08:12)
    3. Morgan closed lots of JIRAs... (morgan_orange, 14:08:44)
    4. The number of open Jiras is till high (24 Epics, 22 Stories, 41 tasks, 13 bugs) (morgan_orange, 14:08:50)
    5. some could be closed (wait for own feedback) (morgan_orange, 14:08:56)
    6. Some were still assigned to Helen or Yang, morgan either reassigned them or closed them (morgan_orange, 14:10:55)
    7. some reassignement may be not correct...and some may have been closed too quickly, do not hesitate to re assign and/or re open if needed (morgan_orange, 14:11:04)
    8. committer promotion (morgan_orange, 14:12:05)
    9. ACTION: morgan_orange brian create a list to submit to the committers (morgan_orange, 14:12:38)
    10. CSIT follow-up: cleanup planned for end of Novemeber (already disabled job) + mail notification done for policy and dcae, all other projects are invited to provide the list of mail address corresponding to the csit jjbs (morgan_orange, 14:13:22)
    11. el alto retrospective (morgan_orange, 14:14:31)
    12. https://wiki.onap.org/display/DW/El-Alto+Retrospective (morgan_orange, 14:15:31)
    13. ACTION: all review this page (morgan_orange, 14:22:03)
    14. discussion on reorganization of the demo repository (morgan_orange, 14:25:19)
    15. we need to agree on the structure (morgan_orange, 14:27:10)
    16. Lukasz has in mind new tests to go beyond the healthcheck (morgan_orange, 14:32:22)
    17. morgan_orange indicates the existence of End to End tests (morgan_orange, 14:32:34)
    18. Lukasz would like to get more information from the components and move the responsability to each team to ensure it works (not the integration team) (morgan_orange, 14:33:33)
    19. Brian mentions SDC already wrote the healthcheck in this perspective (morgan_orange, 14:36:10)
    20. ACTION: morgan_orange brian lukasz prepare a slide deck for PTL meeting to ask for healthcheck better quality with better coverage (morgan_orange, 14:37:40)
    21. lab status (morgan_orange, 14:39:01)
    22. windriver: installation of a gitlabrunner to be able to run CI chains from gitlab.com (morgan_orange, 14:39:05)
    23. Orange: openlab migration to el alto, as soon as el alto Daily is clarified (still SO/VNFM errors preventing some tests to be run) (morgan_orange, 14:39:16)
    24. ACTION: morgan_orange create a stable daily in windriver (morgan_orange, 14:40:36)
    25. Prague: who will attend, which priority topics to be addressed by integration community? (morgan_orange, 14:41:39)
    26. ACTION: all: complete etherpad (morgan_orange, 14:41:43)
    27. https://etherpad.opnfv.org/p/onap_integration_prague (morgan_orange, 14:41:49)

  3. el alto status (morgan_orange, 14:42:05)
    1. https://wiki.onap.org/display/DW/1%3A+El+Alto+Release+Integration+Test+Blocking+Issues (morgan_orange, 14:42:09)
    2. MULTICLOUD-866 reopen - workaround = use starlingx => need to be confirmed (morgan_orange, 14:43:03)
    3. SDNC-961 now closed (morgan_orange, 14:44:07)
    4. Orange Daily chain ~ OK still an issue with SO healthcheck tests but otherwise pod and healthchecks tests look OK (morgan_orange, 14:46:22)
    5. problem with pod onap-aai-aai-graphgraph (morgan_orange, 14:46:26)
    6. JIRA created AAI-2707 (morgan_orange, 14:46:30)
    7. ACTION: morgan reinstall daily CI time series adapter to visualize test evolution = f(time) (morgan_orange, 14:46:35)

  4. frankfurt (morgan_orange, 14:47:10)
    1. Daily Master (morgan_orange, 14:47:46)
    2. 2 pods failing:onap-aai-aai-data-router, onap-aai-aai-graphgraph (morgan_orange, 14:47:52)
    3. all healthcheck OK except So (but test alignment issue) (morgan_orange, 14:47:57)
    4. VNF tests (Ubuntu, NBI and clearwater vIMS) (morgan_orange, 14:48:01)
    5. vCPE discussion: today 3 use cases have soem referenced to vCPE (morgan_orange, 14:48:14)
    6. work in progress (Brian and Bartek) (morgan_orange, 14:55:11)
    7. https://wiki.onap.org/display/DW/2%3A+Frankfurt+Release+Integration+Testing+Status (morgan_orange, 14:55:48)
    8. Use Case: Residential Broadband vCPE (2), vCPE with TOSCA (3), 5G PNF (5): missing use cases? Status for automation? (morgan_orange, 14:55:53)

  5. Round Table (morgan_orange, 15:01:35)
    1. question on PNF Simulator/Netconf Simulator => Andrew will help (morgan_orange, 15:04:13)
    2. Krysztof will also ask his team to look at simulator issue (morgan_orange, 15:07:49)
    3. PNFV registrate can be added in smoke usecase (morgan_orange, 15:08:03)


Meeting ended at 15:09:05 UTC (full logs).

Action items

  1. morgan_orange brian create a list to submit to the committers
  2. all review this page
  3. morgan_orange brian lukasz prepare a slide deck for PTL meeting to ask for healthcheck better quality with better coverage
  4. morgan_orange create a stable daily in windriver
  5. all: complete etherpad
  6. morgan reinstall daily CI time series adapter to visualize test evolution = f(time)


Action items, by person

  1. morgan_orange
    1. morgan_orange brian create a list to submit to the committers
    2. morgan_orange brian lukasz prepare a slide deck for PTL meeting to ask for healthcheck better quality with better coverage
    3. morgan_orange create a stable daily in windriver
  2. UNASSIGNED
    1. all review this page
    2. all: complete etherpad
    3. morgan reinstall daily CI time series adapter to visualize test evolution = f(time)


People present (lines said)

  1. morgan_orange (62)
  2. collabot (3)


Generated by MeetBot 0.1.4.