#onap-int: Integration weekly meeting 02/09/2020

Meeting started by morgan_orange at 14:27:03 UTC (full logs).

Meeting summary

  1. action point follow-up (morgan_orange, 14:27:12)
    1. https://ircbot.wl.linuxfoundation.org/meetings/onap-int/2020/integration_weekly_meeting_26_08_2020/onap-int-integration_weekly_meeting_26_08_2020.2020-08-27-08.34.html (morgan_orange, 14:27:30)
    2. AP1: morgan_orange redo some tests then conctact Intel/Windriver lab team to report results and see how to proceed to improve (morgan_orange, 14:27:39)
    3. done see next topic (morgan_orange, 14:27:48)
    4. AP2: morgan_orange send mail to use case onwers + PTL to report infra test status (morgan_orange, 14:27:56)
    5. status shared with PTL, answers also provided to release management and to some test suite owners (morgan_orange, 14:28:31)
    6. AP3 pawel morgan_orange move all the waiver/xfail lists in integration/seccom + adapt the Dockerfile accordingly (morgan_orange, 14:28:41)
    7. done (morgan_orange, 14:28:42)
    8. AP4 Thierry andreas find the best way to cover both options (morgan_orange, 14:28:52)
    9. in progress (morgan_orange, 14:28:55)
    10. AP5 andreas create a JIRA on SO/AAI data change problem in master (morgan_orange, 14:29:03)
    11. a jira has been created for OOF issue but not yet for SO/AAI (wait for confirmation but regression on master last night (oom/AAI patch reverted) (morgan_orange, 14:29:43)

  2. admin (morgan_orange, 14:29:47)
    1. Infrastructure Audit performed on Intel/Windriver lab levering OPNFV functest benchmark tools (morgan_orange, 14:30:14)
    2. results are not good (morgan_orange, 14:30:19)
    3. one big compute was in down state (but enabled), RAM capability of some compute is above 98%, (morgan_orange, 14:30:50)
    4. VMTP tests showed bad results with compute 5 and no results with compute 9 (98,7 RAM consumption) (morgan_orange, 14:31:22)
    5. the overall RAM consumption is above 75% (morgan_orange, 14:31:35)
    6. several compute services are done (controler 0 + compute 20 and 21) (morgan_orange, 14:31:55)
    7. some errors reported by shaker mentioned VIF issues which seem to indicate that there are some undelays issues (morgan_orange, 14:32:19)
    8. mail shared with lab owner + integration committer + release management (morgan_orange, 14:32:34)
    9. currently it is impossible to guarantee some support for pair wise testing and use cases (morgan_orange, 14:32:56)
    10. possible options: 1) fix Intel/windriver issues 2) extend Azure to deploy instances for ONAP users 3) ask for community members to offers computing resources 4) get Vexhost capabilities (used by LF) (morgan_orange, 14:34:17)
    11. high risk on the release reported to release management (morgan_orange, 14:34:28)
    12. support requested to Intel/Windriver team but no feedback so far (morgan_orange, 14:34:43)
    13. new repo follow-up: we are up to date the 3 last new repos have been created, still some issues of sync ldap/committers (morgan_orange, 14:35:30)
    14. open question on Bell CDS team on any visibility to get the CDS tests (morgan_orange, 14:35:47)
    15. ACTION: Mike Eliott provide some date on the contribution in testsuite/cds repo (morgan_orange, 14:36:08)
    16. Santosh is participating to Integration meeting and involved in CDS testing (morgan_orange, 14:36:26)
    17. committer review (morgan_orange, 14:36:34)
    18. https://git.onap.org/integration/tree/INFO.yaml (morgan_orange, 14:36:41)
    19. several committers are no more active, the critical mass of committers is decreasing, which can be a problem (morgan_orange, 14:37:03)
    20. ACTION: morgan_orange contact recent inactive committers to get their plans (morgan_orange, 14:37:31)
    21. ACTION: all think to 2 or 3 new committers to replace inactive committers (morgan_orange, 14:37:50)
    22. backend moved from Orange azure to LF IT backend end (morgan_orange, 14:38:23)
    23. all the results can be found in https://logs.onap.org/onap-integration/daily/ or https://logs.onap.org/onap-integration/gating (morgan_orange, 14:39:01)
    24. ACTION: morgan create a LF IT ticket to clean first attempts on onap-integration (morgan_orange, 14:39:24)
    25. ACTION: morgan send a mail to notify the new location of the daily and gating results and optionnaly configure a redirection from the previous place (morgan_orange, 14:40:00)
    26. gating extension (morgan_orange, 14:41:23)
    27. DCAE would be interested => possible in H version but requires resources (morgan_orange, 14:41:36)
    28. Clamp included in Guilin (morgan_orange, 14:41:45)
    29. coudl be interested to get feedback from clamp team (morgan_orange, 14:41:55)
    30. ACTION: morgan ask some feedback on clamp gating to clamp team (morgan_orange, 14:42:05)
    31. discussion with Pratik: wait for answer, Integration project would like to know the motivation of the patches (that got -1 in linting) any optimization must not degrade the quality imposed by the linters (morgan_orange, 14:42:56)

  3. Guilin (morgan_orange, 14:43:03)
    1. status on daily master (morgan_orange, 14:43:09)
    2. regression on OOM/AAI detected leading to a revert (morgan_orange, 14:43:22)
    3. https://gerrit.onap.org/r/c/aai/oom/+/111997 (morgan_orange, 14:43:34)
    4. K mentions that a very big patch in in progress to improve the kubernetes version, this has impact (morgan_orange, 14:44:13)
    5. SO &AAI issue also reported by K, seems similar to what ANdreas reported - to be retested and confirmed (morgan_orange, 14:44:44)
    6. K also reported an issue with VID/AAI => not detected a priori on DT and Orange Frnakfurt chain (morgan_orange, 14:45:03)
    7. K shall recheck (morgan_orange, 14:45:07)
    8. still Frankfurt SO version in Master (blocking point found by OOM) (morgan_orange, 14:45:27)
    9. also no news on an update for ccsdk (morgan_orange, 14:45:36)
    10. still no regular "small" version, water falling system still in action (morgan_orange, 14:45:53)
    11. ACTION: morgan_orange retrieve master versions, compare with frankfurt and ask the PTL during the PTL meeting on their options (M4=code freeze supposed to be mid of September..) (morgan_orange, 14:46:34)
    12. CI chain evolution (morgan_orange, 14:47:05)
    13. morgan indicates the current daily/gating chain and proposed the evolution for Guilin (morgan_orange, 14:47:25)
    14. ACTION: morgan shared the evolution on onap-discuss and wait for feedback (morgan_orange, 14:47:35)
    15. ACTION: all give feedback on CI evolution for Guilin (morgan_orange, 14:47:49)
    16. K asks whether a test on CMPv2 has to be planned (morgan_orange, 14:48:00)
    17. any new feature shall come with test..in theory so CMPv2 should provide a way to test it (possible with pnf registrate but test is complex..) (morgan_orange, 14:48:35)
    18. andreas indicates that he was able to onboard/instanciate the vFW with SO macroflow/CDS (morgan_orange, 14:49:03)
    19. he asks CDS team if they could work on HTTPS support otherwise manual steps are needed (morgan_orange, 14:50:09)
    20. https://jira.onap.org/browse/CCSDK-2665?jql=reporter%20%3D%20andreasgeissler%20AND%20resolution%20%3D%20Unresolved%20ORDER%20BY%20priority%20DESC%2C%20updated%20DESC (morgan_orange, 14:50:11)
    21. Jira open since several versions but still not finalized (morgan_orange, 14:50:40)
    22. vCPE update merged => to be tested (morgan_orange, 14:51:51)
    23. nodeport cert check under integration (morgan_orange, 14:51:59)
    24. versions under CI integration, weekly chain needed (for longer tests) (morgan_orange, 14:52:13)
    25. refactoring on master chains daily from monday to saturday, weekly on sunday with longer tests (morgan_orange, 14:52:37)

  4. AoB (morgan_orange, 14:52:46)
    1. quiestion from Biswajit on the robot testuite refactoring delaing with the AAF flag to be supported by SO (morgan_orange, 14:53:22)
    2. morgan indicates that a refactoring of the robot pod was planned but not a full rewritting of the existing robot tests (morgan_orange, 14:53:43)
    3. ACTION: bisjwajit initiate a thread offline integration / So / AAF flag / robot tests (morgan_orange, 14:54:27)


Meeting ended at 14:54:29 UTC (full logs).

Action items

  1. Mike Eliott provide some date on the contribution in testsuite/cds repo
  2. morgan_orange contact recent inactive committers to get their plans
  3. all think to 2 or 3 new committers to replace inactive committers
  4. morgan create a LF IT ticket to clean first attempts on onap-integration
  5. morgan send a mail to notify the new location of the daily and gating results and optionnaly configure a redirection from the previous place
  6. morgan ask some feedback on clamp gating to clamp team
  7. morgan_orange retrieve master versions, compare with frankfurt and ask the PTL during the PTL meeting on their options (M4=code freeze supposed to be mid of September..)
  8. morgan shared the evolution on onap-discuss and wait for feedback
  9. all give feedback on CI evolution for Guilin
  10. bisjwajit initiate a thread offline integration / So / AAF flag / robot tests


Action items, by person

  1. morgan_orange
    1. morgan_orange contact recent inactive committers to get their plans
    2. morgan_orange retrieve master versions, compare with frankfurt and ask the PTL during the PTL meeting on their options (M4=code freeze supposed to be mid of September..)
  2. UNASSIGNED
    1. Mike Eliott provide some date on the contribution in testsuite/cds repo
    2. all think to 2 or 3 new committers to replace inactive committers
    3. morgan create a LF IT ticket to clean first attempts on onap-integration
    4. morgan send a mail to notify the new location of the daily and gating results and optionnaly configure a redirection from the previous place
    5. morgan ask some feedback on clamp gating to clamp team
    6. morgan shared the evolution on onap-discuss and wait for feedback
    7. all give feedback on CI evolution for Guilin
    8. bisjwajit initiate a thread offline integration / So / AAF flag / robot tests


People present (lines said)

  1. morgan_orange (77)
  2. collab-meetbot (3)


Generated by MeetBot 0.1.4.