#onap-int: Integration weekly meeting 05/08/2020

Meeting started by morgan_orange at 15:50:18 UTC (full logs).

Meeting summary

  1. Action point follow-up (morgan_orange, 15:51:28)
    1. AP1 Kryszstof evaluate the possibility to create non regression test on k8s plugin (morgan_orange, 15:52:15)
    2. Jack Lucas had bunch of blueprints for k8s plugin tests but - manual approach ... (morgan_orange, 15:52:32)
    3. would make sense to automate such regression tests (requires k8s tests) and include in weekly/daily (morgan_orange, 15:53:14)
    4. ACTION: kryzstof start a mail thread to evaluate the load/difficulty (morgan_orange, 15:53:57)

  2. Admin (morgan_orange, 15:54:12)
    1. Windriver lab (morgan_orange, 15:54:16)
    2. SB-00 reinstalled yesterday (morgan_orange, 15:54:23)
    3. SB-00 and daily run => issue with clamp due to maria (morgan_orange, 15:54:36)
    4. (morgan_orange, 15:55:16)
    5. error: database is uninitialized and password option is not specified You need to specify one of MYSQL_ROOT_PASSWORD, MYSQL_ALLOW_EMPTY_PASSWORD and MYSQL_RANDOM_ROOT_PASSWORD (morgan_orange, 15:55:25)
    6. this error seems specific to windriver (morgan_orange, 15:55:32)
    7. comparison windriver / orange env => seems that the windriver kubernetes server version is too old 1.5.3 (expected 1.5.11), no big difference detected otherwise (morgan_orange, 15:56:24)
    8. ACTION: morgan_orange update the k8s version to 1.5.11 on windriver (patch needed in master/frankfurt) and give a new try.. (morgan_orange, 15:58:11)
    9. presentation how to reinstall SB-00 (morgan_orange, 15:58:26)
    10. all the integration committers have the procedure (login/password needed to launch the jenkins job) (morgan_orange, 15:58:47)
    11. WIP to reuse the CI chains sued for gating and orange dailys => advantage it is maintained by OOM => no risk of version mis alignement (morgan_orange, 15:59:17)
    12. this ci chain is based on gitlab-ci (runner installed in windriver lab), troubleshooting in progress (morgan_orange, 16:00:27)

  3. Status on ElAlto and Frankfurt Maintenance release (morgan_orange, 16:00:45)
    1. Orange dailys not running between 1/08 => 04/08 due to hardware issue (disk) , VM were in RAM, but no more disk was seen from the physical server hosting VM hosting k8s nodes (morgan_orange, 16:01:48)
    2. server power down, new daily today (morgan_orange, 16:02:11)
    3. https://gating-results.onap.eu/results/onap_daily_pod4_frankfurt-671281880-08-05-2020_01-08/ (morgan_orange, 16:02:25)
    4. frankfurt good results => confirm the GO for maintenance release given by OOM (the clamp issue on windriver is not reproducible) (morgan_orange, 16:02:52)
    5. https://gating-results.onap.eu/results/onap_daily_pod4_elalto-671454952/ (morgan_orange, 16:03:05)
    6. El Alto, results are not significative - as tests docker are frankfurt (morgan_orange, 16:03:36)
    7. only frankfurt dockers available on ONAP Nexus 3 (chain introduced in frankfurt and history not transfered from gitlab.com) (morgan_orange, 16:04:21)
    8. a solution would consist in pushing gitlab.com elalto dockers to the nexus but it is not allowed - LF policy imposed that the artifacts are built on LF servers (morgan_orange, 16:04:52)
    9. ugly workaround may be possible IF < frankfurt use gitlab.com docker else use ONAP dockers.. (morgan_orange, 16:05:19)
    10. it is still possible to run the test manually (morgan_orange, 16:05:32)
    11. https://jira.onap.org/browse/SDNC-1308 (morgan_orange, 16:07:07)
    12. https://jira.onap.org/browse/SDNC-1309 (morgan_orange, 16:07:12)
    13. issue on SO adaptor sent to SO team (morgan_orange, 16:08:12)
    14. SDC issue reported to SDC team (morgan_orange, 16:08:25)

  4. python SDK (morgan_orange, 16:08:49)
    1. new features introduced - CDS onboarding almost ready, CLAMP (morgan_orange, 16:09:41)
    2. scenario => first patch introduced by Amine including clamp and the beginning of closed loop scenario (morgan_orange, 16:10:03)
    3. the patch includes the structure and the work specific to clamp (morgan_orange, 16:10:22)
    4. ACTION: morgan_orange split Amine patch into 2 patches: structure (Thierry proposal) / clamp (Amine) (morgan_orange, 16:10:55)

  5. CDS tests (morgan_orange, 16:11:11)
    1. Bell CDS tests are more functional tests than integration tests => they can be run independently from ONAP, they require Mock obecjts + a kafka server (dmaap not used) (morgan_orange, 16:11:49)
    2. possible to create a dedicated repository - not even if the repository is in ONAP, it does not means that the CI will require jenkins dev. Lots of tests are in ONAp but run through gitlab-ci. So it dependsq on what is needed (docker build for the mock object?) (morgan_orange, 16:13:01)
    3. Andreas indicates that the CDS test with python-sdk requires today manual operation tyo expose the blueprint-processor-http (morgan_orange, 16:13:30)
    4. work in progress to move to HTTPS (Yurik + marek) to avoid this manual step (morgan_orange, 16:13:48)
    5. Bell tests = Bash scripts running set of request to mocked CDS (morgan_orange, 16:14:21)
    6. ACTION: Sebastien : provide code + procedure to give a first try ... (morgan_orange, 16:14:40)
    7. ACTION: Trevor: tell if OK with a dedicated repository. As it is functional testing, it is usually hosted in the project...cds/cds/tests (under Dan responsibility) (morgan_orange, 16:16:39)
    8. other possibility testsuite/cds (under integration responsability) (morgan_orange, 16:17:02)

  6. AoB (morgan_orange, 16:17:15)
    1. question from Kuldeep: Test API availability (morgan_orange, 16:17:39)
    2. ACTION: Kuldeep initiate a mail thread (morgan_orange, 16:17:50)
    3. question from Kuldeep on OOF error on his Frankfurt deployment => suggest to run onap-k8s to get more logs (morgan_orange, 16:18:17)
    4. ACTION: morgan_orange send a mail with the procedure to run onap-k8s tests on any ONAP solution (morgan_orange, 16:18:34)
    5. question from nagindar on how to include new healthcheck tests (morgan_orange, 16:18:56)
    6. som Q&A are available on the main integration page (morgan_orange, 16:19:05)
    7. https://wiki.onap.org/display/DW/Integration+Project (morgan_orange, 16:19:20)
    8. tests can be done directly in the robot pod....(change inside the robot script, then run using the right tag from the controller) then to be run in xtesting (and in CI) a new image shall be built and referenced in the k8s job (morgan_orange, 16:21:09)
    9. ACTION: morgan_orange send the windriver CI SB-00 jenkins script to Sandeep (morgan_orange, 16:21:41)


Meeting ended at 16:21:45 UTC (full logs).

Action items

  1. kryzstof start a mail thread to evaluate the load/difficulty
  2. morgan_orange update the k8s version to 1.5.11 on windriver (patch needed in master/frankfurt) and give a new try..
  3. morgan_orange split Amine patch into 2 patches: structure (Thierry proposal) / clamp (Amine)
  4. Sebastien : provide code + procedure to give a first try ...
  5. Trevor: tell if OK with a dedicated repository. As it is functional testing, it is usually hosted in the project...cds/cds/tests (under Dan responsibility)
  6. Kuldeep initiate a mail thread
  7. morgan_orange send a mail with the procedure to run onap-k8s tests on any ONAP solution
  8. morgan_orange send the windriver CI SB-00 jenkins script to Sandeep


Action items, by person

  1. morgan_orange
    1. morgan_orange update the k8s version to 1.5.11 on windriver (patch needed in master/frankfurt) and give a new try..
    2. morgan_orange split Amine patch into 2 patches: structure (Thierry proposal) / clamp (Amine)
    3. morgan_orange send a mail with the procedure to run onap-k8s tests on any ONAP solution
    4. morgan_orange send the windriver CI SB-00 jenkins script to Sandeep
  2. UNASSIGNED
    1. kryzstof start a mail thread to evaluate the load/difficulty
    2. Sebastien : provide code + procedure to give a first try ...
    3. Trevor: tell if OK with a dedicated repository. As it is functional testing, it is usually hosted in the project...cds/cds/tests (under Dan responsibility)
    4. Kuldeep initiate a mail thread


People present (lines said)

  1. morgan_orange (67)
  2. collab-meetbot (6)


Generated by MeetBot 0.1.4.