#onap-int: Integration weekly meeting 08/07/2020

Meeting started by morgan_orange at 16:28:18 UTC (full logs).

Meeting summary

  1. action point follow up (morgan_orange, 16:28:26)
    1. AP1: morgan_orange krzysztof integrate preonboarding use case in CI Master (morgan_orange, 16:28:38)
    2. not done yet, Krzysztof in PTO, I will be in PTO next weeks. But Still in mind...test prerequisite closed to hv-ves (morgan_orange, 16:29:24)
    3. AP2 & AP8 morgan_orange Pawel W confirm we can swich from http endpoint to nonsslendpoint use case (morgan_orange, 16:29:46)
    4. Pawel confirms, filtering feature to be completed,. nonsslendpoint will be the reference test (morgan_orange, 16:30:33)
    5. AP3: morgan_orange ask Yuriy to get notified when patches are all in (needed for closed loop stuff out of the box) to self release testsuite 1.6.4 (morgan_orange, 16:30:43)
    6. done, 1.6.4 created yesterday (morgan_orange, 16:30:51)
    7. AP4 morgan_orange intiate a wiki page to track the status of Robot rests (runnable from inside/outside) and get the reason cause when it is not runnable from outside (morgan_orange, 16:31:02)
    8. done (morgan_orange, 16:31:04)
    9. https://wiki.onap.org/display/DW/Robot+Pod+Refactoring (morgan_orange, 16:31:12)
    10. AP5: morgan_orange give a try to CDS test for next week (morgan_orange, 16:31:35)
    11. done, several prerequisites needed (user creation, maria db patch, curl to internal CDS) (morgan_orange, 16:32:34)
    12. https://wiki.onap.org/pages/viewpage.action?pageId=71838892 (morgan_orange, 16:32:44)
    13. https://wiki.onap.org/pages/viewpage.action?pageId=71838945#E2ERunTime-655515897 (morgan_orange, 16:32:51)
    14. CDS test still FAIL , test redo with testsuite 1.6.4 (new test to be done on fresh installation, not sure replay on error is possible) (morgan_orange, 16:33:53)
    15. AP6 morgan_orange contact SECCOM to see if we can reset the xfail list now or if we should wait a milestone (morgan_orange, 16:34:09)
    16. done, (morgan_orange, 16:34:15)
    17. ACTION: morgan_orange reset xfail list of security tests (morgan_orange, 16:34:28)
    18. AP8 morgan_orange integrate the cert test in CI (morgan_orange, 16:34:51)
    19. work in progress (morgan_orange, 16:34:59)

  2. Admin (morgan_orange, 16:35:08)
    1. Windriver cleaning step 1 done (morgan_orange, 16:35:19)
    2. https://wiki.onap.org/pages/viewpage.action?pageId=6593670&preview=/6593670/84657430/windriver_status_after_cleaning_campaign.pdf (morgan_orange, 16:35:32)
    3. in short saving CPU 15%, RAM 19% Disk 8%, nb of projects 128 > 43 (morgan_orange, 16:36:11)
    4. still possible to clean additional resources (projects and Integration) (morgan_orange, 16:36:44)
    5. no feedback received from some projects but projects kept for the moment (morgan_orange, 16:37:12)
    6. release daily reconfigure to use frankfurt by default (morgan_orange, 16:37:35)
    7. replacement of 1 node planned on Intel/Winder lab https://jira.opnfv.org/browse/INFRA-443 (no place left on the switch but possibility to replace an existing compute node with a better one) (morgan_orange, 16:38:00)
    8. integration/seccom shall be available => 1 file with recommended versions (morgan_orange, 16:38:17)
    9. baseline images: FAQ on python3 to see how to use the image (morgan_orange, 16:38:43)
    10. ACTION: morgan_orange create FAQ on how to use the python baseline image (morgan_orange, 16:38:58)
    11. discussion with Amy (SECCOM) on the need to build more images (debian|ubuntu|centos|alpine + java11|python3) (morgan_orange, 16:39:27)
    12. wait for TSC discussion regrading the license topic. The less base image we have, the easiest to maintain/check CVE (e.g. with Harbor) (morgan_orange, 16:40:19)
    13. June CI logs saved on Nexus (morgan_orange, 16:40:30)
    14. https://logs.onap.org/onap-integration/ (morgan_orange, 16:40:46)
    15. summer time organization => need to find somebody to manage integration weekly meetings (morgan_orange, 16:41:16)
    16. ACTION: morgan_orange find committer to manage the meeting (morgan_orange, 16:41:34)

  3. stable branches (morgan_orange, 16:41:59)
    1. frankfurt status: onap-aaf-cert-service error => internal cert expired (morgan_orange, 16:42:46)
    2. few consequences as this feature is not used by lots of use cases (morgan_orange, 16:43:06)
    3. for the maintenance release, some certificates (detected on nodeports) are expired or about to expired (morgan_orange, 16:43:39)
    4. ACTION: morgan_orange send a mail to ptl/release to ask what is the plan for the expired cert or the too long cert for the maintenance release (morgan_orange, 16:44:07)
    5. ACTION: morgan_orange update the release note for the frankfurt maintenance release (1.6.4) (morgan_orange, 16:44:40)
    6. maintenance release for El Alto (morgan_orange, 16:45:03)
    7. diffuclties to reset El Alto CI chain, OOM is investigating. Needed to check the last patch (mainly certificates update) (morgan_orange, 16:45:37)

  4. Guilin (morgan_orange, 16:46:18)
    1. new page on robot tests. few can be run from outside the cluster as they call internal ports. (morgan_orange, 16:47:12)
    2. sometimes it is normal/logical as some components are not exposed (morgan_orange, 16:47:40)
    3. but sometimes it is just a shortcut to simplify the tests (morgan_orange, 16:47:56)
    4. test done on nodeport, could be redone on ingress but it should be the same results.. (morgan_orange, 16:48:18)
    5. shall we create a special tag for the use case runnable from outside the cluster? enduser? (morgan_orange, 16:48:47)
    6. question from Krzysztof, no End to End test => there are at least 3 tests (basic_vm, freeradius_nbi, clearwater_ims) leveraging onap-test framework (morgan_orange, 16:49:58)
    7. this framework will be deprecated in Guilin and replaced by scenario leveraging python_onapsdk (morgan_orange, 16:50:22)
    8. presentation of the status on the scenarios (morgan_orange, 16:50:31)
    9. ACTION: thierry push prototype to ONAp repository (morgan_orange, 16:50:49)
    10. it shall be easy to switch from nodeport to ingress thanks to the config (morgan_orange, 16:51:14)
    11. https://gitlab.com/Orange-OpenSource/lfn/onap/python-onapsdk/-/blob/develop/src/onapsdk/configuration/global_settings.py (morgan_orange, 16:51:48)
    12. ACTION: morgan_orange create a global setting for ingress configuration (morgan_orange, 16:52:08)
    13. the goal is to replace the existing E2E tests by new scenarios (morgan_orange, 16:52:24)
    14. Thierry presents the prototype (morgan_orange, 16:52:35)
    15. https://gitlab.com/Orange-OpenSource/lfn/onap/pythonsdk-tests/-/blob/master/run_e2e.py (morgan_orange, 16:52:45)
    16. basic _vm can be replaced by this file (20 lines) (morgan_orange, 16:53:00)
    17. service is based on a yaml file (morgan_orange, 16:53:17)
    18. additional tests expected: basic_network, basic_cnf, ... (morgan_orange, 16:53:40)
    19. scenarios to be integrated during summer (morgan_orange, 16:53:49)
    20. discussion on REQ-399 (morgan_orange, 16:54:16)
    21. https://jira.onap.org/browse/REQ-399 (morgan_orange, 16:54:25)
    22. statement from Andreas (morgan_orange, 16:54:34)
    23. Mandatory GUI-Tests have to be provided to verify: (morgan_orange, 16:55:32)
    24. - Standalone GUI startup without failures (morgan_orange, 16:55:42)
    25. - User Login (if applicable) (morgan_orange, 16:55:51)
    26. - GUI startup within Portal (if applicable) - For each user role (morgan_orange, 16:56:04)
    27. Addon Tests (morgan_orange, 16:56:10)
    28. - Complete GUI workflow execution (morgan_orange, 16:56:39)
    29. - Page functionality (e.g. dialog, search,…) (morgan_orange, 16:56:51)
    30. - GUI accessibility test (morgan_orange, 16:56:59)
    31. - Internationalization (morgan_orange, 16:57:10)
    32. The tests have to run without any user interaction and have to be integratable into the Integration CI chains. (morgan_orange, 16:57:20)
    33. Existing frameworks (e.g. robot testsuite) include the Selenium test framework and might be an option to be used. (morgan_orange, 16:57:30)
    34. Ashish working on SDC (morgan_orange, 16:57:44)
    35. a test had been initiated on SDC (morgan_orange, 16:57:54)
    36. https://git.onap.org/testsuite/tree/robot/testsuites/portalApp.robot (morgan_orange, 16:59:00)
    37. but lots of tests not maintained (morgan_orange, 16:59:09)
    38. right place to commit is testsuite repo (morgan_orange, 16:59:29)

  5. AoB (morgan_orange, 16:59:48)


Meeting ended at 16:59:53 UTC (full logs).

Action items

  1. morgan_orange reset xfail list of security tests
  2. morgan_orange create FAQ on how to use the python baseline image
  3. morgan_orange find committer to manage the meeting
  4. morgan_orange send a mail to ptl/release to ask what is the plan for the expired cert or the too long cert for the maintenance release
  5. morgan_orange update the release note for the frankfurt maintenance release (1.6.4)
  6. thierry push prototype to ONAp repository
  7. morgan_orange create a global setting for ingress configuration


Action items, by person

  1. morgan_orange
    1. morgan_orange reset xfail list of security tests
    2. morgan_orange create FAQ on how to use the python baseline image
    3. morgan_orange find committer to manage the meeting
    4. morgan_orange send a mail to ptl/release to ask what is the plan for the expired cert or the too long cert for the maintenance release
    5. morgan_orange update the release note for the frankfurt maintenance release (1.6.4)
    6. morgan_orange create a global setting for ingress configuration


People present (lines said)

  1. morgan_orange (89)
  2. collab-meetbot` (4)


Generated by MeetBot 0.1.4.