#onap-int: Integration weekly meeting 16/09/2020

Meeting started by morgan_orange at 14:29:32 UTC (full logs).

Meeting summary

  1. action point follow up (morgan_orange, 14:29:40)
    1. AP1 morgan_orange initiate committer promotion (xcheck with them first then initiate the procedure) (morgan_orange, 14:29:52)
    2. AP2 morgan_orange contact new committers and initiate the procedure (morgan_orange, 14:30:11)
    3. AP1 and AP2 done, candidates OK, survey sent to existing committers (morgan_orange, 14:30:30)
    4. results of the survey 3 candidates got a majority of Yes (morgan_orange, 14:30:51)
    5. ACTION: morgan_orange finalize official procedure for new committers (morgan_orange, 14:31:02)
    6. Krysztof create a jira to track cloudify/DCAE bootstrap race condition issue (morgan_orange, 14:31:10)
    7. no update (morgan_orange, 14:31:13)
    8. done see Guilin Section (morgan_orange, 14:31:32)
    9. AP5 morgan_orange create bunch of JIRAs (morgan_orange, 14:31:40)
    10. JIRAs created, available on Integration Guilin Page or Release management page (morgan_orange, 14:32:02)

  2. admin (morgan_orange, 14:32:07)
    1. no news from windriver (neither lab, windriver TSC member, TSC,..) (morgan_orange, 14:32:29)
    2. Action item taken 10 days ago in TSC, but no feedback during last TSC (morgan_orange, 14:32:48)
    3. Kenny took the action in PTL to escalade (morgan_orange, 14:33:07)
    4. new committers, process on track (morgan_orange, 14:33:19)
    5. repo: last repo available 5g-core-ns (morgan_orange, 14:33:34)
    6. first commit in terraform seen (morgan_orange, 14:33:41)
    7. no update on cds repo (morgan_orange, 14:33:46)

  3. Guilin (morgan_orange, 14:33:53)
    1. CI status: Master unbroken by a revert (morgan_orange, 14:34:13)
    2. issue was on SDNC with a mix of 2 entry points (morgan_orange, 14:34:26)
    3. since sdnrb is disabled it is possible to onboard/instantiate (morgan_orange, 14:34:39)
    4. good thing is that we are able to properly revert (more than 2 weeks) (morgan_orange, 14:34:57)
    5. hope we will detect earlier next time - we detected it but not reported it strongly enough to OOM.. (morgan_orange, 14:35:21)
    6. https://logs.onap.org/onap-integration/weekly/onap_weekly_pod4_master/09-13-2020_06-09/ (morgan_orange, 14:35:38)
    7. new weekly master (every sunday) (morgan_orange, 14:35:45)
    8. include versions test -python/java) (morgan_orange, 14:35:53)
    9. issue last time, but manual run was OK and used to trigger a bunch of Jiras (morgan_orange, 14:36:12)
    10. https://logs.onap.org/onap-integration/daily/onap_daily_pod4_master/09-16-2020_06-09/ (morgan_orange, 14:36:33)
    11. last daily master: small/medium HC have been removed (morgan_orange, 14:36:44)
    12. new version of onap-helm (morgan_orange, 14:36:51)
    13. https://logs.onap.org/onap-integration/daily/onap_daily_pod4_master/09-16-2020_06-09/infrastructure-healthcheck/k8s/onap-helm/helm.html (morgan_orange, 14:37:03)
    14. nodeport certificate test also integrated (morgan_orange, 14:37:27)
    15. https://logs.onap.org/onap-integration/daily/onap_daily_pod4_master/09-16-2020_06-09/infrastructure-healthcheck/k8s/nodeport_check_certs/certificates.html (morgan_orange, 14:37:32)
    16. https://logs.onap.org/onap-integration/daily/onap_daily_pod4_master/09-16-2020_06-09/infrastructure-healthcheck/k8s/nodeport_check_certs/certificates.html (morgan_orange, 14:37:35)
    17. jiras also created for certificate issues (morgan_orange, 14:37:49)
    18. onap-tests basic_vm is back (morgan_orange, 14:38:01)
    19. blocking points (integration + security) summarized in https://wiki.onap.org/display/DW/Guilin+Integration+blocking+points (morgan_orange, 14:38:24)
    20. Release management created also a table (morgan_orange, 14:38:31)
    21. https://wiki.onap.org/display/DW/Correlation+of+Guilin+Issues+to+Release+Requirements+and+Component+Commitments (morgan_orange, 15:18:14)
    22. demo pythonsdk-tests (morgan_orange, 15:18:29)
    23. pythonsdk-tests is a little abstraction framework leveraging onapsdk (morgan_orange, 15:18:53)
    24. onapsdk in gitlab (morgan_orange, 15:19:08)
    25. a pypi repo is available (morgan_orange, 15:19:16)
    26. https://pypi.org/project/onapsdk/ (morgan_orange, 15:19:28)
    27. a version 1.0.0 had been created in August (morgan_orange, 15:19:41)
    28. a 7.0.0 (to follow ONAP release naming) is planned (morgan_orange, 15:20:00)
    29. the code is currently in freeze mode to be able to publish a 7.0.0 next week (morgan_orange, 15:20:16)
    30. pythonsdk-tests is using the develop branch for the moment, the idea is to use the 7.0.0 (morgan_orange, 15:20:33)
    31. https://gitlab.com/Orange-OpenSource/lfn/onap/python-onapsdk (morgan_orange, 15:20:44)
    32. https://git.onap.org/testsuite/pythonsdk-tests/tree/ (morgan_orange, 15:20:56)
    33. a dshbaord for the migration onap-tests to pythonsdk-tests has been created (morgan_orange, 15:21:07)
    34. https://wiki.onap.org/display/DW/Onap_tests+to+pythonsdk-tests+migration (morgan_orange, 15:21:32)
    35. illustration provided to explain the way pythonsd-test is structure ~ matroyshka mode with lot of heritage corresponding to steps (morgan_orange, 15:22:10)
    36. demo done with a simple Vm and a clearwater IMS (morgan_orange, 15:22:20)
    37. discussion with Amy on the table proposed by release management (morgan_orange, 15:24:50)
    38. first waivers granted (morgan_orange, 15:24:54)
    39. ACTION: morgan_orange pawel update security tests to include the waivers alredy given (seem mail from Krysztof) e.g. all the filebeats (morgan_orange, 15:25:19)
    40. lots of projects asked for waivers...the goal is not to hide the problems but find a way to address them... (morgan_orange, 15:25:56)
    41. the question of maintenance project has been raised during PTL meeting.. (morgan_orange, 15:26:09)
    42. and shall be addressed by TSC (morgan_orange, 15:26:18)
    43. recommendation, ,non mandatory components under maintenance must be excluded from the deployment and documented for a manual installation (morgan_orange, 15:26:47)
    44. unfortunately some maintenance components are needed (e.g. AAF) (morgan_orange, 15:27:05)
    45. stability test: morgan_orange shared the 3 weeks monitoring view of the Orange Openlab (Frankfurt maintenance release SR1) - community lab with manual operation + daily instantiation of 3 VNFs - RAM is increasing continuously over the 3 weeks. cassandra is consuming lots of resources, we can see some cleaning but globally it is increasing. The requirement on stability tests and metrics has been postponed (no resource) but we will (morgan_orange, 15:28:53)

  4. AoB (morgan_orange, 15:29:09)
    1. Amy indicates that too many pods (including our robot) are based on full distros and including lots of useless components. Typically the python 2.7 interpreter is present but not used in many cases. It is probably not the only component offering a broader surface of attack...tracked by the Jira but few resources to address them. (morgan_orange, 15:30:25)


Meeting ended at 15:30:28 UTC (full logs).

Action items

  1. morgan_orange finalize official procedure for new committers
  2. morgan_orange pawel update security tests to include the waivers alredy given (seem mail from Krysztof) e.g. all the filebeats


Action items, by person

  1. morgan_orange
    1. morgan_orange finalize official procedure for new committers
    2. morgan_orange pawel update security tests to include the waivers alredy given (seem mail from Krysztof) e.g. all the filebeats


People present (lines said)

  1. morgan_orange (73)
  2. collab-meetbot (3)


Generated by MeetBot 0.1.4.