#onap-int: Integration weekly meeting 16/12/2020

Meeting started by morgan_orange at 14:43:05 UTC (full logs).

Meeting summary

  1. action point follow-up (morgan_orange, 14:43:13)
    1. https://ircbot.wl.linuxfoundation.org/meetings/onap-int/2020/integration_weekly_meeting_9_12_2020/onap-int-integration_weekly_meeting_9_12_2020.2020-12-09-14.26.html (morgan_orange, 14:43:34)
    2. AP1 morgan alexander contact Jessica to see if it would be possible to add the script when building the dockers (morgan_orange, 14:43:48)
    3. mail thread initiated, PoC on vagrant to be done first then see how to insert the test within the build chain (morgan_orange, 14:44:12)
    4. AP2 morgan_orange create a page to list possible new tests => team will vote for the priorities... (morgan_orange, 14:44:24)
    5. done (morgan_orange, 14:44:26)
    6. https://wiki.onap.org/display/DW/Honolulu+Integration+Test+priorities (morgan_orange, 14:44:54)
    7. AP3 morgan_orange contact China mobile to see the status of the test (morgan_orange, 14:45:51)
    8. done, comments added in JIRA (morgan_orange, 14:45:58)
    9. https://jira.onap.org/browse/INT-1356 (morgan_orange, 14:48:43)
    10. AP4 morgan_orange Krzysztof fix build chain (morgan_orange, 14:49:00)
    11. not done yet (morgan_orange, 14:49:03)
    12. 1.7.3 expected for guilin maintenance release... (morgan_orange, 14:49:13)
    13. AP5 morgan_orange create a ticket to track the fact that the duration=f(t) seems to increase in average (morgan_orange, 14:49:56)
    14. done (morgan_orange, 14:49:59)
    15. https://jira.onap.org/browse/SO-3419?filter=-2 (morgan_orange, 14:50:23)

  2. demo (morgan_orange, 14:51:12)
    1. demo of basic_cds (morgan_orange, 14:51:17)
    2. shall be available in master daily CI ..still minor config issue to be fixed... (morgan_orange, 14:51:32)
    3. ACTION: morgan_orange have a look at xtesting_onap configuration (morgan_orange, 14:51:40)
    4. demo OK done on daily master (morgan_orange, 14:51:46)
    5. | basic_cds | integration | 00:16 | PASS | (morgan_orange, 14:51:58)
    6. it verifies the possibility to contact the CDS (open nodeport) + enrich CBA (morgan_orange, 14:52:16)
    7. it is part of healthcheck as it deals onlys with CDS (morgan_orange, 14:52:26)
    8. the rule => 1 component = healthcheck, multiple components = smoke (morgan_orange, 14:52:46)
    9. video available soon.. (morgan_orange, 14:52:54)
    10. demo basic_clamp (morgan_orange, 14:53:00)
    11. viedo also available soon... (morgan_orange, 14:53:07)
    12. test creates a VF in SDC, includes a TCA blueprint in the service, certifies the services, distributes the services, wait for distribution. Then contact Clamp (using old certificate based method), then check the policies, creates a loops and deploys the loop in Policy Engine and triggers the creation of a pod through DCAE (morgan_orange, 14:54:55)
    13. demo was OK (morgan_orange, 14:55:01)
    14. still in patch, several fixes needed before going to CI (morgan_orange, 14:55:16)
    15. settings refactoring => workaround needed as pythonsdk-test and onap-sdk path shall be in python path, copy of the onapsdk config file done in pythonsdk-tests (morgan_orange, 14:55:49)
    16. functional test shall be amended (currently failing in python-onapsdk) ..some difficulties to re run it on local env (morgan_orange, 14:56:16)
    17. the option to use the basic auth shall be also implemented in python-onapsdk (better that the certificate based authentication to clamp) (morgan_orange, 14:56:41)

  3. Honolulu (morgan_orange, 14:56:51)
    1. simu wrapper proposal presented by Eli (morgan_orange, 14:57:10)
    2. https://wiki.onap.org/display/DW/Pythonsdk-test+wrapper+for+simulators (morgan_orange, 14:57:21)
    3. AGREED: (morgan_orange, 14:57:27)
    4. discussion on stability test evolution (morgan_orange, 14:57:55)
    5. https://wiki.onap.org/display/DW/Honolulu+stability+test+evolution (morgan_orange, 14:57:58)
    6. looking forward to your feedback on the acurate KPIs to define the stability (morgan_orange, 14:58:14)
    7. what kind of tests, which figures (morgan_orange, 14:58:25)
    8. natacha will help me to build testsuite to be run as part of stability stage in weekly deployments (morgan_orange, 14:58:46)
    9. testsuite back to OOM in progress (morgan_orange, 14:58:58)
    10. topic still open.. (morgan_orange, 14:59:06)
    11. any volunteer welcome (morgan_orange, 15:03:09)
    12. CI/CD evolution (morgan_orange, 15:03:40)
    13. no resource on Nokia side to fully manage the CI/CD part of windriver (for the use cases and eventually some diversity testing) (morgan_orange, 15:04:06)

  4. AoB (morgan_orange, 15:04:16)
    1. Andreas reporting some issues on helm3 installation (Maria DB + pb Clamp failing) (morgan_orange, 15:04:38)
    2. PNF use case (macro) available but blocked by an issue on SDC (Jira created) (morgan_orange, 15:05:08)


Meeting ended at 15:05:17 UTC (full logs).

Action items

  1. morgan_orange have a look at xtesting_onap configuration


Action items, by person

  1. morgan_orange
    1. morgan_orange have a look at xtesting_onap configuration


People present (lines said)

  1. morgan_orange (56)
  2. collab-meetbot (4)


Generated by MeetBot 0.1.4.