#onap-int: Integration weekly meeting 18/11/2020

Meeting started by morgan_orange at 14:41:53 UTC (full logs).

Meeting summary

  1. action point follow up (morgan_orange, 14:42:00)
    1. no AP from last week (morgan_orange, 14:42:05)

  2. admin (morgan_orange, 14:42:24)
    1. discussion on real time support (morgan_orange, 14:42:32)
    2. currently we are using a rockect chat self-hosted solution (morgan_orange, 14:42:54)
    3. open question on the opportunity to move to slack (morgan_orange, 14:43:04)
    4. slack chan created by LF (Kenny) (morgan_orange, 14:43:11)
    5. some companies are not allowed to connect to rocket/slack/irc/what'sapp ...and rules are different from one company to another (morgan_orange, 14:43:46)
    6. keep on rocket chat for the moment (morgan_orange, 14:43:55)
    7. michal indicates that there is a bug with client 3.x (morgan_orange, 14:44:07)
    8. christophe reports that it is a client bug and there is a workaround (morgan_orange, 14:44:27)
    9. https://github.com/RocketChat/Rocket.Chat.Electron/issues/1743 (morgan_orange, 14:44:38)
    10. christophe has the admin credentials for this self hosted instance => possible to update if needed (morgan_orange, 14:44:59)
    11. AGREED: remain on rocket chat (morgan_orange, 14:45:16)
    12. committer: Lasse officially granted committer (morgan_orange, 14:45:28)
    13. ACTION: morgan_orange update all the INFO.yaml of all the Integration repositories (morgan_orange, 14:45:47)

  3. Staging labs (morgan_orange, 14:45:53)
    1. morgan_orange crashed several VMs from infrastructure prohect (alle xcept the 2 locked one (docker/proxy) (morgan_orange, 14:46:21)
    2. as a consequence we lost our Jenkins VM that was used to bootstrap SB-00 labs and managing the the Windriver CD (morgan_orange, 14:46:47)
    3. as nobody was really maintaining this system => good opportunity to change the CD on windriver (morgan_orange, 14:47:09)
    4. several options (morgan_orange, 14:47:13)
    5. nokia chain / terraform chain / gitlab-ci chain /.. (morgan_orange, 14:47:29)
    6. we have a short term need => reinstall SB-00 for MDONS (morgan_orange, 14:47:41)
    7. and a longer term setup CD that makes sense... (morgan_orange, 14:48:00)
    8. morgan_orange contacted Nokia (OK for a PoC) and terraform team (wait for feedback) (morgan_orange, 14:48:22)
    9. work on exporting CI chain (azure/gating/daily/weekly) in windriver lab (morgan_orange, 14:48:44)
    10. please note that a full reinstallation of the DC could be done after guilin... (morgan_orange, 14:48:56)
    11. morgan_orangenoticed that resources are poorly cleaned. Lors of instances/volumes/server gtroup withou any project (morgan_orange, 14:49:18)
    12. christophe remarks that some buttons recently disappeared..troubleshotting to be continue offline...consequence of the VM wild cleanup? (morgan_orange, 14:49:52)

  4. Guilin (morgan_orange, 14:50:00)
    1. documentation refactored (morgan_orange, 14:50:09)
    2. wiki (morgan_orange, 14:50:12)
    3. https://wiki.onap.org/display/DW/Integration+Project (morgan_orange, 14:50:20)
    4. official doc (morgan_orange, 14:50:25)
    5. https://docs.onap.org/projects/onap-integration/en/latest/index.html (morgan_orange, 14:50:41)
    6. doc still need to be updated for guilin (morgan_orange, 14:50:51)
    7. any feedback welcome... (morgan_orange, 14:50:57)
    8. democe cmpv2/pnf simulator postponed to next week (morgan_orange, 14:51:19)
    9. CI status (morgan_orange, 14:51:25)
    10. Daily master and Guilin are back (morgan_orange, 14:51:38)
    11. issues due to postconfigure (kubespray installation) and prometheus oeprtor (helm v3 cleanup of old unmaitained helm2 charts) (morgan_orange, 14:52:09)
    12. sylvain fixed the issue, 2 chains re run today (morgan_orange, 14:52:21)
    13. daily master issue due to docker hub (morgan_orange, 14:52:31)
    14. https://logs.onap.org/onap-integration/daily/onap_daily_pod4_master/11-18-2020_07-11/ (morgan_orange, 14:52:57)
    15. https://logs.onap.org/onap-integration/daily/onap_daily_pod4_master/11-18-2020_07-11/infrastructure-healthcheck/k8s/kubernetes-status/pod-onap-sdc-fe-866576b8dd-6xkh2.html (morgan_orange, 14:53:05)
    16. Failed to pull image "dibi/envsubst": rpc error: code = Unknown desc = Error response from daemon: toomanyrequests: You have reached your pull rate limit. You may increase the limit by authenticating and upgrading: https://www.docker.com/increase-rate-limit (morgan_orange, 14:53:14)
    17. similar issue reported by CSIT (morgan_orange, 14:53:25)
    18. ACTION: morgan_orange contact LF/TSC as it may be blocking.. (morgan_orange, 14:53:40)
    19. daily guilin https://logs.onap.org/onap-integration/daily/onap_daily_pod4_master/11-18-2020_07-11/ (morgan_orange, 14:54:02)
    20. dsashboard is wrong because the guilin pod was not declared in DB (done) (morgan_orange, 14:54:16)
    21. error due to bad start of so-openstack-adpater. Deleting of the pod => everything OK (morgan_orange, 14:54:36)
    22. | basic_vm | integration | 14:36 | PASS | (morgan_orange, 14:54:54)
    23. ok for redeployement of staging 3 (morgan_orange, 14:55:16)
    24. main info of last week was the merge of so 1.7.9 (morgan_orange, 14:56:07)
    25. 1.7.10 merged meanwhile.. (morgan_orange, 14:56:15)
    26. huge work by OPOM to help SO to test their patch on staging azure (morgan_orange, 14:56:29)
    27. RC0 are then OK from integration perspective since last friday.. (morgan_orange, 14:58:37)
    28. now time to resetup env for use cases (morgan_orange, 14:58:49)
    29. use cases...what are the use cases for guilin...it is not clear (at least to me) (morgan_orange, 14:59:06)
    30. the JIRA tables that replaced the wiki table only mentioned new stuff but not maintained use cases (morgan_orange, 14:59:30)
    31. difference between the requirements and the use cases not crystal clear.. (morgan_orange, 14:59:44)
    32. some use cases (vFW CL and scale out shall be rested by Christophe) but it is not really tracked (morgan_orange, 15:00:08)
    33. ACTION: morgan_orange send a mail to TSC to ask for clarification (morgan_orange, 15:00:19)
    34. morgan_orange sent a mail to old frankfurt use case owners (not referenced in the jira)...no feedback so far (morgan_orange, 15:00:42)
    35. soem use case are discovering now how to generate the documentation (main part supposed to be ready at M4) (morgan_orange, 15:01:09)
    36. clearification needed in order to avoid missing use case and reference what is still supported (morgan_orange, 15:01:26)
    37. doc will highlight use casesthat have been tested on guilin + automatic tests, other tests could be declared as "not tested on Guilin" (morgan_orange, 15:01:55)
    38. onapsdk 7.2 released (morgan_orange, 15:02:27)
    39. https://pypi.org/project/onapsdk/ (morgan_orange, 15:02:44)
    40. - VES events sender - PNF instantiation - SDC Service/Resource category management - SDC Service2Service compositon - Doc fixes (morgan_orange, 15:02:54)
    41. 7.3 already in tracked (with some changes around Dmaap provided by Nokia) (morgan_orange, 15:03:13)
    42. basic_cds test also in progrerss (morgan_orange, 15:03:22)
    43. basic_clamp under finalization (vijay indictaed that the blueprint was uncorrect for guilin) (morgan_orange, 15:03:43)

  5. Honolulu (morgan_orange, 15:04:10)
    1. Music PoC in progress (morgan_orange, 15:04:19)
    2. ACTION: demo of CSIT / Music next week (morgan_orange, 15:04:29)
    3. opensk quesiton on where to put k8s client to create a nodeport for CDS (fixed planned in Honolulu now) (morgan_orange, 15:05:05)
    4. andreas and morgan suggests pythonsdk-tests (morgan_orange, 15:05:13)
    5. thierry indiictaed that for basic_cnf it is done at xtesting-onap level (system) (morgan_orange, 15:05:32)


Meeting ended at 15:05:42 UTC (full logs).

Action items

  1. morgan_orange update all the INFO.yaml of all the Integration repositories
  2. morgan_orange contact LF/TSC as it may be blocking..
  3. morgan_orange send a mail to TSC to ask for clarification
  4. demo of CSIT / Music next week


Action items, by person

  1. morgan_orange
    1. morgan_orange update all the INFO.yaml of all the Integration repositories
    2. morgan_orange contact LF/TSC as it may be blocking..
    3. morgan_orange send a mail to TSC to ask for clarification


People present (lines said)

  1. morgan_orange (81)
  2. collab-meetbot (3)


Generated by MeetBot 0.1.4.