#onap-int: Integration weekly meeting 23/09/2020

Meeting started by morgan_orange at 14:56:29 UTC (full logs).

Meeting summary

  1. Action point follow-up (morgan_orange, 14:56:42)
    1. AP1 morgan_orange finalize official procedure for new committers (morgan_orange, 14:56:52)
    2. done (morgan_orange, 14:56:55)
    3. AP2 morgan_orange pawel update security tests to include the waivers alredy given (seem mail from Krysztof) e.g. all the filebeats (morgan_orange, 14:57:01)
    4. work started (morgan_orange, 14:57:05)

  2. admin (morgan_orange, 14:57:15)
    1. windriver status (morgan_orange, 14:58:56)
    2. after PTL meeting decision was to reinstall SB-00 and install a backup azure version (morgan_orange, 14:59:23)
    3. on windriver, all the jenkins CI chains have been disabled, all Integration tenants cleand (morgan_orange, 14:59:43)
    4. and SB-00 ha sbeen reinstalled (morgan_orange, 14:59:50)
    5. cluster test done 24 after installation provided good results (morgan_orange, 15:00:00)
    6. https://logs.onap.org/onap-integration/windriver-SB00/2020-09-22/ (morgan_orange, 15:00:19)
    7. robot HC run this morning (+48) still OK (morgan_orange, 15:00:28)
    8. hope it will last longer than usual (morgan_orange, 15:00:38)
    9. the cleaning saved 5 labs so save RAM/Disk/Compute resources (morgan_orange, 15:01:01)
    10. installation of azure in the pipe But way to access to this lab to be setup (morgan_orange, 15:01:18)
    11. committers: congratulations to Lukasz, Michal and Thierry, they are now officially committers (morgan_orange, 15:01:54)
    12. all committers merge the INFO.yaml update on all the repositories (morgan_orange, 15:02:11)
    13. Note: Integration today is dealing with 22 active repositories (morgan_orange, 15:03:41)
    14. 5G-core-nf-simulator cds dc-simulator heatbridge mdons onap-python pnf-simulator python-testing-utils robot-utils terraform xtesting bbs csit demo integration onap-java11 oom pythonsdk-tests ran-simulator seccom testsuite (morgan_orange, 15:04:27)

  3. Guilin (morgan_orange, 15:04:47)
    1. https://logs.onap.org/onap-integration/daily/onap_daily_pod4_master/09-23-2020_10-09/ (morgan_orange, 15:05:19)
    2. strange status on smoke tests, wait for next iteration..if so JIRA may be needeed (5G, pnf, hvves => issues with ves collector, basic_ => issue with SDC) (morgan_orange, 15:06:10)
    3. It was 83% yesterday so wait and see.. (morgan_orange, 15:06:23)
    4. Blocking points follow UP (morgan_orange, 15:06:38)
    5. https://wiki.onap.org/display/DW/Guilin+Integration+blocking+points (morgan_orange, 15:06:46)
    6. review of the different categories (morgan_orange, 15:15:36)
    7. ACTION: all review your JIRA and update, for M4 we should not have High priority Jira opened for more then 36 hours, fix, or move them to Honolulu (morgan_orange, 15:16:28)
    8. no more code dev for Guilin (M4 rules apply also to integration/testsuite) (morgan_orange, 15:57:59)
    9. but adaptation/integration obviously still accepted (morgan_orange, 15:58:14)
    10. pythonsdk-tests: Andreas, thierry and myself were able to re-run successfully the demo showed last week + scenario on basic network (morgan_orange, 15:58:54)
    11. it is now time to see how to integrate it in CI (morgan_orange, 15:59:03)
    12. ACTION: morgan_orange package pythonsdk-tests in CI (morgan_orange, 15:59:16)
    13. maybe some help needed, please review the patch (morgan_orange, 15:59:27)
    14. https://gerrit.onap.org/r/c/testsuite/pythonsdk-tests/+/113002 (morgan_orange, 15:59:36)
    15. pythonsdk to be released this week (morgan_orange, 16:00:10)
    16. last topic to be finalised the k8s plugin in pythonsdk => to keep coverage at 98% (morgan_orange, 16:00:31)
    17. ACTION: michal see with Sylvain how to release the new version (morgan_orange, 16:01:59)
    18. discussions on future evolution started (morgan_orange, 16:02:08)
    19. use the etherpad to list what you would like to see (morgan_orange, 16:02:16)
    20. https://etherpad.opnfv.org/p/onap_integration_pythonsdk (morgan_orange, 16:02:27)
    21. ACTION: all complete the pythonsdk evolution etherpad (morgan_orange, 16:02:45)
    22. note no sessions planned during ONES summit => keep the usual slot (morgan_orange, 16:03:02)
    23. xfail lists for security tests (morgan_orange, 16:03:20)
    24. AGREED: waiver related patches must be +2/merged by SECCOM (not by integration) (morgan_orange, 16:03:39)
    25. open question on the current patch => Fabian set -1 / Amy +1 => exceptions are valid only during the release scope, and will be reste for Honolulu..so exceptions shall be seen as "will not be fixed for this released", the exception list should be used in the documentation to identify the weakness (morgan_orange, 16:04:58)
    26. presentation of tern results (morgan_orange, 16:05:08)
    27. tern is a docker inspectin tool for licenses (morgan_orange, 16:05:15)
    28. so far => static analysis of the repository (morgan_orange, 16:10:31)
    29. tern performs a dynamic analysis on the dockers (morgan_orange, 16:10:41)
    30. https://github.com/tern-tools/tern (morgan_orange, 16:11:10)
    31. tests done on 29 dockers (among the 165 deployed in master) => 70% contains GPLv3 (morgan_orange, 16:11:33)
    32. https://logs.onap.org/onap-integration/weekly/onap_weekly_pod4_master/09-20-2020_08-09/security/licenses/ (morgan_orange, 16:11:37)
    33. problem reported to TSC (as a requirement was not GPLv3 in the dockers we are building) (morgan_orange, 16:11:54)
    34. ACTION: morgan_orangecreate JIRA on HPLv3 (morgan_orange, 16:12:02)
    35. note that some fixes can be quick..if projects are using the alpine baseline image (java or python) it is GPLv3 free (morgan_orange, 16:12:26)
    36. it is a legal issues more than a security issues => see what TSC suggests (morgan_orange, 16:13:22)

  4. AoB (morgan_orange, 16:13:46)
    1. quesiton on CSIT tests, Lasse reported so issues (still dublin images referenced in some tests) (morgan_orange, 16:14:03)
    2. morgan sugest to clean/disable some tests (morgan_orange, 16:14:11)
    3. it would be good to initiate a guideline in order to help the project to bring back their functionnal tests in their repo and archive csit (morgan_orange, 16:14:37)
    4. some projects already did (SDC) (morgan_orange, 16:14:48)
    5. ACTION: lasse sent a mail on onap-discuss + initiate a wiki page to help the reinsourcing of csit tests (morgan_orange, 16:15:14)
    6. K has question on the capability of the k8s plugin in pythonsdk (morgan_orange, 16:15:32)
    7. Michal C indicates that a documentation exists (morgan_orange, 16:15:41)
    8. https://gitlab.com/Orange-OpenSource/lfn/onap/python-onapsdk/-/merge_requests/130 (morgan_orange, 16:16:15)
    9. this MR has to be merged for Guilin (morgan_orange, 16:16:23)


Meeting ended at 16:16:27 UTC (full logs).

Action items

  1. all review your JIRA and update, for M4 we should not have High priority Jira opened for more then 36 hours, fix, or move them to Honolulu
  2. morgan_orange package pythonsdk-tests in CI
  3. michal see with Sylvain how to release the new version
  4. all complete the pythonsdk evolution etherpad
  5. morgan_orangecreate JIRA on HPLv3
  6. lasse sent a mail on onap-discuss + initiate a wiki page to help the reinsourcing of csit tests


Action items, by person

  1. morgan_orange
    1. morgan_orange package pythonsdk-tests in CI
  2. UNASSIGNED
    1. all review your JIRA and update, for M4 we should not have High priority Jira opened for more then 36 hours, fix, or move them to Honolulu
    2. michal see with Sylvain how to release the new version
    3. all complete the pythonsdk evolution etherpad
    4. morgan_orangecreate JIRA on HPLv3
    5. lasse sent a mail on onap-discuss + initiate a wiki page to help the reinsourcing of csit tests


People present (lines said)

  1. morgan_orange (75)
  2. collab-meetbot (4)


Generated by MeetBot 0.1.4.