#onap-int: Integration weekly meeting 25/11/2020

Meeting started by morgan_orange at 15:22:35 UTC (full logs).

Meeting summary

  1. action point follow up (morgan_orange, 15:22:41)
    1. AP1: morgan_orange update all the INFO.yaml of all the Integration repositorie (morgan_orange, 15:22:59)
    2. done (morgan_orange, 15:23:00)
    3. AP2: morgan_orange contact LF/TSC for dockerhub policy change as it may be blocking.. (morgan_orange, 15:23:15)
    4. done, LF paied the 300$ annual fees => will be OK for jenkins/csit but not fix the daily deployement executed from gitlab.com on Orange servers or Azure (morgan_orange, 15:23:51)
    5. AP3: morgan_orange send a mail to TSC to ask for clarification on use case in guilin documentation (morgan_orange, 15:24:07)
    6. point clarified during TSC meeting, split doc into 2 parts: Guilin use cases (including new use cases, requirements and old use cases retested in guilin) + 1 part for old/deprecated use cases (morgan_orange, 15:24:54)
    7. AP4: demo of CSIT / Music next week (morgan_orange, 15:25:03)
    8. done see following topic (morgan_orange, 15:25:08)

  2. demo cmpv2 use case + pnf simulator (morgan_orange, 15:25:18)
    1. Krzysztof Kuzmicki shows the CMPV2 demo introduced in Guilin to demonstrate cmvp2 capabilities with ONAP (morgan_orange, 15:25:51)
    2. robot test integrated in CI (morgan_orange, 15:25:59)
    3. pnf-simu (ves-simu) has been updated (morgan_orange, 15:26:12)
    4. there are several pnf simu...it is a bit misleading (morgan_orange, 15:26:22)
    5. a pnf simulator was created several versions ago and not very maintained (morgan_orange, 15:26:43)
    6. a forw was done => mass-pnf (morgan_orange, 15:26:50)
    7. mass-pnf no more maintained (to be confirmed) (morgan_orange, 15:27:00)
    8. but legacy pnf simulator refactored, it offers a full REST API (with a swagger) to manage template/config (morgan_orange, 15:27:28)
    9. it can be used for CDS (to simulate a config update) or by loop tests to generate events (morgan_orange, 15:27:52)
    10. morgan_orange indicates it will make sense to referenc eit more properly in the official documentation (morgan_orange, 15:28:08)
    11. ACTION: morgan_orange create a tools section in official integration documentation (morgan_orange, 15:28:27)
    12. ACTION: contact mass-pnf simu to get a status (morgan_orange, 15:28:44)
    13. legacy pnf simu repo is here: (morgan_orange, 15:28:57)
    14. https://git.onap.org/integration/simulators/pnf-simulator/ (morgan_orange, 15:29:19)
    15. actions to be planned in Honolulu for a better identification of the simulators (morgan_orange, 15:29:39)
    16. KK indicates trhat he discovered some regression (cert authen working fine by basic auth no more) (morgan_orange, 15:29:59)
    17. ACTION: krzysztof fix pnf-simu basic authen (morgan_orange, 15:30:12)
    18. tests in progres on python-sdk tests were initiated with the mass-pnf simu... (morgan_orange, 15:30:33)
    19. cmpv2 tests will be improved in Honolulu (morgan_orange, 15:31:21)

  3. demo csit reactoring (morgan_orange, 15:31:29)
    1. lass presents the proposed flow for CSIT including a demo to illustrate the change with Music project (morgan_orange, 15:31:57)
    2. new jjb recreated (morgan_orange, 15:32:01)
    3. the goal is to reintegrate the CSIT in project repo and trigger them on patch submition rather than out of the blue in daily/csit (morgan_orange, 15:32:32)
    4. projects started doing differently (SDC) and some have inter project dependencies (mix of functionnal and integration tests) (morgan_orange, 15:32:56)
    5. the refactoring gives a real value to the tests for the project (morgan_orange, 15:33:13)
    6. it also imposes a review of the docker buil strategy (morgan_orange, 15:33:22)
    7. Lasse is discussing this refactoring with PTL during PTL meeting (morgan_orange, 15:33:36)
    8. Christophe indicates that providing also feedback from sona in this flow will be appreciated by the PTL (morgan_orange, 15:34:09)
    9. for the moment sonar is run as a daily batch indepandently from the code (morgan_orange, 15:34:46)
    10. ACTION: christophe contact Music to give a try on merge flow (morgan_orange, 15:35:01)
    11. https://wiki.onap.org/pages/viewpage.action?pageId=93001989 (morgan_orange, 15:53:25)

  4. AoB (morgan_orange, 15:53:31)
    1. ACTION: all committers review mail on release note (morgan_orange, 15:53:48)
    2. new tests expected on NBI/macro flow/pnf/basic clamp.. (morgan_orange, 15:54:08)
    3. thanks to Dan and KK for the installation of windriver staging SB-00 (morgan_orange, 15:54:33)
    4. 2 Guilin staging labs available for testing (morgan_orange, 15:54:43)


Meeting ended at 15:54:57 UTC (full logs).

Action items

  1. morgan_orange create a tools section in official integration documentation
  2. contact mass-pnf simu to get a status
  3. krzysztof fix pnf-simu basic authen
  4. christophe contact Music to give a try on merge flow
  5. all committers review mail on release note


Action items, by person

  1. morgan_orange
    1. morgan_orange create a tools section in official integration documentation
  2. UNASSIGNED
    1. contact mass-pnf simu to get a status
    2. krzysztof fix pnf-simu basic authen
    3. christophe contact Music to give a try on merge flow
    4. all committers review mail on release note


People present (lines said)

  1. morgan_orange (48)
  2. collab-meetbot (3)


Generated by MeetBot 0.1.4.