#onap-int: Integration Weekly meeting 26/08/2020

Meeting started by morgan_orange at 08:34:28 UTC (full logs).

Meeting summary

  1. action point follow up (morgan_orange, 08:34:38)
    1. https://ircbot.wl.linuxfoundation.org/meetings/onap-int/2020/weekly_integration_meeting_19_08_2020/onap-int-weekly_integration_meeting_19_08_2020.2020-08-19-15.00.html (morgan_orange, 08:34:47)
    2. AP1 morgan_orange amine andreas thierry give a try to Michal structure with existing tests (basic_vm, basic_vm(yaml), basic_clamp, basic_network) (morgan_orange, 08:34:59)
    3. test done, first patch merged, see dedicated sections below (morgan_orange, 08:35:19)

  2. Admin (morgan_orange, 08:35:36)
    1. windriver: OPNFV functest test setup to evaluate performance on Intel/Windriver lab (morgan_orange, 08:36:13)
    2. last VMTP tests showed that the performance are lower than they used to be before the move and after OPNFV (Cédric) audit (morgan_orange, 08:36:45)
    3. tests needed to confirm that (morgan_orange, 08:36:53)
    4. Andreas cofirms that low level infra issues have a big impact on ONAP (morgan_orange, 08:37:16)
    5. ACTION: morgan_orange redo some tests then conctact Intel/Windriver lab team to report results and see how to proceed to improve (morgan_orange, 08:37:46)
    6. as the machines have been reinstalled after the move, it could look like a MTU setting /switching issues (morgan_orange, 08:38:23)
    7. a risk has been raised for Guilin on the availability of an Integration lab for the use cases (morgan_orange, 08:39:09)
    8. ACTION: morgan_orange send mail to use case onwers + PTL to report infra test status (morgan_orange, 08:39:34)
    9. new repositories available (sdc and terraform) (morgan_orange, 08:39:53)
    10. strange => creation done with the self-service method, but INFO.yaml created is not reported in the repository (an additional patch is needed) (morgan_orange, 08:40:23)
    11. baseline image follow up: Python 7.0.1 (no ONBUILD constraints) released (morgan_orange, 08:40:46)
    12. tern-tool test on the baseline image planned by dmaap showed the presence of GPLv3 (morgan_orange, 08:41:10)
    13. xtesting dockers: frankfurt dockers created (morgan_orange, 08:41:22)
    14. it is now possible to precise that the branch can be used in docker build probess (not only tags) (morgan_orange, 08:41:40)
    15. howver classical issue => master branch lead to master tags, where latest is used (no master tags) (morgan_orange, 08:42:09)
    16. issue reported to Jessica through a LF ticket (morgan_orange, 08:42:19)

  3. Maintenance releases (morgan_orange, 08:42:54)
    1. El Alto and Frankfurt release officially available (morgan_orange, 08:43:08)
    2. both CI chains still run on Orange HW (morgan_orange, 08:43:17)

  4. Guilin (morgan_orange, 08:43:26)
    1. demo Pawel on version check (morgan_orange, 08:43:32)
    2. sub demo focusing on introspection of AAI dockers to verify Java and python versions according to SECCOM recommendations (morgan_orange, 08:43:55)
    3. parallelization needed because a full sequential audit would take more than 2h (morgan_orange, 08:44:34)
    4. the demo (AAI only) takes ~10 minutes (morgan_orange, 08:44:44)
    5. the introspector connect to each pod and run a version command line (morgan_orange, 08:44:59)
    6. results are cllected and compared to the reference versions set by SECCOM (morgan_orange, 08:45:12)
    7. work in progress to optimize the test duration (morgan_orange, 08:45:26)
    8. goal is to include it in security xtesting docker (morgan_orange, 08:45:38)
    9. AGREED: put all the xfail lists in integration/seccom (morgan_orange, 08:45:58)
    10. for the moment some are in integration repo some in xtesting repo (morgan_orange, 08:46:09)
    11. ACTION: pawel morgan_orange move all the waiver/xfail lists in integration/seccom + adapt the Dockerfile accordingly (morgan_orange, 08:46:40)
    12. pythonsdk basic_vm (without the cleaning) executed successfully on daily_frankfurt last friday (morgan_orange, 08:47:10)
    13. test structure validated and merged (morgan_orange, 08:47:23)
    14. https://gerrit.onap.org/r/c/testsuite/pythonsdk-tests/+/110288 (morgan_orange, 08:48:19)
    15. several JIRAs have been created to start from this structure and start implementing new use cases (morgan_orange, 08:48:38)
    16. the 3 ones used in Frankfurt based onap_tests shall be replaced + new ones (morgan_orange, 08:49:01)
    17. https://wiki.onap.org/display/DW/Onap_tests+to+pythonsdk-tests+migration (morgan_orange, 08:49:20)
    18. goal is to migrate on Master for mid september (onap_tests are not fully reliable due to customer race conditions in SDC), new versions shall be more reliable and trustable (morgan_orange, 08:49:55)
    19. discussions on how to manage multicloud/no multicloud configuration => change in DB needed or use 2 Cloud regions (morgan_orange, 08:50:30)
    20. ACTION: Thierry andreas find the best way to cover both options (morgan_orange, 08:50:45)
    21. andreas working onmacro workflow using CDS + Multicloud for vFW (morgan_orange, 08:51:06)
    22. still k8s operations needed for CDS (expose a node port) (morgan_orange, 08:51:17)
    23. demo testsuite DB: how do we define tests/pods (morgan_orange, 08:51:43)
    24. hwo to push results (morgan_orange, 08:51:47)
    25. how to create your own test DB/Test API (morgan_orange, 08:51:55)
    26. use the ansible galacy role created by C.Ollivier (OPNFv Functest) (morgan_orange, 08:52:08)
    27. https://wiki.opnfv.org/pages/viewpage.action?pageId=29098314 (morgan_orange, 08:52:21)
    28. for public reporting you can use testresults.opnfv.org (morgan_orange, 08:52:32)
    29. reporting page is created through a python scrypt (morgan_orange, 08:53:35)
    30. https://gitlab.com/Orange-OpenSource/lfn/onap/xtesting-onap/-/blob/master/doc/generate_status.py (morgan_orange, 08:53:37)

  5. AoB (morgan_orange, 08:53:42)
    1. Andreas detected a regression in master for E2E tests due to the misalignement between AAI (new fields) and SO (morgan_orange, 08:54:02)
    2. ACTION: andreas create a JIRA on SO/AAI data change problem in master (morgan_orange, 08:54:22)


Meeting ended at 08:54:51 UTC (full logs).

Action items

  1. morgan_orange redo some tests then conctact Intel/Windriver lab team to report results and see how to proceed to improve
  2. morgan_orange send mail to use case onwers + PTL to report infra test status
  3. pawel morgan_orange move all the waiver/xfail lists in integration/seccom + adapt the Dockerfile accordingly
  4. Thierry andreas find the best way to cover both options
  5. andreas create a JIRA on SO/AAI data change problem in master


Action items, by person

  1. morgan_orange
    1. morgan_orange redo some tests then conctact Intel/Windriver lab team to report results and see how to proceed to improve
    2. morgan_orange send mail to use case onwers + PTL to report infra test status
    3. pawel morgan_orange move all the waiver/xfail lists in integration/seccom + adapt the Dockerfile accordingly
  2. UNASSIGNED
    1. Thierry andreas find the best way to cover both options
    2. andreas create a JIRA on SO/AAI data change problem in master


People present (lines said)

  1. morgan_orange (60)
  2. collab-meetbot (3)


Generated by MeetBot 0.1.4.