#onap-int: Integration weekly meeting 9/12/2020

Meeting started by morgan_orange at 14:26:15 UTC (full logs).

Meeting summary

  1. Action point follow-up (morgan_orange, 14:26:38)
    1. https://ircbot.wl.linuxfoundation.org/meetings/onap-int/2020/integration_weekly_meeting_2_12_2020/onap-int-integration_weekly_meeting_2_12_2020.2020-12-03-16.31.html (morgan_orange, 14:26:50)
    2. AP1 contact mass-pnf simu to get a status (morgan_orange, 14:27:01)
    3. done, Ericcson responds that no one on their side was maintaining sur simualtor anymore (morgan_orange, 14:27:26)

  2. discussion MDONS use case (morgan_orange, 14:27:47)
    1. presentation of the use case MDONS extension (morgan_orange, 14:27:58)
    2. https://wiki.onap.org/display/DW/Integration+Meeting+Minutes?preview=%2F11930007%2F93003492%2FMDONS-Extension-R7.pdf (morgan_orange, 14:29:02)
    3. MDON (Multiple Domain Optical Networks) was introduced in Frankfurt (morgan_orange, 14:29:24)
    4. see presentation for call flows and architecture (morgan_orange, 14:29:37)
    5. it is based on MEF modelisation, In trankfurts it fulfills an interco between a Fujitsu equipment and openRoadm (morgan_orange, 14:30:27)
    6. work for a compelte multi Service Provider including transport PCE (morgan_orange, 14:30:42)
    7. in OOF the main change is the use of OOF and setup of CL for the optimal optical path computation (event sent in VES in cas of bad interdfomain link or error) (morgan_orange, 14:31:26)
    8. a Domain Controller simulator was developed in F but needs to be improved if we want to use it for automate the use case (morgan_orange, 14:31:57)
    9. test done on real physical equipment (morgan_orange, 14:32:10)
    10. test scripts shall also be improved (morgan_orange, 14:32:24)

  3. Honolulu (morgan_orange, 14:32:33)
    1. discussion on the license verification (morgan_orange, 14:32:50)
    2. a tern PoC test was done in September (morgan_orange, 14:33:59)
    3. few pods were tested and results pushed to LF backend (morgan_orange, 14:34:13)
    4. https://logs.onap.org/onap-integration/weekly/onap_weekly_pod4_master/09-20-2020_08-09/security/licenses/aaf-core.html.gz (morgan_orange, 14:34:28)
    5. Tern is pretty clear on the layer and the components/licenses introduced by layer (morgan_orange, 14:34:45)
    6. LF whitesource tool (used in SaaS mode) also provides some licesing information (morgan_orange, 14:35:03)
    7. PTL shall have an access to this kind of tools (like sonarcloud) (morgan_orange, 14:35:21)
    8. but it is not directly linked to the code (morgan_orange, 14:35:29)
    9. to run Ten, some priviledges are needed and the test is relatively long (morgan_orange, 14:35:50)
    10. discussion on where such test shall be triggered (morgan_orange, 14:36:02)
    11. 2 possible options: in the integration chain (weekly chain) or in the docker build creation chain (LF / jenkins when asking for new release) (morgan_orange, 14:36:37)
    12. ACTION: morgan alexander contact Jessica to see if it would be possible to add the script when building the dockers (morgan_orange, 14:37:04)
    13. if not possible a temp solution could be to run in the CI chain (fully managed by Integration) (morgan_orange, 14:39:28)
    14. testsuite back to OOM in progress (morgan_orange, 14:39:28)
    15. on Master oom/testsuite is now emptu, the code has been transfered back to OOM (morgan_orange, 14:39:29)
    16. for guilin change oom/testsuite remains the rught place (but change directly in guilin branch - no Master/cherry pick) (morgan_orange, 14:39:29)
    17. reflexion on the evolution of the robot pod to be done (morgan_orange, 14:39:30)
    18. pod run as root, using an ubuntu image, without limits including python 2.7, not cloud native (robot and DB in the same pod)...we can do better (morgan_orange, 14:39:30)
    19. evolution initiated by D.Rose (split nginx/robot) (morgan_orange, 14:39:36)
    20. work to be completed... (morgan_orange, 14:39:52)
    21. look for volunteer to refactor the robot pod in H... (morgan_orange, 14:40:02)
    22. where shall we focus our resources for H... (morgan_orange, 14:40:27)
    23. ACTION: morgan_orange create a page to list possible new tests => team will vote for the priorities... (morgan_orange, 14:40:52)
    24. several new tests already in the pipe (nasic_cds, basic_clamp, macro with PNF,..) (morgan_orange, 14:41:15)
    25. automation of vFW CL/Scale out...doc updated (morgan_orange, 14:41:35)
    26. qui of vCPE Tosca (morgan_orange, 14:41:40)
    27. ACTION: morgan_orange contact China mobile to see the status of the test (morgan_orange, 14:41:52)
    28. CI/CD evolution => continue reflexion offline, but reinstallation of Windriver not before Q2 2021..we will ahve to live with the existing windriver for H (morgan_orange, 14:42:30)

  4. Guilin (morgan_orange, 14:42:41)
    1. doc finalized (morgan_orange, 14:42:44)
    2. testsuite 1.7.3 (morgan_orange, 14:42:53)
    3. build chain seems broken but lots of instability on jenkins last days (morgan_orange, 14:43:09)
    4. new changes done by Brian for vFW CL to be integrated for Guilin (morgan_orange, 14:43:25)
    5. ACTION: morgan_orange Krzysztof fix build chain (morgan_orange, 14:43:38)
    6. stability test page updated (morgan_orange, 14:43:49)
    7. https://logs.onap.org/production/vex-yul-ecomp-jenkins-1/rtdv3-global-verify-master/3024/docs/integration-s3p.html#integration-s3p (morgan_orange, 14:44:03)
    8. memory leak detected on SDNC (morgan_orange, 14:44:10)
    9. https://jira.onap.org/browse/SDNC-1430 (morgan_orange, 14:44:30)
    10. we also observed that the average time of test is increasing (morgan_orange, 14:44:55)
    11. ACTION: morgan_orange create a ticket to track the fact that the duration=f(t) seems to increase in average (morgan_orange, 14:45:33)


Meeting ended at 14:45:57 UTC (full logs).

Action items

  1. morgan alexander contact Jessica to see if it would be possible to add the script when building the dockers
  2. morgan_orange create a page to list possible new tests => team will vote for the priorities...
  3. morgan_orange contact China mobile to see the status of the test
  4. morgan_orange Krzysztof fix build chain
  5. morgan_orange create a ticket to track the fact that the duration=f(t) seems to increase in average


Action items, by person

  1. morgan_orange
    1. morgan_orange create a page to list possible new tests => team will vote for the priorities...
    2. morgan_orange contact China mobile to see the status of the test
    3. morgan_orange Krzysztof fix build chain
    4. morgan_orange create a ticket to track the fact that the duration=f(t) seems to increase in average


People present (lines said)

  1. morgan_orange (59)
  2. collab-meetbot (3)


Generated by MeetBot 0.1.4.