#onap-int: Integration weekly meeting 12/02/2020

Meeting started by morgan_orange at 14:00:45 UTC (full logs).

Meeting summary

  1. action point follow up (morgan_orange, 14:00:49)
    1. AP1: morgan_orange organize ad hoc meeting with lab owners to share tooling and best practices (morgan_orange, 14:00:54)
    2. done, mail sent to Open Lab subcommitee, wait for feedback (morgan_orange, 14:00:58)
    3. AP2: pawel complete the scripts to exclude false positive (morgan_orange, 14:01:01)
    4. done for jdwp (morgan_orange, 14:01:06)
    5. https://gerrit.onap.org/r/c/integration/+/101517 (morgan_orange, 14:01:13)
    6. still to be done for http endpoints (morgan_orange, 14:01:14)
    7. mail sent to the community to collect the exception for HTTP exposure (morgan_orange, 14:01:18)
    8. ACTION: : pawel complete the scripts to exclude false positive in http_endpoints scanning (morgan_orange, 14:01:23)
    9. AP3: all review the page and adjust the criteria / morgan to report to David before the end of the week (morgan_orange, 14:01:28)
    10. link sent to David Mc Bride (morgan_orange, 14:08:58)
    11. AP4: morgan_orange create JIRA on OOF and VFC (morgan_orange, 14:09:09)
    12. done (morgan_orange, 14:09:14)
    13. https://jira.onap.org/browse/OPTFRA-697 (morgan_orange, 14:09:20)
    14. fixed and merge (morgan_orange, 14:09:24)
    15. https://jira.onap.org/browse/VFC-1616 (morgan_orange, 14:09:29)
    16. fixed wait for merge (morgan_orange, 14:09:34)
    17. AP5: morgan move ingress_nodeport to infrastructure-healthcheck (morgan_orange, 14:09:41)
    18. done (morgan_orange, 14:10:15)

  2. Feedback from the Syncho with Seccom/OOM (morgan_orange, 14:10:24)
    1. meeting last week with seccom (morgan_orange, 15:54:06)
    2. conclusion can be found in https://wiki.onap.org/display/DW/Docker+and+Kubernetes+Security (morgan_orange, 15:54:54)
    3. priority pod_roots, then remove jdpw ports, reduce list of public HTTP endpoints, improve CIS as much as possible (morgan_orange, 15:55:25)

  3. Admin (morgan_orange, 15:55:34)
    1. Specific Integration milestones to be defined and reported to David McBride: Integration M4 milestone possible evolution (morgan_orange, 15:55:41)
    2. Update on Integration verification job (morgan_orange, 15:55:45)
    3. python verification job added in Integration repo (for vCPE) (morgan_orange, 15:55:51)
    4. alias team.onap.eu created (morgan_orange, 15:55:55)
    5. reinsourcing of oom/robot in robot: https://gerrit.onap.org/r/c/oom/+/101605 (morgan_orange, 15:56:03)
    6. oom/robot was initially in oom repository, then it was decided to use submodules (aai then robot did the work to externalize the helm charts). But the OOM position is now to come back to first view as it is very difficult to manage for OOM team especially when refactoring for secret, common DB, .. (morgan_orange, 15:59:22)

  4. Lab Status (morgan_orange, 15:59:30)
    1. no update (morgan_orange, 15:59:47)

  5. Frankfurt status (morgan_orange, 15:59:52)
    1. Use case update (morgan_orange, 16:00:17)
    2. PNF onboarding blocked by DCAE issue. Patch submitted to fix it (morgan_orange, 16:00:42)
    3. https://gerrit.onap.org/r/c/oom/+/99998 (morgan_orange, 16:00:54)
    4. issues dealing with AAF under investigation on Gating part (Only Orange platform seems to be impacted - better results on Azure) (morgan_orange, 16:02:29)
    5. vFW use case - no change (morgan_orange, 16:02:49)
    6. scaleout will include improvement on CDS side (morgan_orange, 16:02:55)
    7. preload ONAP with some date including which controller we want to use (morgan_orange, 16:03:02)
    8. leverage the latest CDS functionalities (preload data) (morgan_orange, 16:03:08)
    9. in previous release, some manual steps where needed (which controllers in SO) (morgan_orange, 16:03:17)
    10. still work needed on integration (morgan_orange, 16:03:25)
    11. Prahbu provided an update on use case 18 - more a feature than a use case (morgan_orange, 16:04:40)
    12. wiki and rst files have been updated (morgan_orange, 16:05:03)
    13. https://gerrit.onap.org/r/#/c/sdc/+/82573/3/docs/configuration.rst (morgan_orange, 16:05:05)
    14. https://gerrit.onap.org/r/#/c/sdc/+/82573/3/docs/externaltesting.rst (morgan_orange, 16:05:13)
    15. it is an extended feature of Dublin release in SDC and has been successfully tests in Vodafone and Huawei's lab (morgan_orange, 16:05:47)
    16. Tech Mahindra working on stability test (72h) (morgan_orange, 16:06:40)
    17. discussions in progress with Brian (the right person) (morgan_orange, 16:06:53)
    18. documentaiton is lacking (morgan_orange, 16:06:59)
    19. morgan_orange suggests to start a doc based on exchanges with Brian as such tests are very valuabel, should be runnable in any lab and even extended (morgan_orange, 16:07:44)
    20. discussion during Prague DDF on this topic (morgan_orange, 16:07:53)
    21. https://wiki.lfnetworking.org/pages/viewpage.action?pageId=25364127&preview=/25364127/28738378/performance_robustness_tests_final.pdf (morgan_orange, 16:08:48)
    22. DCAE and pnf_registrate tests blocked by DCAE issue (morgan_orange, 16:09:18)
    23. Portal tests: morgan_orange sent a mail to Portal PTL to know if there is any test plan. It would be nice to add basic tests (login/logout of all users, browsing, access to sub pages) (morgan_orange, 16:09:57)
    24. a test already exists (healthportalapp but 5 tests are failing (and all users not tested) but it could be a good base (morgan_orange, 16:10:31)
    25. refactoring would be needed but it could bring value all the more as we can integrate it in the gate (morgan_orange, 16:10:57)
    26. Open question on "basic CDS" test availability (morgan_orange, 16:11:35)
    27. ACTION: Get Feedback from Yuri on the availability of such test (as CDS had some issue in El Alto release - we should test it more and automate basic test to give more trust to end users) (morgan_orange, 16:12:16)
    28. update on CM and k8s/CDS: Lukasz is confident, good progress done by Samsung team, integration phase started (no patchset pending for the moment) (morgan_orange, 16:13:16)
    29. JIRA status (morgan_orange, 16:13:36)
    30. https://jira.onap.org/secure/RapidBoard.jspa?rapidView=207&quickFilter=630 (morgan_orange, 16:13:36)
    31. in the blocking point there is an open JIRA dealing with Log and pomba which is not supported in Frankfurt (morgan_orange, 16:13:57)
    32. ACTION: morgan_orange contact Andrew to see if the log/pomba blocking point is still relevant (morgan_orange, 16:14:14)
    33. New A&AI regression detected (no more tenant id leading to failure of the end to end VNF tests) (morgan_orange, 16:14:24)
    34. Jimmy built a staging docker, successfully tested on windriver, a release version shall be built very soon (morgan_orange, 16:14:48)
    35. CI status (morgan_orange, 16:14:57)
    36. Master status (morgan_orange, 16:15:01)
    37. https://orange-opensource.gitlab.io/lfn/tools/results_ts_view/ (morgan_orange, 16:15:08)
    38. status relatively stable, several fix APPC, OOF expected soon (morgan_orange, 16:15:40)
    39. Parallelization of the VNF and security tests (to save CI time) in progress to save CI time and keep CI under control (morgan_orange, 16:16:06)
    40. windriver CI still pending - runner is working well but clean/server creation seems to request parameters that do not fit well together (morgan_orange, 16:16:16)

  6. AoB (morgan_orange, 16:16:19)
    1. time slot to be planned for Estech simulator presentation to Integration team (morgan_orange, 16:16:34)
    2. Kube-hunter new security test introduce to report k8s vulnerabilities (morgan_orange, 16:16:57)
    3. morgan_orange will be in PTO until the 26th, Marco and Brian will be your Master of Ceremony for next weekly meetings (morgan_orange, 16:17:43)


Meeting ended at 16:17:45 UTC (full logs).

Action items

  1. : pawel complete the scripts to exclude false positive in http_endpoints scanning
  2. Get Feedback from Yuri on the availability of such test (as CDS had some issue in El Alto release - we should test it more and automate basic test to give more trust to end users)
  3. morgan_orange contact Andrew to see if the log/pomba blocking point is still relevant


Action items, by person

  1. morgan_orange
    1. morgan_orange contact Andrew to see if the log/pomba blocking point is still relevant
  2. UNASSIGNED
    1. : pawel complete the scripts to exclude false positive in http_endpoints scanning
    2. Get Feedback from Yuri on the availability of such test (as CDS had some issue in El Alto release - we should test it more and automate basic test to give more trust to end users)


People present (lines said)

  1. morgan_orange (79)
  2. collabot` (3)


Generated by MeetBot 0.1.4.