#onap-int: ONAP integration weekly meeting 12/08/2020

Meeting started by morgan_orange at 15:40:16 UTC (full logs).

Meeting summary

  1. Action point follow-up (morgan_orange, 15:40:26)
    1. AP1 kryzstof start a mail thread to evaluate the load/difficulty to automate k_s plugin test for DCAE (morgan_orange, 15:40:53)
    2. not done yet (morgan_orange, 15:41:00)
    3. ACTION: kryzstof start a mail thread to evaluate the load/difficulty to automate k_s plugin test for DCAE (morgan_orange, 15:41:09)
    4. AP2 morgan_orange update the k8s version to 1.5.11 on windriver (patch needed in master/frankfurt) and give a new try.. (morgan_orange, 15:41:18)
    5. test done by Christophe on windriver, version change has no impact (and it is well working on Nokia using 1.15.3 + OOM reco = 1.15.x) (morgan_orange, 15:41:51)
    6. done (morgan_orange, 15:41:57)
    7. AP3 morgan_orange split Amine patch into 2 patches: structure (Thierry proposal) / clamp (Amine) (morgan_orange, 15:42:11)
    8. not needed, there were already 2 patches (morgan_orange, 15:42:18)
    9. Amine patches includ update of the proposal from thierry but the 2 patches (infra / CLAMP) were separated (morgan_orange, 15:42:42)
    10. AP4: Sebastien (Bell): provide code + procedure to give a first try ... (morgan_orange, 15:43:00)
    11. not done (morgan_orange, 15:43:04)
    12. Sebstien indicated that he was not sure to be able to do it this week (morgan_orange, 15:43:21)
    13. AP5 Trevor (Bell): tell if OK with a dedicated repository. As it is functional testing, it is usually hosted in the project...cds/cds/tests (under Dan responsibility) (morgan_orange, 15:43:34)
    14. done, request sent to coordinator (morgan_orange, 15:43:41)
    15. AP6: Kuldeep initiate a mail thread (morgan_orange, 15:43:50)
    16. done (morgan_orange, 15:43:52)
    17. AP7 Kuldeep initiate a mail thread morgan_orange send a mail with the procedure to run onap-k8s tests on any ONAP solution (morgan_orange, 15:44:00)
    18. done (morgan_orange, 15:44:02)
    19. AP8: morgan_orange send the windriver CI SB-00 jenkins script to Sandeep (morgan_orange, 15:44:10)
    20. done (morgan_orange, 15:44:14)

  2. Admin (morgan_orange, 15:44:24)
    1. new alpine based java image ready to be merged (morgan_orange, 15:44:36)
    2. it seems that committers do not have the +2/merge despite an up to date INFO.yaml (morgan_orange, 15:44:54)
    3. ACTION: morgan_orange report INFO.yaml unsync issue to LF (morgan_orange, 15:45:09)
    4. once merged => a 7.1.0 will be produced (morgan_orange, 15:45:23)
    5. reminder the goal is to propose a GPLv3 free community java 11.08 baseline image (morgan_orange, 15:45:53)
    6. projects can do whatever they want but tjis image is without GPLv3 and with the SECCOM recommended version (morgan_orange, 15:46:17)
    7. projects must be compliant with these 2 topics (GPLv3 + java11) (morgan_orange, 15:46:42)
    8. michal indicated that a new version of the python baseline is needed (morgan_orange, 15:46:54)
    9. the directive prevent the install of package pip -r requirement executed, but system lib needed (morgan_orange, 15:47:18)
    10. ACTION: morgan michall review offline what is needed and release a 7.0.1 version for onap-python (morgan_orange, 15:47:36)
    11. new repository creation requests: testsuite/cds (request sent) + integration/simulators/cn-simulator, integration/terraform (morgan_orange, 15:48:33)
    12. ACTION: morgan initiate the procedure to create integration/simulators/cn-simulator (morgan_orange, 15:49:17)
    13. ACTION: morgan_orange initiate the procedure to create integration/terraform (morgan_orange, 15:49:24)
    14. note that it is a bit painfull to manage...as the notion of right heritage is not really working (see unsync INFO.yaml issues) but it is clearer for maintenance (morgan_orange, 15:49:56)
    15. windriver lab (morgan_orange, 15:50:07)
    16. several issues on SB-00 and windriver daily (morgan_orange, 15:50:29)
    17. CLAMP deployement is failing, OOM is suspected (was working in Frankfurt) (morgan_orange, 15:50:44)
    18. DB/login passwords are available in the secret but empty from the init container of the clamp DB (morgan_orange, 15:51:06)
    19. as a consequence DB not startin > backend not starting > clamp deployment failing (morgan_orange, 15:51:22)
    20. it is reproducible on windriver (morgan_orange, 15:51:29)
    21. SB-00 reinstalled on the 5th of August => all healthcheck (except CLAMP) were PASS (morgan_orange, 15:52:08)
    22. 7 days later several HC issues reported (morgan_orange, 15:52:21)
    23. performance issues have already been reported in the lab but it seems that it is hard to keep a stable version of ONAP (morgan_orange, 15:52:50)
    24. infrastructure is stable (morgan_orange, 15:52:59)
    25. info Stephe Goosh disk are only SSD or NVME => no no issue due to old disc and known Cassandra/ceph performance issue (morgan_orange, 15:53:45)
    26. hard to reinstall every 2 days all the more as previous lab managers (Gary / Marco) are o more involved (morgan_orange, 15:54:10)
    27. installation procedure is based on Gary's script, jenkins script is on jenkins server. conf files in the integration repository (morgan_orange, 15:54:51)
    28. manual operations are needed to maintain the sync (morgan_orange, 15:55:01)
    29. during Frankfurt, we detected relatively late that the versions of kubernetes and helm were not the ones recommended by OOM team (morgan_orange, 15:55:25)
    30. as we are lacking resources, morgan_orange suggests to give the feedback to TSC and release manager. Stability is needed before offering the lab for testing (morgan_orange, 15:56:20)
    31. in the past charts were regularly reinstalled to fix issues but these resources are no more present to deal with that (morgan_orange, 15:56:52)
    32. it is still possible to use Orange lab assuming that part of the daily could be offloaded (e.g. daily master run on DT chain?) (morgan_orange, 15:57:17)
    33. ACTION: morgan_orange indicate that Integration ONAP installation Intel/Windriver lab is under investigation to work on the stability and cannot be used until it is fixed. (morgan_orange, 15:58:07)
    34. possible mitigation gate resources to supervize the lab. But reinstalling every 3 days is not an option (morgan_orange, 15:58:48)

  3. Status on ElAlto Maintenance release (morgan_orange, 15:59:03)
    1. https://gating-results.onap.eu/results/onap_daily_pod4_elalto-682043557/smoke-usecases/basic_vm/xtesting.debug.log (morgan_orange, 15:59:17)
    2. last issue looks like an integration issue and a KEYSTONE_V2/KEYSTONE_V3 bad configuration in SO adapter (morgan_orange, 15:59:40)
    3. additional tests are needed to verify (morgan_orange, 15:59:51)
    4. if instantiation can be completed El Alto Maintenance release will be ready for tagging (morgan_orange, 16:00:06)
    5. note as reported to PTL last Monday, new critical components will expire within 50 days... (morgan_orange, 16:00:33)
    6. improvement done in frankfurt shall improve the cert manager in the future but if El Alto is fine..let's tag it (morgan_orange, 16:01:02)

  4. Status on Frankfurt Maintenance release (morgan_orange, 16:01:13)
    1. daily frankfurt stable, tagging done by LF (morgan_orange, 16:01:34)

  5. Guilin (morgan_orange, 16:01:46)
    1. discussions on the structure of the tests leveraging pythonsdk (morgan_orange, 16:02:02)
    2. https://gerrit.onap.org/r/c/testsuite/pythonsdk-tests/+/110288 (morgan_orange, 16:02:28)
    3. Michal submitted a proposal (morgan_orange, 16:02:34)
    4. AGREED: (morgan_orange, 16:02:37)
    5. we need to test it through examples (morgan_orange, 16:02:52)
    6. possible to add a yaml support to match Thierry expectencies to have flexibility on the service (with several VF) (morgan_orange, 16:03:13)
    7. maybe wording could be improved => base = scenario / component = step ? (morgan_orange, 16:03:37)
    8. ACTION: morgan_orange amine andreas thierry give a try to Michal structure with existing tests (basic_vm, basic_vm(yaml), basic_clamp, basic_network) (morgan_orange, 16:04:24)
    9. plan a demo next week (morgan_orange, 16:04:31)
    10. demo cert => currently run mannualy (morgan_orange, 16:04:47)
    11. allow to get info on the certificates (morgan_orange, 16:04:56)
    12. same code for tests executed from outside (node port / ingress to be added) or inside (morgan_orange, 16:05:18)
    13. tests done and results shared with the community on daily elalto and daily frankfurt (morgan_orange, 16:05:35)
    14. a JIRA has been created to integrate it in CI (morgan_orange, 16:05:47)
    15. demo version postponed to the 26th of August (morgan_orange, 16:05:56)

  6. AoB (morgan_orange, 16:05:59)
    1. question from yoonsoon on where to push his code (morgan_orange, 16:06:11)
    2. ACTION: morgan_orange initiate admin procedure + send a mail to yoonsoon (morgan_orange, 16:06:35)
    3. open question on the stability of the installation using Terraform and the possibility to get a demo (morgan_orange, 16:06:57)
    4. ACTION: morgan_orange plan a terraform demo next week (morgan_orange, 16:07:05)


Meeting ended at 16:07:11 UTC (full logs).

Action items

  1. kryzstof start a mail thread to evaluate the load/difficulty to automate k_s plugin test for DCAE
  2. morgan_orange report INFO.yaml unsync issue to LF
  3. morgan michall review offline what is needed and release a 7.0.1 version for onap-python
  4. morgan initiate the procedure to create integration/simulators/cn-simulator
  5. morgan_orange initiate the procedure to create integration/terraform
  6. morgan_orange indicate that Integration ONAP installation Intel/Windriver lab is under investigation to work on the stability and cannot be used until it is fixed.
  7. morgan_orange amine andreas thierry give a try to Michal structure with existing tests (basic_vm, basic_vm(yaml), basic_clamp, basic_network)
  8. morgan_orange initiate admin procedure + send a mail to yoonsoon
  9. morgan_orange plan a terraform demo next week


Action items, by person

  1. morgan_orange
    1. morgan_orange report INFO.yaml unsync issue to LF
    2. morgan_orange initiate the procedure to create integration/terraform
    3. morgan_orange indicate that Integration ONAP installation Intel/Windriver lab is under investigation to work on the stability and cannot be used until it is fixed.
    4. morgan_orange amine andreas thierry give a try to Michal structure with existing tests (basic_vm, basic_vm(yaml), basic_clamp, basic_network)
    5. morgan_orange initiate admin procedure + send a mail to yoonsoon
    6. morgan_orange plan a terraform demo next week
  2. UNASSIGNED
    1. kryzstof start a mail thread to evaluate the load/difficulty to automate k_s plugin test for DCAE
    2. morgan michall review offline what is needed and release a 7.0.1 version for onap-python
    3. morgan initiate the procedure to create integration/simulators/cn-simulator


People present (lines said)

  1. morgan_orange (91)
  2. collab-meetbot (4)


Generated by MeetBot 0.1.4.