#onap-int: weekly integration meeting 19/08/2020

Meeting started by morgan_orange at 15:00:54 UTC (full logs).

Meeting summary

  1. Action point follow-up (morgan_orange, 15:01:04)
    1. AP1: kryzstof start a mail thread to evaluate the load/difficulty to automate k_s plugin test for DCAE (morgan_orange, 15:01:22)
    2. done (morgan_orange, 15:01:24)
    3. AP2: morgan_orange report INFO.yaml unsync issue to LF (morgan_orange, 15:01:36)
    4. done but only on the reported repo, the issue occurs regularly on new repository. It was suggested to create a cron to resync regularly. Meanwhile the way to resync = LFN ticket (morgan_orange, 15:02:17)
    5. AP3: morgan michall review offline what is needed and release a 7.0.1 version for onap-python (morgan_orange, 15:02:28)
    6. patch in the gate to remove the oNBUILD contrainst (morgan_orange, 15:02:40)
    7. Christophe reported that SDC had no issue and provides his Dockerfile (morgan_orange, 15:03:03)
    8. unfortunately it does not work (morgan_orange, 15:03:11)
    9. so the question of the patch remain open (morgan_orange, 15:03:20)
    10. if no workaround 7.0.1 could ge officially released without the ONBUILD directives (morgan_orange, 15:03:38)
    11. AP4: morgan initiate the procedure to create integration/simulators/cn-simulator (morgan_orange, 15:03:49)
    12. done (morgan_orange, 15:03:52)
    13. AP5: morgan_orange initiate the procedure to create integration/terraform (morgan_orange, 15:04:02)
    14. done, demo planned today (morgan_orange, 15:04:09)
    15. AP6: morgan_orange indicate that Integration ONAP installation Intel/Windriver lab is under investigation to work on the stability and cannot be used until it is fixed. (morgan_orange, 15:04:22)
    16. done, topic created for last PTL meeting (morgan_orange, 15:04:37)
    17. Christophe mentioned that he made a minimal installation on windriver with only 1 node => clamp issue is reproducible (morgan_orange, 15:06:33)
    18. so it does not look linked to the deployment..infra audit in progress we need to eliminate scenario (hardware/infra/deployment/..) (morgan_orange, 15:08:55)
    19. AP7: morgan_orange amine andreas thierry give a try to Michal structure with existing tests (basic_vm, basic_vm(yaml), basic_clamp, basic_network) (morgan_orange, 15:09:08)
    20. activity started but still in progress.. (morgan_orange, 15:09:27)
    21. AP8: morgan_orange initiate admin procedure + send a mail to yoonsoon (morgan_orange, 15:09:37)
    22. done (morgan_orange, 15:09:39)
    23. AP9 morgan_orange plan a terraform demo next week (morgan_orange, 15:09:44)
    24. done (morgan_orange, 15:09:45)
    25. ACTION: morgan_orange amine andreas thierry give a try to Michal structure with existing tests (basic_vm, basic_vm(yaml), basic_clamp, basic_network) (morgan_orange, 15:09:56)

  2. Admin (morgan_orange, 15:10:08)
    1. Windriver SB-00 (morgan_orange, 15:10:30)
    2. reinstallation of Functest Gate on Windriver to get facts and figures based on Functest test suites (morgan_orange, 15:10:45)
    3. daily CI chain to be reset (morgan_orange, 15:10:59)
    4. new repo on track (morgan_orange, 15:11:08)
    5. https://gerrit.linuxfoundation.org/infra/c/releng/info-master/+/65140 (morgan_orange, 15:11:24)
    6. https://gerrit.linuxfoundation.org/infra/c/releng/info-master/+/65138 (morgan_orange, 15:11:33)
    7. https://gerrit.linuxfoundation.org/infra/c/releng/info-master/+/65139 (morgan_orange, 15:11:40)
    8. java baseline image released 7.1.0 (based on alpine) (morgan_orange, 15:12:01)
    9. python baseline image discussion to know if we keep (or not) the ONBUILD constraints (morgan_orange, 15:12:25)
    10. M5 Guilin Jira already there (morgan_orange, 15:12:35)
    11. we are late, some code activity did not start (robot helm chart, switch onap_tests /pythonsdk-tests,..integration of new tests...) (morgan_orange, 15:13:02)
    12. M4 is planned for mid september (morgan_orange, 15:13:09)

  3. Maintenance releases (morgan_orange, 15:13:17)
    1. frnakfurt release note updated (morgan_orange, 15:13:23)
    2. elalto and frankfurt CI are fine (morgan_orange, 15:13:34)

  4. Guilin (morgan_orange, 15:13:42)
    1. demo terraform (morgan_orange, 15:13:46)
    2. yoonsoon developp terraform/terragrunt scripts to simplify the deployement of the cloud infra to host ONAP (morgan_orange, 15:14:12)
    3. demo of the creation of the VM according to OOM reco (morgan_orange, 15:14:22)
    4. code will be shared in integration/terraform (morgan_orange, 15:14:31)
    5. no plan to go further - OOM scripts will be reused as such (morgan_orange, 15:14:45)
    6. wait for community feedback on resources creation (morgan_orange, 15:14:58)
    7. K indicates that Nokia considered this option but there were some issues linked to weird metadata management (VM spawning could take very long time and even get stuck) (morgan_orange, 15:15:34)
    8. function is possible to reduce the risk (morgan_orange, 15:15:44)
    9. demo of Amine (basic_clamp and basic_loop) (morgan_orange, 15:15:59)
    10. Amine shares the work done on python SDK to support clamp call (morgan_orange, 15:16:14)
    11. he developped the SDK part following the rules and quality constraints + a clamp Mock (in GO) + scenario (levergaing for the Moment Thierry's structure) (morgan_orange, 15:16:49)
    12. in the demo he was able to shows both use cases (morgan_orange, 15:17:09)
    13. basic clamp can be used to retrieve the existing loop, edit the rules,..it consists in a clamp CSIT test (morgan_orange, 15:17:37)
    14. basic_loop includes clamp in a more global usecase => deploy a VNF including VES agent then trigger loop condition and check that the loop is triggered (morgan_orange, 15:18:13)

  5. AoB (morgan_orange, 15:18:24)
    1. AGREED: VNF_API is now fully deprecated, you are allowed to remove the BNF_API based use cases in Master (morgan_orange, 15:18:54)
    2. Andreas detected blocking bugs in multicloud (using old version of MSB API) (morgan_orange, 15:19:11)
    3. extending the scope of tests is one of the ambition of the new SDK (morgan_orange, 15:19:44)


Meeting ended at 15:19:47 UTC (full logs).

Action items

  1. morgan_orange amine andreas thierry give a try to Michal structure with existing tests (basic_vm, basic_vm(yaml), basic_clamp, basic_network)


Action items, by person

  1. morgan_orange
    1. morgan_orange amine andreas thierry give a try to Michal structure with existing tests (basic_vm, basic_vm(yaml), basic_clamp, basic_network)


People present (lines said)

  1. morgan_orange (64)
  2. collab-meetbot (3)


Generated by MeetBot 0.1.4.