#onap-int: weekly integration meeting 9/9/2020

Meeting started by morgan_orange at 15:49:45 UTC (full logs).

Meeting summary

  1. Action point follow-up (morgan_orange, 15:49:55)
    1. AP1: Mike Eliott provide some date on the contribution in testsuite/cds repo (morgan_orange, 15:50:17)
    2. AP2: morgan_orange contact recent inactive committers to get their plans (morgan_orange, 15:51:03)
    3. done (morgan_orange, 15:51:06)
    4. AP3 all think to 2 or 3 new committers to replace inactive committers (morgan_orange, 15:51:14)
    5. no objection to initiate the procedure for Michal, Lukasz and Thierry (morgan_orange, 15:51:30)
    6. ACTION: morgan_orange initiate committer promotion (xcheck with them first then initiate the procedure) (morgan_orange, 15:51:51)
    7. AP4 morgan create a LF IT ticket to clean first attempts on onap-integration (morgan_orange, 15:52:01)
    8. done, WIP..I do not have the expected menus (morgan_orange, 15:52:19)
    9. AP5: morgan send a mail to notify the new location of the daily and gating results and optionnaly configure a redirection from the previous place (morgan_orange, 15:52:33)
    10. done + redirection active (morgan_orange, 15:52:38)
    11. morgan ask some feedback on clamp gating to clamp team (morgan_orange, 15:52:44)
    12. christophe indicates that they used it but they do not use it as much as they expect - clmap is small and mature and clamp team now moved to SDC and has no time to add tests (morgan_orange, 15:53:33)
    13. however it was useful (morgan_orange, 15:53:41)
    14. christophe moved SDC CSIT tests back to SDC, he would like to setup also gating on SDC in the future (morgan_orange, 15:54:00)
    15. subset of functionnal tests could be used for gating/daily (morgan_orange, 15:54:13)
    16. AP7: morgan_orange retrieve master versions, compare with frankfurt and ask the PTL during the PTL meeting on their options (M4=code freeze supposed to be mid of September..) (morgan_orange, 15:55:20)
    17. done, shared with PTL and the community (morgan_orange, 15:55:27)
    18. https://wiki.onap.org/display/DW/Guilin+Docker+version+follow-up (morgan_orange, 15:55:47)
    19. AP8: morgan shared the evolution on onap-discuss and wait for feedback (morgan_orange, 15:56:17)
    20. done 0 feedback (morgan_orange, 15:56:22)
    21. AP9 all give feedback on CI evolution for Guilin (morgan_orange, 15:56:31)
    22. see next section (morgan_orange, 15:56:34)
    23. AP10 bisjwajit initiate a thread offline integration / So / AAF flag / robot tests (morgan_orange, 15:56:44)
    24. mail not sent yet (morgan_orange, 15:56:52)

  2. Admin (morgan_orange, 15:56:56)
    1. windriver lab status (morgan_orange, 15:57:12)
    2. no feedback on the performance issue, TSC took the point but no feedback since thursday (morgan_orange, 15:57:29)
    3. only feedback reported on power outage affecting the DC (morgan_orange, 15:57:41)
    4. power is back but no access (morgan_orange, 15:57:46)
    5. no feedback on lab stability => TSC issue (morgan_orange, 15:57:58)
    6. high risk that Integration team cannot provide labs neither for pairwise not use case support (morgan_orange, 15:58:18)
    7. info shared during last TSC with several mitigation scenario, no feedback so far (morgan_orange, 15:58:34)
    8. discussion with Pratik - patch on CI optimization (cache, depth in cloning, ..) (morgan_orange, 15:58:45)
    9. noshow (morgan_orange, 15:58:48)
    10. christophe indicates that some of his patches have eben merged on SDC (no regreesion) (morgan_orange, 15:59:13)
    11. in integration it triggers regressions (linting), wait for correction before being able to move forward (morgan_orange, 15:59:33)
    12. new committers: check with Michal, Lukasz and Thierry, if Ok launch promotion mechanism (morgan_orange, 15:59:54)
    13. ACTION: morgan_orange contact new committers and initiate the procedure (morgan_orange, 16:00:07)

  3. Guilin (morgan_orange, 16:00:20)
    1. several pages created on the wiki (morgan_orange, 16:00:28)
    2. https://wiki.onap.org/display/DW/Integration+G+Release (morgan_orange, 16:00:43)
    3. blocking points: https://wiki.onap.org/display/DW/Guilin+Integration+blocking+points (morgan_orange, 16:00:55)
    4. readiness page: https://wiki.onap.org/display/DW/Guilin+Readiness+dashboard, docker version tracking (morgan_orange, 16:01:14)
    5. use case follow-up (now JIRA based): https://wiki.onap.org/display/DW/Guilin+Use+case+follow-up (morgan_orange, 16:01:30)
    6. Master daily very ugly today (morgan_orange, 16:01:42)
    7. https://logs.onap.org/onap-integration/daily/onap_daily_pod4_master/09-09-2020_08-09/ (morgan_orange, 16:02:05)
    8. better results yesterday (morgan_orange, 16:02:10)
    9. https://logs.onap.org/onap-integration/daily/onap_daily_pod4_master/09-07-2020_06-09/ (morgan_orange, 16:02:21)
    10. only difference => move OOM from no limit to limits (morgan_orange, 16:02:37)
    11. let's see if issue is reproducible...not sure.. (morgan_orange, 16:02:53)
    12. daily master in DT 100% OK (infra + healthcheck tests) (morgan_orange, 16:03:21)
    13. Nokia reported also possible race condition on DCAE side that lead to deployment issues (morgan_orange, 16:03:46)
    14. ACTION: Krysztof create a jira to track cloudify/DCAE bootstrap race condition issue (morgan_orange, 16:04:08)
    15. Master weekly created (tun once a week) (morgan_orange, 16:04:19)
    16. first integration tests on versions and certificate in progress (morgan_orange, 16:04:32)
    17. CI chain evolution - list of use cases final cut (morgan_orange, 16:05:44)
    18. no objection to proposal from last week (shared by mail) (morgan_orange, 16:05:55)
    19. AGREED: adopt guilin Ci evolution as described last week (morgan_orange, 16:06:08)
    20. ONAP tests to pythonsdk migration status (morgan_orange, 16:06:21)
    21. several patches merged (availability zone, multicloud) (morgan_orange, 16:06:31)
    22. Andreas has still some patches to merge (pb on AAI, Vendor creation using Yaml (morgan_orange, 16:06:46)
    23. AGREED: , instantiation scenario shall be based on yaml file (at least for the VNF param) (morgan_orange, 16:07:13)
    24. SECCOM test follow up (morgan_orange, 16:07:20)
    25. review with AMY on the status of the security tests for Guilin (morgan_orange, 16:07:30)
    26. xfail list reset (morgan_orange, 16:07:36)
    27. versions soon available in weekly (Sunday) (morgan_orange, 16:07:46)
    28. ACTION: morgan_orange initiate Jira to the projects for the different tests (morgan_orange, 16:07:59)
    29. question on who is responsible for the upstream ccomponents (morgan_orange, 16:08:10)
    30. if upstream attached to a project X => X (morgan_orange, 16:08:19)
    31. if generic => OOM (morgan_orange, 16:08:22)
    32. ACTION: morgan_orange create bunch of JIRAs (morgan_orange, 16:09:00)
    33. pythonsdk basic_scenario shall be available soon (goal before the end of the week) (morgan_orange, 16:09:05)


Meeting ended at 16:09:08 UTC (full logs).

Action items

  1. morgan_orange initiate committer promotion (xcheck with them first then initiate the procedure)
  2. morgan_orange contact new committers and initiate the procedure
  3. Krysztof create a jira to track cloudify/DCAE bootstrap race condition issue
  4. morgan_orange initiate Jira to the projects for the different tests
  5. morgan_orange create bunch of JIRAs


Action items, by person

  1. morgan_orange
    1. morgan_orange initiate committer promotion (xcheck with them first then initiate the procedure)
    2. morgan_orange contact new committers and initiate the procedure
    3. morgan_orange initiate Jira to the projects for the different tests
    4. morgan_orange create bunch of JIRAs


People present (lines said)

  1. morgan_orange (76)
  2. collab-meetbot (3)


Generated by MeetBot 0.1.4.