#onap-int: weekly integration test 30/09/2020

Meeting started by morgan_orange at 14:38:34 UTC (full logs).

Meeting summary

  1. action point follow-up (morgan_orange, 14:38:44)
    1. https://ircbot.wl.linuxfoundation.org/meetings/onap-int/2020/integration_weekly_meeting_23_09_2020/onap-int-integration_weekly_meeting_23_09_2020.2020-09-23-14.56.html (morgan_orange, 14:38:59)
    2. AP1: all review your JIRA and update, for M4 we should not have High priority Jira opened for more then 36 hours, fix, or move them to Honolulu (morgan_orange, 14:39:13)
    3. still to be done..review your JIRA, postpone the one that you will not be able to do for Guilin...close the ones done (morgan_orange, 14:39:38)
    4. AP2 michal see with Sylvain how to release the new version (morgan_orange, 14:39:46)
    5. done see next section (morgan_orange, 14:39:51)
    6. AP3: all complete the pythonsdk evolution etherpad (morgan_orange, 14:39:59)
    7. still shy, do not hesitate to complete... (morgan_orange, 14:40:08)
    8. AP4 morgan_orange morgan_orangecreate JIRA on GPLv3 (morgan_orange, 14:40:28)
    9. done (morgan_orange, 14:40:29)
    10. note that xtesting & robot pods have also GPLv3 inside.. (morgan_orange, 14:40:44)
    11. AP5 lasse sent a mail on onap-discuss + initiate a wiki page to help the reinsourcing of csit tests (morgan_orange, 14:41:11)
    12. done, see next topic (morgan_orange, 14:41:17)

  2. Admin (morgan_orange, 14:41:24)
    1. windriver lab up&running and seems slow but stable => the cleanup of the 5 Integration labs seems to be enough to ensure a good level of stability (morgan_orange, 14:41:51)
    2. feel free to use the lab.. (morgan_orange, 14:42:00)
    3. Auzre lab created, 8 people asked for an access to the lab (morgan_orange, 14:42:14)
    4. zoom bridge, ticket raised on the 24th of September, no real response yet, LF resources busy with ONES virtual event (morgan_orange, 14:42:47)
    5. use a public zoom for the demo (morgan_orange, 14:42:57)

  3. Guilin (morgan_orange, 14:43:57)
    1. CSIT status (morgan_orange, 14:44:02)
    2. lasse initiated a wiki page (morgan_orange, 14:44:09)
    3. https://wiki.onap.org/display/DW/Moving+CSIT+to+project+repositories (morgan_orange, 14:44:22)
    4. CSIT as it is today has most of the time no sense. csdk tests are delaing with..dublin (morgan_orange, 14:44:42)
    5. PTL must revisit (morgan_orange, 14:44:50)
    6. morgan indictaes that such functional tests must be performed in the project repo..to avoid such maintenance issues (morgan_orange, 14:45:10)
    7. tests are triggered daily independently from code submission (morgan_orange, 14:45:21)
    8. gating extension on target env are real integration tests: on patch submission => docker obuilt on the fly => deployment + Test => feedback before merge (morgan_orange, 14:45:58)
    9. currently most of tests done on master => code need to be merged, no verification before merged (morgan_orange, 14:46:23)
    10. other projects shoudl do the same... (morgan_orange, 14:46:49)
    11. ACTION: morgan lasse prepare a slide deck to share with PTL during PTL meeting in 2 weeks (morgan_orange, 14:47:16)
    12. CI status (morgan_orange, 14:47:26)
    13. https://logs.onap.org/onap-integration/daily/onap_daily_pod4_master/09-30-2020_07-09/ (morgan_orange, 14:47:36)
    14. Ci pretty stable (morgan_orange, 14:47:41)
    15. issue with DCAE - race condition on slow labs? DCAE cannot be installed properly, problem reported by several labs (morgan_orange, 14:48:14)
    16. we should be careful and avoid the need of overcommited lab to make things work... (morgan_orange, 14:48:28)
    17. https://jira.onap.org/browse/DCAEGEN2-2457 (morgan_orange, 14:48:41)
    18. SDNC/AAI issues also preventing End to End test to be fully completed (morgan_orange, 14:48:58)
    19. https://jira.onap.org/browse/SDNC-1371?src=confmacro (morgan_orange, 14:49:48)
    20. pythonsdk status (morgan_orange, 14:50:02)
    21. version 7.0.0 release this week (7.0.0 <=> Guilin) (morgan_orange, 14:50:20)
    22. new features: - Network instantiation (morgan_orange, 14:50:40)
    23. - SDC properties assignment (morgan_orange, 14:50:52)
    24. - SDC artifacts assignment (morgan_orange, 14:50:59)
    25. - PNF onboarding (morgan_orange, 14:51:06)
    26. - SO macro flow instantiation (morgan_orange, 14:51:11)
    27. - CLAMP closed loop instantiation (morgan_orange, 14:51:18)
    28. pythonsdk = function to interact with ONAP != use cases (morgan_orange, 14:51:40)
    29. use cases are in pythonsdk-tests and potentially in other places, but pythonsdk-tests is used by integration to create use case leveraging pythonsdk (morgan_orange, 14:52:08)
    30. packaging done, the master version of xtestin-smoke-usecases-pythonsdk is now fully based on pythonsdk (morgan_orange, 14:52:35)
    31. old framework based on onap_tests is deprecated (was supporting only VNF_API which is fully deprectaed now) (morgan_orange, 14:52:57)
    32. docker available (morgan_orange, 14:53:04)
    33. demo how to run it and how to create your own use case based on pythonsdk (morgan_orange, 14:53:22)
    34. integration in CI in progress (shall be OK before the end of the week) (morgan_orange, 14:54:10)
    35. docker run -v <path to your clouds.yaml>:/root/.config/openstack/clouds.yaml -v <path to your res dir>:/var/lib/xtesting/results --add-host=portal.api.simpledemo.onap.org:<your cluster IP> --add-host=vid.api.simpledemo.onap.org:<your cluster IP> --add-host=sdc.api.fe.simpledemo.onap.org:<your cluster IP> --add-host=sdc.api.be.simpledemo.onap.org:<your cluster IP> --add-host=aai.api.sparky.simpledemo.onap.org:<your cluster IP> --a (morgan_orange, 15:21:38)
    36. with 2 mandatory variables in the env file (morgan_orange, 15:21:51)
    37. ONAP_PYTHON_SDK_SETTINGS=onaptests.configuration.ubuntu16_nomulticloud_settings & OS_TEST_CLOUD=onap-master-daily-vnfs-ci (morgan_orange, 15:22:32)
    38. Demo (morgan_orange, 15:22:40)
    39. pnf-registrate blocked by a bug (morgan_orange, 15:23:01)
    40. CMPv2 test in progress, evolution with pythonsdp possible in Honolulu (morgan_orange, 15:23:18)
    41. OOM issue reported by Bartek (CMPv2 evolution leads to issue on offline deployments) (morgan_orange, 15:23:41)


Meeting ended at 15:23:50 UTC (full logs).

Action items

  1. morgan lasse prepare a slide deck to share with PTL during PTL meeting in 2 weeks


People present (lines said)

  1. morgan_orange (82)
  2. collab-meetbot (4)


Generated by MeetBot 0.1.4.