#onap-int: Integration weekly meeting 13/1/2021

Meeting started by morgan_orange at 14:51:54 UTC (full logs).

Meeting summary

  1. action point follow up (morgan_orange, 14:52:00)
    1. no remaining action points, last week meeting canceled (no quorum due to bank holidays) (morgan_orange, 14:52:23)

  2. Honolulu (morgan_orange, 14:52:30)
    1. demo CDS regression tests (morgan_orange, 14:52:39)
    2. teh demo shows how Bell is performing CDS regression tests (CDS considered as a standalone component) (morgan_orange, 14:53:07)
    3. https://wiki.onap.org/display/DW/Integration+Meeting+Minutes?preview=/11930007/93006984/cds_regression_test.pdf (morgan_orange, 14:53:26)
    4. several mock services needed, tests done in parallel (morgan_orange, 14:53:42)
    5. ingress controller to run the tests to different CDS versions (morgan_orange, 14:53:55)
    6. CI based on gitrlab-CI - 6 stages pipeline including deployment/configuration (CDS) (morgan_orange, 14:54:18)
    7. tests = bash script running command on CDS with mock services for CDS <=> services emulation (morgan_orange, 14:54:47)
    8. looks feasible to include that in CI (morgan_orange, 14:54:54)
    9. ONAP integraiton CI/CD is based on gitlab (morgan_orange, 14:55:02)
    10. tests are // through xtesting dockers (morgan_orange, 14:55:14)
    11. Jozsef indicates that the repo shall be updated (upstream code no more up to date) (morgan_orange, 14:55:38)
    12. ACTION: morgan_orange create CDS test Epic for Honolulu (morgan_orange, 14:55:51)
    13. review repo + Mock servcies, include cds code in xtesting docker (morgan_orange, 14:56:06)
    14. then give a try on a daily (morgan_orange, 14:56:15)
    15. cds regression tests coudl be added to healthcheck (as we are testing 1 component) or on smoke (morgan_orange, 14:56:58)
    16. note with pythonsdk a first test has been committed to enrich the CBA (and exposde the port) (morgan_orange, 14:57:19)
    17. second demo on DataFileCollector (DCAE feature) (morgan_orange, 14:57:50)
    18. copy/paste adaptation of what was available in ftp/sftp (morgan_orange, 14:58:09)
    19. new feature for http/https server (for the moment only http) (morgan_orange, 14:58:21)
    20. modification needed in integration (morgan_orange, 14:58:32)
    21. then enrichment of CSIT tests planed (morgan_orange, 14:58:43)
    22. https://gerrit.onap.org/r/c/integration/+/116574 (morgan_orange, 14:59:07)

  3. Guilin maintenance release (morgan_orange, 14:59:21)
    1. testsuiote 1.7.3 generated and available in the Nexus (morgan_orange, 14:59:31)
    2. change committed in OOM/guilin (morgan_orange, 14:59:40)
    3. note oom/testsuite is valid only up to Guilin (so commit done in Guilin branch directly) (morgan_orange, 15:00:02)
    4. for next release the chart is hosted back in oom to avoid circular dependency issues (morgan_orange, 15:00:20)

  4. vEvent (morgan_orange, 15:21:55)
    1. several sessions planned for the next vEvent (morgan_orange, 15:22:03)
    2. https://wiki.lfnetworking.org/display/LN/2021+February+Developer+Topic+Proposals (morgan_orange, 15:22:29)
    3. for integration 3 sessions so far (morgan_orange, 15:22:35)
    4. session 1 with Alexander (scope LFN) introduction to Tern (dynamic licence scanning) (morgan_orange, 15:23:01)
    5. session 2: lessons learned and Honolulu plan (morgan_orange, 15:23:42)
    6. colelctive session, morgan_orangewill recontact the integration committers and plan to share the sessions with update on pythonsdk, CSI, labs,... (morgan_orange, 15:24:05)
    7. session3: updtae and stability resiliency (morgan_orange, 15:24:15)
    8. detail what has been done in guilin (morgan_orange, 15:24:31)
    9. new tests done by Natacha on // testing in SDC (morgan_orange, 15:24:39)
    10. a status shall be planned soon (morgan_orange, 15:24:47)
    11. first results seem to say that it is fine (morgan_orange, 15:24:55)
    12. the errors seen in CI due to parallel processing is not seen anymore even if the nulber of services accumulated becomes big (morgan_orange, 15:25:21)
    13. ACTION: plan a update with Natacha on the last tests done (morgan_orange, 15:25:36)
    14. if any integration contributor woudl like to present another topic => fell free (morgan_orange, 15:25:54)

  5. AoB (morgan_orange, 15:25:57)


Meeting ended at 15:26:02 UTC (full logs).

Action items

  1. morgan_orange create CDS test Epic for Honolulu
  2. plan a update with Natacha on the last tests done


Action items, by person

  1. morgan_orange
    1. morgan_orange create CDS test Epic for Honolulu


People present (lines said)

  1. morgan_orange (49)
  2. collab-meetbot (3)


Generated by MeetBot 0.1.4.