#onap-int: Integration weekly meeting 20/01/2021

Meeting started by morgan_orange at 16:06:44 UTC (full logs).

Meeting summary

  1. action point follow up (morgan_orange, 16:07:04)
    1. https://ircbot.wl.linuxfoundation.org/meetings/onap-int/2021/integration_weekly_meeting_13_1_2021/onap-int-integration_weekly_meeting_13_1_2021.2021-01-13-14.51.html (morgan_orange, 16:07:19)
    2. AP1 morgan_orange create CDS test Epic for Honolulu (morgan_orange, 16:07:32)
    3. AP2 morgan_orange plan a update with Natacha on the last tests done (morgan_orange, 16:07:46)
    4. done see next topic (morgan_orange, 16:07:51)

  2. admin (morgan_orange, 16:08:02)
    1. new repositories created (morgan_orange, 16:08:13)
    2. 3 mock repositories for cds regression tests (morgan_orange, 16:08:21)
    3. the chart shall be hosted with other chartq (morgan_orange, 16:08:32)
    4. ACTION: morgan_orange contact OOM team to see where to host test charts (morgan_orange, 16:08:46)
    5. real time support chan (morgan_orange, 16:08:56)
    6. rocket chat will be closed end of January (morgan_orange, 16:09:06)
    7. recommendation is to move to slack (morgan_orange, 16:09:12)
    8. christophe initiated an internal exception procedure for ATT users (morgan_orange, 16:09:24)
    9. not possible to export/import rocket chat history in slack (morgan_orange, 16:09:37)
    10. but possible to save rocket chan history locally (morgan_orange, 16:09:55)
    11. local saving requires rocketchat application (morgan_orange, 16:10:23)

  3. Honolulu (morgan_orange, 16:10:28)
    1. PNF demo postponed to next week (DT workshop today) (morgan_orange, 16:10:47)
    2. CSIT redesign update (morgan_orange, 16:10:59)
    3. lasse will update the status to PTL next Monday (morgan_orange, 16:11:11)
    4. light changes to remove the dependency to the nexus..as teh verificaiton/merge job is done in 1 job it is possible to reuse the locally built docker and not push docker in staging nexus (morgan_orange, 16:11:48)
    5. it simplifies the workflow and save CI/CD resources (morgan_orange, 16:12:01)
    6. presentation of the stability onboard tests performed beginning of january (morgan_orange, 16:12:26)
    7. https://wiki.onap.org/display/DW/Honolulu+stability+test+evolution (morgan_orange, 16:12:47)
    8. goal of 10 simultaneous onboarding seems OK (morgan_orange, 16:12:57)
    9. duration = f(nb // onboarding) (morgan_orange, 16:13:07)
    10. size of teh DB has no influence: onboarding series executed after lots of onbaording faster than first series (morgan_orange, 16:13:30)
    11. impossible to reproduce the race condition seen regularly in CI (morgan_orange, 16:13:44)
    12. possible to mix scenarios to try to reproduce the issue seen in CI (morgan_orange, 16:13:56)
    13. presnetation planned for the vEvent (morgan_orange, 16:14:06)
    14. ACTION: christophe contact ATT operational team for KPI definitions (nb of simultaneous onboarding/instantation/loop/messages/;..) in order to build a realistic scenario (morgan_orange, 16:25:41)
    15. update on tern tests (morgan_orange, 16:26:26)
    16. alexander luanched tests + scan code on almost all the ONAP images used in the weekly aster lab (morgan_orange, 16:26:47)
    17. 80% contains GPLv3 (morgan_orange, 16:26:58)
    18. https://logs.onap.org/onap-integration/weekly/onap_weekly_pod4_master/01-14-2021_00-01/tern-reports/ (morgan_orange, 16:27:34)
    19. note some of the files are very big..so it takes time to open#info information of the components layer by layer (morgan_orange, 16:27:57)
    20. some images have an incredible number of layers..lots of space for optimization (morgan_orange, 16:28:13)
    21. GPLv3 python lib included in the baseline image provided by alpine (morgan_orange, 16:28:39)
    22. ACTION: morgan_orange send a mail to PTL to explain that the results are available (morgan_orange, 16:28:54)
    23. ACTION: alexander contact steve Winslow to clarify some legal issues (morgan_orange, 16:29:14)
    24. a presentation is planned in Plenary during the vEvent on a feedback of dynamic scanning (morgan_orange, 16:29:31)
    25. thanks to docviz, it is also possible to visualize the links between the different dockers, it is very useful to see the different heritages..and identify which hardening could be the most useful (morgan_orange, 16:30:26)
    26. https://logs.onap.org/onap-integration/weekly/onap_weekly_pod4_master/01-14-2021_00-01/tern-reports/images-created-by2.png (morgan_orange, 16:30:42)

  4. CI/CD (morgan_orange, 16:30:59)
    1. request from Xin Miao to redeploy SB00 on windriver (morgan_orange, 16:31:16)
    2. ACTION: Krzysztof Kuzmicki ask Daniel if it is possible to redeploy SB-00 using the Nokia scripts used mid december (morgan_orange, 16:31:50)
    3. resiliency tests (backup and restore, disaster recovery,..) to be considered and initiated. (morgan_orange, 16:32:19)
    4. it is part of the presentation planned for the event (morgan_orange, 16:32:27)
    5. we are almost sure that ONAP today cannot survive the reboot of a worked node hosting pod with NFS storage...but evidence would eb nice to create JIRA (morgan_orange, 16:33:01)
    6. historically Gary introduced a test: test => delete pod => test => delete pod => test => .....to test the resiliency (morgan_orange, 16:33:25)
    7. it shall be easily reproducible by relaunching the basic_vm test as we did during the long duration test (morgan_orange, 16:33:52)
    8. short dev needed to list the pod, delete them, wait for recovery before re-launching the test (morgan_orange, 16:34:18)
    9. to be planned as part of resiliency activities (morgan_orange, 16:34:27)
    10. additionnaly nice k8s chaos monkey frameworks are available, if you are interested..please come back to me (morgan_orange, 16:34:52)
    11. one of the open question assuming that ONAP cannot survive some reboot... "why the k8s magic cannot apply.." (morgan_orange, 16:35:42)
    12. the cloudreadiness is not good enough..but with the last OOM improvement it should be better (especially the work on storage class) (morgan_orange, 16:36:32)

  5. vEvent (morgan_orange, 16:36:45)
    1. 3 presentations for integration: docker dynamic scanning, stability/Resiliency, Integration lesson learned + Honolulu planned (morgan_orange, 16:37:15)
    2. first slide deck shared with commiters (morgan_orange, 16:37:29)
    3. the topics are: Lab support, Testcases, Pythonsdk, CI/CD, CSIT, Community and use case support, quality of code and simulators, stability&resiliency testing (morgan_orange, 16:38:29)
    4. AGREED: bartek will ahev a look at the quality part (verification jobs) (morgan_orange, 16:38:47)
    5. additionnaly he will have a look at the existing simulators in order to get a good view on what is mature, can be promoted in future Honolulu doc (good doc needed) (morgan_orange, 16:39:38)
    6. Pawel indicates that there is no need for a dedicated security test topics => part of testcases (morgan_orange, 16:39:56)
    7. some refactoring needed on the existing security tests (morgan_orange, 16:40:05)


Meeting ended at 16:40:09 UTC (full logs).

Action items

  1. morgan_orange contact OOM team to see where to host test charts
  2. christophe contact ATT operational team for KPI definitions (nb of simultaneous onboarding/instantation/loop/messages/;..) in order to build a realistic scenario
  3. morgan_orange send a mail to PTL to explain that the results are available
  4. alexander contact steve Winslow to clarify some legal issues
  5. Krzysztof Kuzmicki ask Daniel if it is possible to redeploy SB-00 using the Nokia scripts used mid december


Action items, by person

  1. morgan_orange
    1. morgan_orange contact OOM team to see where to host test charts
    2. morgan_orange send a mail to PTL to explain that the results are available
  2. UNASSIGNED
    1. christophe contact ATT operational team for KPI definitions (nb of simultaneous onboarding/instantation/loop/messages/;..) in order to build a realistic scenario
    2. alexander contact steve Winslow to clarify some legal issues
    3. Krzysztof Kuzmicki ask Daniel if it is possible to redeploy SB-00 using the Nokia scripts used mid december


People present (lines said)

  1. morgan_orange (67)
  2. collab-meetbot (3)


Generated by MeetBot 0.1.4.