#opnfv-functest: Functest weekly meeting July 26th 2016

Meeting started by jose_lausuch at 08:01:42 UTC (full logs).

Meeting summary

    1. https://wiki.opnfv.org/display/functest/Functest+Meeting (jose_lausuch, 08:01:48)

  1. roll call (jose_lausuch, 08:01:52)
    1. Jose Lausuch (jose_lausuch, 08:02:33)
    2. Valentin Boucher (boucherv_orange, 08:02:43)
    3. raghavendrachari (raghu_, 08:03:08)
    4. SerenaFeng (SerenaFeng, 08:03:46)

  2. Action point follow-up (meeting on the 19th July) (jose_lausuch, 08:05:16)
    1. AP: SerenaFeng update test api on testresults.opnfv.org with last version of datamodel (jose_lausuch, 08:05:27)
    2. AP: May-meimei jose_lausuch check the problem with the jumphost accessing the artifacts: AccessDeniedException: 401 Login Required. (jose_lausuch, 08:06:19)
    3. problem solved, the compass pods have now access to push things to artifacts. (jose_lausuch, 08:06:36)
    4. AP: jose_lausuch contact Bryan (bryan_att) to report the failure. DONE. Being fixed at the moment. (jose_lausuch, 08:07:35)
    5. AP: jose_lausuch contact moon project to see when the scenario can be active. In progrress. (jose_lausuch, 08:07:47)
    6. ACTION: jose_lausuch contact moon project to see when the scenario can be active. (jose_lausuch, 08:07:51)
    7. AP: jose_lausuch: try to find the reason why Functest-joid fails and contact joid folks for support. (jose_lausuch, 08:08:01)
    8. Functest has almost successfully run on JOID: https://build.opnfv.org/ci/view/functest/job/functest-joid-baremetal-daily-master/117/console (jose_lausuch, 08:08:06)
    9. However there are problems with Domino test case (jose_lausuch, 08:08:57)
    10. ACTION: jose_lausuch contact Domino team (JIRA) to report the failure. (jose_lausuch, 08:09:04)
    11. ACTION: jose_lausuch contact Jack Morgan or Fatih, gsutils is not installed on intel-pod6 jumphost (jose_lausuch, 08:09:14)

  3. Feature projects integration status (jose_lausuch, 08:09:55)
    1. SDNVPN: test already in CI and reporting the results to DB. (jose_lausuch, 08:10:16)
    2. ODL-SFC to be enabled this week in CI, but they need a tacker-post install script on the controller side. (jose_lausuch, 08:10:42)
    3. SECURITY: there is a problem that jenkins output reports "sudo: hiera: command not found" (jose_lausuch, 08:12:31)
    4. ACTION: lhinds look into the problem "sudo: hiera: command not found" . Example: https://build.opnfv.org/ci/view/functest/job/functest-apex-apex-daily-master-daily-master/108/console (jose_lausuch, 08:12:54)
    5. "security_scan - INFO - Installing OpenSCAP..." this takes too long and makes the jenkins job timeout... (jose_lausuch, 08:13:27)
    6. ACTION: lhinds: look for the possibility to install OpenSCAP in the docker image so that we dont have to do it while running the job in Jenkins (jose_lausuch, 08:13:48)
    7. MULTISITE: there are some problems with fetch_os_creds.sh because they have a deployment with 2 fuel environemnts (2 regions) and that is not considered in the script. (jose_lausuch, 08:14:43)
    8. troubleshooting now (jose_lausuch, 08:15:04)
    9. Sashish working on that. The way to fix the fuel environment id is with a new environment variable for docker "FUEL_ENV" (jose_lausuch, 08:17:04)
    10. https://gerrit.opnfv.org/gerrit/#/c/17515/ (jose_lausuch, 08:17:08)
    11. fdegir installed & verified gsutil on intel pod5 and pod6 jumphosts (jose_lausuch, 08:18:55)

  4. Colorado status (jose_lausuch, 08:19:28)
    1. https://jira.opnfv.org/issues/?filter=-1&jql=project%20%3D%20FUNCTEST%20AND%20status%20in%20(Open%2C%20%22In%20Progress%22)%20AND%20resolution%20%3D%20Unresolved%20ORDER%20BY%20updatedDate%20DESC (jose_lausuch, 08:19:36)
    2. : problem with ODL reporting is fixed, and now it also works with APEX. Tim Rozet had a fix for accessing the SDN_CONTROLLER_IP (jose_lausuch, 08:20:07)
    3. vPing_ssh has been deactivated for ODL_L3 scenarios, due to an ODL Bug: https://bugs.opendaylight.org/show_bug.cgi?id=5586 (jose_lausuch, 08:20:30)
    4. it will be reactivated as soon as we now floating ips work again (jose_lausuch, 08:20:52)
    5. The functest timeout for daily-smoke tests has been fixed to 120 seconds (2hours) and that has triggered some timeouts in some scenarios/installers. For example JOID or APEX: #link https://build.opnfv.org/ci/view/functest/job/functest-apex-apex-daily-master-daily-master/108/console (jose_lausuch, 08:21:29)
    6. https://build.opnfv.org/ci/job/functest-joid-baremetal-daily-master/116/console (jose_lausuch, 08:21:42)
    7. https://build.opnfv.org/ci/view/functest/job/functest-apex-apex-daily-master-daily-master/108/console (jose_lausuch, 08:21:46)
    8. let's put it to 180 for now: https://gerrit.opnfv.org/gerrit/#/c/17541/ (jose_lausuch, 08:22:08)
    9. for apex, it could be due to the security install test, when installing OpenSCAP (jose_lausuch, 08:22:19)
    10. for JOID, the tests take longer than normal. For example, healthcehck takes 7 miinutes, whereas normally it takes 4. Tempest takes 60 minutes to complete whereas it takes 30 minutes max normally... (jose_lausuch, 08:22:24)
    11. https://build.opnfv.org/ci/view/functest/job/functest-compass-virtual-daily-master/209/console (May-meimei, 08:23:53)
    12. some failures in virtual deploements https://build.opnfv.org/ci/view/functest/job/functest-compass-virtual-daily-master/209/console (jose_lausuch, 08:27:31)
    13. compass looks quite "blue" in baremetal https://build.opnfv.org/ci/view/functest/job/functest-compass-baremetal-daily-master/ (jose_lausuch, 08:27:40)
    14. Tempest takes around 10 minutes to execute all the smoke test in Compass (jose_lausuch, 08:27:52)

  5. AoB (jose_lausuch, 08:41:31)
    1. https://jira.opnfv.org/browse/FUNCTEST-365 (SerenaFeng, 08:41:52)
    2. https://gerrit.opnfv.org/gerrit/#/c/17525/ (jose_lausuch, 08:42:33)
    3. boucherv_orange will commit a code with a change to allow to use other endpoint type like internal or admin not always public (jose_lausuch, 08:48:36)
    4. It's a new change into JOID code (public api exposition), we must specify the endpoint type to internal (with env variable OS_ENDPONINT_TYPE) (jose_lausuch, 08:48:41)
    5. ACTION: jose_lausuch remove or indicate that https://wiki.opnfv.org/display/functest/Collection+Of+Test+Results is outdated (jose_lausuch, 08:51:02)
    6. https://jira.opnfv.org/browse/FUNCTEST-176, (raghu_, 08:51:44)
    7. raghu_ submited this task in releng repo create a web portal to add test case/projects/pods to the DB (jose_lausuch, 08:52:15)
    8. https://gerrit.opnfv.org/gerrit/#/c/17243/ (jose_lausuch, 08:52:37)


Meeting ended at 08:55:27 UTC (full logs).

Action items

  1. jose_lausuch contact moon project to see when the scenario can be active.
  2. jose_lausuch contact Domino team (JIRA) to report the failure.
  3. jose_lausuch contact Jack Morgan or Fatih, gsutils is not installed on intel-pod6 jumphost
  4. lhinds look into the problem "sudo: hiera: command not found" . Example: https://build.opnfv.org/ci/view/functest/job/functest-apex-apex-daily-master-daily-master/108/console
  5. lhinds: look for the possibility to install OpenSCAP in the docker image so that we dont have to do it while running the job in Jenkins
  6. jose_lausuch remove or indicate that https://wiki.opnfv.org/display/functest/Collection+Of+Test+Results is outdated


Action items, by person

  1. jose_lausuch
    1. jose_lausuch contact moon project to see when the scenario can be active.
    2. jose_lausuch contact Domino team (JIRA) to report the failure.
    3. jose_lausuch contact Jack Morgan or Fatih, gsutils is not installed on intel-pod6 jumphost
    4. jose_lausuch remove or indicate that https://wiki.opnfv.org/display/functest/Collection+Of+Test+Results is outdated
  2. UNASSIGNED
    1. lhinds look into the problem "sudo: hiera: command not found" . Example: https://build.opnfv.org/ci/view/functest/job/functest-apex-apex-daily-master-daily-master/108/console
    2. lhinds: look for the possibility to install OpenSCAP in the docker image so that we dont have to do it while running the job in Jenkins


People present (lines said)

  1. jose_lausuch (137)
  2. May-meimei (24)
  3. SerenaFeng (21)
  4. raghu_ (7)
  5. collabot (5)
  6. boucherv_orange (5)
  7. fdegir (4)


Generated by MeetBot 0.1.4.