#opnfv-functest: Functest weekly meeting August 9th

Meeting started by morgan_orange at 08:00:14 UTC (full logs).

Meeting summary

  1. call roll (morgan_orange, 08:00:19)
    1. Morgan (morgan_orange, 08:00:25)
    2. Juha Kosonen (juhak, 08:00:34)
    3. Luke Hinds (lhinds, 08:00:45)
    4. SerenaFeng (SerenaFeng, 08:00:47)
    5. CG_Nokia (Colum Gaynor) (CG_Nokia, 08:00:48)
    6. Juha Haapavirta (JuhaHaapa, 08:00:52)
    7. meimei (May-meimei, 08:01:04)
    8. agenda https://wiki.opnfv.org/display/functest/Functest+Meeting (morgan_orange, 08:01:05)
    9. raghavendrachari (raghu_, 08:01:23)

  2. Action point follow-up (morgan_orange, 08:01:50)
    1. AP: jose_lausuch contact moon project to see when the scenario can be active. (morgan_orange, 08:01:59)
    2. Moon PTL contacted morgan_orange, seems there are OK from releng perspective, ready on functest side (without reporting), wait for scenario run (morgan_orange, 08:02:06)
    3. AP: jose_lausuch contact Domino team (JIRA) to report the failure. (morgan_orange, 08:02:14)
    4. ACTION: morgan_orange check with Domino project (no update seen in the ltos of mail I discovered yesterday) (morgan_orange, 08:02:36)
    5. AP: jose_lausuch remove or indicate that https://wiki.opnfv.org/display/functest/Collection+Of+Test+Results is outdated (morgan_orange, 08:02:44)
    6. ACTION: morgan_orange reference this page from Brahamaputra page only (morgan_orange, 08:04:28)
    7. ACTION: morgan_orange for Coloradao put the URl to swagger (morgan_orange, 08:04:48)
    8. AP: lhinds look into the problem "sudo: hiera: command not found" . Example: https://build.opnfv.org/ci/view/functest/job/functest-apex-apex-daily-master-daily-master/108/console (morgan_orange, 08:04:58)
    9. AP: lhinds: look for the possibility to install OpenSCAP in the docker image so that we dont have to do it while running the job in Jenkins (morgan_orange, 08:05:14)
    10. AP: Manuel Buil troubleshooting ODL-SFC bugs (morgan_orange, 08:07:13)
    11. AP: morgan contact copper people to troubleshooting failure problem (morgan_orange, 08:07:40)
    12. ACTION: morgan_orange contact bryan_att to sync on this issue (morgan_orange, 08:07:55)
    13. AP: SerenaFeng contack docker people to trouble shooting failure problem (morgan_orange, 08:08:03)
    14. AP: SerenaFeng contact parser people when to start parser test (morgan_orange, 08:08:54)
    15. patch done to get more error for parser (morgan_orange, 08:09:33)
    16. AP: viktor follow the progress of black list of testcases (morgan_orange, 08:09:53)
    17. ACTION: all formalize the condition for tempest smoke suite case exclusion (may initiate a wiki page for that) (morgan_orange, 08:13:07)
    18. SerenaFeng morgan discuss about the 'No space left' on testresults.opnfv.org issue (morgan_orange, 08:13:24)
    19. issue due to elastic search licence issues (lots of logs claiming that the licence is not valid...) (morgan_orange, 08:13:30)
    20. ACTION: morgan_orange ask for x2 on storage capability for the testresult VM (morgan_orange, 08:15:24)
    21. ACTION: morgan_orange see if we should buy (OPNFV has money..) an elasticsearch licence (if none available for free software project) (morgan_orange, 08:15:56)
    22. AP: SerenaFeng jose morgan discuss whether report function will be supported in CLI (morgan_orange, 08:16:55)
    23. decision on the integration of reporting capability within the CLi end of August (morgan_orange, 08:19:07)

  3. Feature projects integration status (morgan_orange, 08:19:52)
    1. SDNVPN: completed. Tests running in CI and reporting to DB. Almost a sun in the bgpvpn scenario http://testresults.opnfv.org/reporting/functest/release/master/index-status-fuel.html (maybe when you read this it is a sun hopefully) (morgan_orange, 08:20:20)
    2. ODL-SFC: integration completed but execution with bugs. Being troubleshooted by Manuel Buil. He will provide more fixes in Functest during next days. Please Valentin and Serena, give him a +2 and merge when he needs it. When they produce some results, they need to add the code to report it to the DB. (morgan_orange, 08:20:27)
    3. ONOS-SFC: Integrated and running and reporting to DB. But they use the name ‘onos’ for both test cases: the default ‘onos’ we already had before, and ‘onos_sfc’ for the new SFC test case. I suggested them to split that into 2 different test cases à keep the old onos test and add a new test in the features tier for the sfc test. https://jira.opnfv.org/browse/ONOSFW-172 (morgan_orange, 08:20:35)
    4. Multisite: They run tempest with a specific configuration. https://git.opnfv.org/cgit/functest/tree/ci/exec_test.sh#n161 but the multisite.py script is still empty… They are running the tests virtually, specially tempest. Still some failures: https://build.opnfv.org/ci/view/functest/job/functest-fuel-virtual-suite-master/lastBuild/console (morgan_orange, 08:20:43)
    5. Moon: I have no info about it. The scenario is not active in CI, so no tests run… (morgan_orange, 08:20:54)
    6. Domino: the test fails (morgan_orange, 08:20:59)
    7. https://build.opnfv.org/ci/view/functest/job/functest-joid-baremetal-daily-master/132/console (morgan_orange, 08:21:06)
    8. Copper: the test is integrated but it fails. (morgan_orange, 08:21:11)
    9. https://jira.opnfv.org/browse/COPPER-20 (morgan_orange, 08:21:15)
    10. https://build.opnfv.org/ci/view/functest/job/functest-apex-apex-daily-master-daily-master/131/console (morgan_orange, 08:21:20)
    11. Doctor: the test fails in CI. (morgan_orange, 08:21:24)
    12. https://jira.opnfv.org/browse/DOCTOR-63 (morgan_orange, 08:21:28)
    13. https://build.opnfv.org/ci/view/functest/job/functest-apex-apex-daily-master-daily-master/131/console (morgan_orange, 08:21:36)
    14. Parser: VNF integrated (morgan_orange, 08:21:39)
    15. https://gerrit.opnfv.org/gerrit/#/c/17785/ (morgan_orange, 08:21:40)
    16. parser should be ready this week (morgan_orange, 08:25:10)
    17. possibility to split onos and onos_sfc already possible in the DB (morgan_orange, 08:25:30)
    18. ACTION: morgan_orange contact onos-sfc to discuss this option (morgan_orange, 08:25:43)
    19. : last two failures, Ashish is working on this issure (May-meimei, 08:26:44)
    20. http://testresults.opnfv.org/reporting/functest/release/master/index-status-apex.html (morgan_orange, 08:29:10)
    21. ACTION: SerenaFeng contact Doctor team to support integration (morgan_orange, 08:30:19)
    22. http://testresults.opnfv.org/test/api/v1/results?case=security_scan&last=10 (morgan_orange, 08:33:59)

  4. Colorado status (morgan_orange, 08:34:33)
    1. documentation (morgan_orange, 08:34:42)
    2. ACTION: CG_Nokia organize webex to discuss remaining topic on documentation (morgan_orange, 08:37:00)
    3. scenarios: almost 7 now per installer, with new fdio scenario recently (morgan_orange, 08:37:22)
    4. https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=59 (morgan_orange, 08:38:51)
    5. most of the JIRA linked to project integration now (morgan_orange, 08:39:43)
    6. ACTION: morgan_orange contact releng team to see if we could have weekly run on Sunday to give a chance to vIMS, Tempest full and Rally full (morgan_orange, 08:44:11)
    7. ACTION: morgan_orange initiate mail for bitergia related to test results (morgan_orange, 08:47:49)

  5. Dovetail (morgan_orange, 08:47:55)
    1. we may plan a GTM next week for an update on dovetail (morgan_orange, 08:48:19)
    2. dovetail aims to select a subset of functest/yardstick/storeperf/* test projects to qualify and certify as system as an OPNFV system (morgan_orange, 08:48:58)
    3. ACTION: morgan_orange invite hongbo to present Dovetail update to Functest team (morgan_orange, 08:49:39)

  6. Student Intern project proposals (morgan_orange, 08:51:08)
    1. mark created a page for intern program (morgan_orange, 08:51:21)
    2. https://wiki.opnfv.org/display/DEV/Intern-projects-page (morgan_orange, 08:51:32)
    3. ACTION: all brainstorm on intern proposals (morgan_orange, 08:53:47)

  7. AoB (morgan_orange, 08:54:28)
    1. I have been contacted by OAI (Open Air Interface), I would invite them to a weekly test meeting (morgan_orange, 08:55:09)
    2. testapi update planned for tomorrow (morgan_orange, 09:02:09)


Meeting ended at 09:02:35 UTC (full logs).

Action items

  1. morgan_orange check with Domino project (no update seen in the ltos of mail I discovered yesterday)
  2. morgan_orange reference this page from Brahamaputra page only
  3. morgan_orange for Coloradao put the URl to swagger
  4. morgan_orange contact bryan_att to sync on this issue
  5. all formalize the condition for tempest smoke suite case exclusion (may initiate a wiki page for that)
  6. morgan_orange ask for x2 on storage capability for the testresult VM
  7. morgan_orange see if we should buy (OPNFV has money..) an elasticsearch licence (if none available for free software project)
  8. morgan_orange contact onos-sfc to discuss this option
  9. SerenaFeng contact Doctor team to support integration
  10. CG_Nokia organize webex to discuss remaining topic on documentation
  11. morgan_orange contact releng team to see if we could have weekly run on Sunday to give a chance to vIMS, Tempest full and Rally full
  12. morgan_orange initiate mail for bitergia related to test results
  13. morgan_orange invite hongbo to present Dovetail update to Functest team
  14. all brainstorm on intern proposals


Action items, by person

  1. CG_Nokia
    1. CG_Nokia organize webex to discuss remaining topic on documentation
  2. morgan_orange
    1. morgan_orange check with Domino project (no update seen in the ltos of mail I discovered yesterday)
    2. morgan_orange reference this page from Brahamaputra page only
    3. morgan_orange for Coloradao put the URl to swagger
    4. morgan_orange contact bryan_att to sync on this issue
    5. morgan_orange ask for x2 on storage capability for the testresult VM
    6. morgan_orange see if we should buy (OPNFV has money..) an elasticsearch licence (if none available for free software project)
    7. morgan_orange contact onos-sfc to discuss this option
    8. morgan_orange contact releng team to see if we could have weekly run on Sunday to give a chance to vIMS, Tempest full and Rally full
    9. morgan_orange initiate mail for bitergia related to test results
    10. morgan_orange invite hongbo to present Dovetail update to Functest team
  3. SerenaFeng
    1. SerenaFeng contact Doctor team to support integration
  4. UNASSIGNED
    1. all formalize the condition for tempest smoke suite case exclusion (may initiate a wiki page for that)
    2. all brainstorm on intern proposals


People present (lines said)

  1. morgan_orange (161)
  2. SerenaFeng (36)
  3. lhinds (11)
  4. CG_Nokia (5)
  5. May-meimei (3)
  6. collabot (3)
  7. boucherv_orange (2)
  8. juhak (1)
  9. JuhaHaapa (1)
  10. raghu_ (1)


Generated by MeetBot 0.1.4.