#opnfv-functest: Functest weekly meeting october 18th

Meeting started by jose_lausuch at 08:00:53 UTC (full logs).

Meeting summary

  1. role call (jose_lausuch, 08:01:11)
    1. Cristina Pauna (ENEA) (CristinaPauna, 08:01:17)
    2. Luke Hinds (lhinds, 08:01:22)
    3. Juha Kosonen (juhak, 08:01:25)
    4. Morgan Richomme (morgan_orange, 08:01:27)
    5. Hideyasu_ool (hideyasu, 08:01:27)
    6. SerenaFeng (SerenaFeng, 08:01:34)
    7. HelenYao (HelenYao, 08:01:50)
    8. agenda for today here: https://wiki.opnfv.org/display/functest/Functest+Meeting#FunctestMeeting-18/10(8UTC) (jose_lausuch, 08:02:36)
    9. previous minutes: http://ircbot.wl.linuxfoundation.org/meetings/opnfv-functest/2016/opnfv-functest.2016-10-11-08.01.html (jose_lausuch, 08:02:46)
    10. Jose Lausuch (jose_lausuch, 08:02:52)

  2. Action point follow-up (jose_lausuch, 08:03:15)
    1. initiate presentation with proposals for the - and -- alreday referenced. Not ready yet. (jose_lausuch, 08:03:33)
    2. ACTION: : morgan_orange jose_lausuch initiate presentation with proposals for the - and -- alreday referenced (jose_lausuch, 08:04:16)
    3. morgan_orange modify Info in repo + inform TSC. Done. (jose_lausuch, 08:04:49)
    4. morgan_orange see how to trigger unit testing on commit on master (jose_lausuch, 08:05:11)
    5. I think we can use storperf as best practice (morgan_orange, 08:05:28)
    6. https://build.opnfv.org/ci/view/storperf/job/storperf-verify-master/81/testReport/ (morgan_orange, 08:05:37)
    7. creation of a dedicated tests dir submitted: https://gerrit.opnfv.org/gerrit/#/c/23233/ (morgan_orange, 08:06:01)
    8. with an illustration with unit test for CLI (I let utilities for the internship) (morgan_orange, 08:06:19)
    9. I will submit a patch in releng to follow stroperf view to trigger unittests (morgan_orange, 08:06:35)
    10. SerenaFeng jose_lausuch review proposal from morgan_orange. (jose_lausuch, 08:07:05)
    11. https://gerrit.opnfv.org/gerrit/#/c/23233/ this submit? (SerenaFeng, 08:07:50)
    12. I sent some comments to the email thread but I agree on the idea exposed in the presentation (jose_lausuch, 08:08:29)
    13. ACTION: SerenaFeng and others review CI proposal from Morgan (jose_lausuch, 08:10:22)
    14. jose_lausuch identify which packages are installed in the docker build process and for what reason. Done. https://wiki.opnfv.org/display/functest/Docker+images+slicing (jose_lausuch, 08:10:38)
    15. HelenYao SerenaFeng jose_lausuch study impact on a massive dockerization of feature. (jose_lausuch, 08:11:11)
    16. Ongoing. Some important impacts detected. https://wiki.opnfv.org/display/functest/Docker+images+slicing (jose_lausuch, 08:11:22)
    17. morgan_orange create a JIRA_epic on docker topic (jose_lausuch, 08:11:55)
    18. Done https://jira.opnfv.org/browse/FUNCTEST-509 (jose_lausuch, 08:13:08)
    19. morgan_orange ask for functest gerrit alias. Done. We have alias for contributors and commiters (jose_lausuch, 08:14:29)
    20. https://gerrit.opnfv.org/gerrit/#/groups/self (jose_lausuch, 08:15:02)
    21. https://gerrit.opnfv.org/gerrit/#/admin/groups/ (jose_lausuch, 08:16:23)
    22. morgan_orange check copyright stuff with Ray. (jose_lausuch, 08:19:16)
    23. I checked with Ray and we should include the license header in all the files (jose_lausuch, 08:20:20)
    24. disucssion in progress between Ray and Cedric (morgan_orange, 08:20:34)
    25. jose_lausuch: ollivier morgan_orange SerenaFeng final decision on patch https://gerrit.opnfv.org/gerrit/#/c/22487/ (jose_lausuch, 08:20:58)

  3. JIRA best practices (jose_lausuch, 08:22:36)
    1. Recommendation is to create an EPIC for a bug story or activity and create tasks within that epic. (jose_lausuch, 08:23:06)
    2. The tasks must be broken down so that it doesn't require a tremendous amount of work. Something that be achieved in a couple of days. (jose_lausuch, 08:23:29)
    3. a JIRA Task does not correspond to 1 commit. 1 task can be completed with 1 or more commits. The idea is not to create JIRA tasks for small changes. (jose_lausuch, 08:23:46)
    4. If sometimes, the change is obvious, it might not include a JIRA reference at all. It is not a mandatory, just optional. (jose_lausuch, 08:24:14)
    5. However, for important changes, we must have JIRA epic/tasks created for it. (jose_lausuch, 08:24:34)
    6. https://wiki.opnfv.org/display/functest/JIRA+management (HelenYao, 08:25:06)
    7. https://wiki.opnfv.org/display/functest/JIRA+management (jose_lausuch, 08:25:36)
    8. ACTION: jose_lausuch include new points in that wiki (jose_lausuch, 08:25:49)
    9. https://jira.opnfv.org/browse/FUNCTEST-332 (SerenaFeng, 08:28:44)
    10. Testcase class refactoring (jose_lausuch, 08:31:08)
    11. https://gerrit.opnfv.org/gerrit/#/c/22921/ (morgan_orange, 08:31:32)
    12. with illustration on odl test (morgan_orange, 08:31:59)
    13. Cedric proposed a way to converge all the test cases created in functest. (jose_lausuch, 08:32:05)
    14. this will help consolidating the framework being more robust and structured. (jose_lausuch, 08:32:18)
    15. all the new test cases should be implemented the same way (jose_lausuch, 08:32:51)
    16. refactoring is usefull to manage feature project in a consistent way by imposing methods (morgan_orange, 08:32:52)
    17. agree on refactor the existing test cases to thenew Testcase class (jose_lausuch, 08:35:59)

  4. Colorado 2.0: what do we have to do (release notes, doc, ...) (jose_lausuch, 08:37:20)
    1. ACTION: morgan_orange jose_lausuch review scenario changes for the release notes, and check jira (jose_lausuch, 08:39:27)
    2. release date Colroado 2.0: doc and test complete 24/10 (morgan_orange, 08:39:54)
    3. ACTION: jose_lausuch tag stable branch next week (jose_lausuch, 08:39:56)
    4. release date COlorado 2.0: 27/10 (morgan_orange, 08:40:06)

  5. OpenStack summit (jose_lausuch, 08:41:43)
    1. people in Barcelona: SerenaFeng morgan_orange HelenYao juhak Cedric David jose_lausuch (Valentin) (jose_lausuch, 08:42:31)
    2. https://wiki.opnfv.org/display/EVNT/OPNFV+at+OpenStack-Barcelona (morgan_orange, 08:43:45)
    3. Functest Meetup planned on Wednesday morning 9-13h (morgan_orange, 08:44:01)
    4. Functest meeting planned for Wednesday 26th , 9:00-13:00 (jose_lausuch, 08:44:59)
    5. discussion with Bitergia about testing dashboard on Thursday at 14:00-1:00 (jose_lausuch, 08:46:21)
    6. discussion with Bitergia about testing dashboard on Thursday at 14:00-16:00 (morgan_orange, 08:47:07)

  6. Docker discussion (jose_lausuch, 08:47:22)
    1. Proposal for slicing our docker image: https://wiki.opnfv.org/display/functest/Docker+images+slicing (jose_lausuch, 08:48:25)
    2. the idea is to have 1 image for Functest core testcases, 1 for feature feature, 1 for sdn controllers, 1 per each vnf (vIMS, vRouter, ...) (jose_lausuch, 08:48:37)
    3. in the comments section there are already some proposals about how to orchestrate all the containers from a central one (jose_lausuch, 08:48:47)
    4. However, this change increases the complexity of the Docker containers management in CI ==> is it worth it? (jose_lausuch, 08:48:56)
    5. agreed 1 core(functest+sdn), 1(feature tests), 1(vims), 1(vnfX),.. (jose_lausuch, 08:53:05)
    6. ACTION: HelenYao prepare script to update jumphost with the needed docker daemon flags (jose_lausuch, 08:56:33)

  7. Internships (jose_lausuch, 08:57:21)
    1. we performed a first interview and have another one this week. (jose_lausuch, 08:57:27)
    2. Added a new internship projet to implement security groups https://wiki.opnfv.org/display/DEV/Intern-projects-page (jose_lausuch, 08:58:31)

  8. AoB (jose_lausuch, 08:59:19)
    1. https://git.opnfv.org/cgit/releng/tree/jjb/releng-macros.yaml (morgan_orange, 09:03:20)


Meeting ended at 09:03:45 UTC (full logs).

Action items

  1. : morgan_orange jose_lausuch initiate presentation with proposals for the - and -- alreday referenced
  2. SerenaFeng and others review CI proposal from Morgan
  3. jose_lausuch include new points in that wiki
  4. morgan_orange jose_lausuch review scenario changes for the release notes, and check jira
  5. jose_lausuch tag stable branch next week
  6. HelenYao prepare script to update jumphost with the needed docker daemon flags


Action items, by person

  1. HelenYao
    1. HelenYao prepare script to update jumphost with the needed docker daemon flags
  2. jose_lausuch
    1. : morgan_orange jose_lausuch initiate presentation with proposals for the - and -- alreday referenced
    2. jose_lausuch include new points in that wiki
    3. morgan_orange jose_lausuch review scenario changes for the release notes, and check jira
    4. jose_lausuch tag stable branch next week
  3. morgan_orange
    1. : morgan_orange jose_lausuch initiate presentation with proposals for the - and -- alreday referenced
    2. morgan_orange jose_lausuch review scenario changes for the release notes, and check jira
  4. SerenaFeng
    1. SerenaFeng and others review CI proposal from Morgan


People present (lines said)

  1. jose_lausuch (217)
  2. morgan_orange (88)
  3. HelenYao (58)
  4. SerenaFeng (36)
  5. collabot` (4)
  6. juhak (2)
  7. hideyasu (2)
  8. CristinaPauna (1)
  9. lhinds (1)


Generated by MeetBot 0.1.4.