#opnfv-functest: Functest weekly meeting January 17th 2017

Meeting started by jose_lausuch at 08:00:22 UTC (full logs).

Meeting summary

  1. role call (jose_lausuch, 08:00:53)
    1. Jose Lausuch (jose_lausuch, 08:00:59)
    2. Helen Yao (HelenYao, 08:01:19)
    3. Linda Wang (LindaWang, 08:01:29)
    4. Juha Kosonen (juhak, 08:01:44)
    5. Juan Vidal (jvidal, 08:01:50)
    6. Morgan Richomme (morgan_orange, 08:02:07)
    7. rohitsakala (rohitsakala, 08:02:30)

  2. Troubleshooting status (jose_lausuch, 08:03:07)
    1. APEX (jose_lausuch, 08:03:19)
    2. Apex jobs: https://build.opnfv.org/ci/job/apex-daily-master/ (jose_lausuch, 08:03:24)
    3. Deployments seem stable (blue) (jose_lausuch, 08:03:31)
    4. healthcheck, vPing, rally_smoke, connection_check and api_check are 100% ok. (jose_lausuch, 08:03:47)
    5. 1 error in Tempest. Copper and Doctor fail. (jose_lausuch, 08:03:58)
    6. https://git.opnfv.org/functest/tree/functest/opnfv_tests/sdn/odl/odl.py#n150 (jose_lausuch, 08:09:15)
    7. 9 tempest failures in odl_l3 scenario (jose_lausuch, 08:09:47)
    8. we think after the odl port fix, tempest have reduced to 1 error only, as in nosdn scenarios (jose_lausuch, 08:12:14)
    9. ACTION: jose_lausuch contact Copper PTL to see what happens with Copper test case (jose_lausuch, 08:12:40)
    10. ACTION: jose_lausuch contact Doctor PTL for Doctor test case (jose_lausuch, 08:12:51)
    11. all SNAPS smoke tests are OK with apex (morgan_orange, 08:13:16)
    12. tempest error log: http://artifacts.opnfv.org/logs/functest/lf-pod1/2017-01-13_10-55-38/tempest/tempest.log (jose_lausuch, 08:14:35)
    13. ACTION: juhak troubleshoot on Apex error (morgan_orange, 08:15:00)
    14. COMPASS (jose_lausuch, 08:15:01)
    15. https://wiki.opnfv.org/display/SWREL/Keystone+API+Usage+per+Installer+in+Danube (HelenYao, 08:15:49)
    16. ACTION: talk to trozet about openstack version vs keystone version. Can we use v3 as all the others? (jose_lausuch, 08:16:39)
    17. get a snaphsot of teh versions of the main component before doing tests could be useful (for further versions..) (morgan_orange, 08:17:22)
    18. deployments are not 100% stable (mixture of red and blue balls) https://build.opnfv.org/ci/job/compass-deploy-baremetal-daily-master/ (jose_lausuch, 08:20:12)
    19. Rally_sanity fails in keystone scenario. 10 failures in tempest (jose_lausuch, 08:20:33)
    20. rest of the test cases are ok. (jose_lausuch, 08:20:37)
    21. https://gerrit.opnfv.org/gerrit/#/c/27015/ (HelenYao, 08:21:05)
    22. filed a fix for keystone problems (also with other installers) https://gerrit.opnfv.org/gerrit/#/c/27015/ (jose_lausuch, 08:21:39)
    23. ACTION: review all https://gerrit.opnfv.org/gerrit/#/c/27015/ (jose_lausuch, 08:24:51)
    24. ACTION: SerenaFeng get an status update about Compass deployment problems (jose_lausuch, 08:33:41)
    25. JOID (jose_lausuch, 08:33:49)
    26. the deployments don´t look stable in CI https://build.opnfv.org/ci/job/joid-deploy-baremetal-daily-master/ (jose_lausuch, 08:33:58)
    27. no joid deployment since 25/12 (morgan_orange, 08:34:19)
    28. ACTION: HelenYao get an status update about Compass deployment problems (jose_lausuch, 08:34:25)
    29. last Functest run was in December 28... (jose_lausuch, 08:34:35)
    30. joid deployed on Intel pods...Intel pods no more available (morgan_orange, 08:34:37)
    31. joid pod available on Huawei but installation not available (morgan_orange, 08:34:52)
    32. ACTION: jose_lausuch talk to jmorgan1 about intel pods status (jose_lausuch, 08:35:06)
    33. ACTION: morgan_orange contact narinder to get visibility...would be hard to troubleshoot if no run before the end of january (morgan_orange, 08:35:29)
    34. fuel (morgan_orange, 08:36:47)
    35. Fuel Deploy jobs: https://build.opnfv.org/ci/job/fuel-deploy-baremetal-daily-master/ (jose_lausuch, 08:37:29)
    36. irc://irc.freenode.net:6667/#info despite the red balls in the past days in the deploy jobs, Functest is executed and surprisingly some tests are ok. (jose_lausuch, 08:38:15)
    37. irc://irc.freenode.net:6667/#info despite the red balls in the past days in the deploy jobs, Functest is executed and surprisingly some tests are ok. (jose_lausuch, 08:38:21)
    38. Functest jobs: https://build.opnfv.org/ci/view/functest/job/functest-fuel-baremetal-daily-master/ (jose_lausuch, 08:39:02)
    39. vPing and Tempest are 100% ok. (jose_lausuch, 08:39:15)
    40. Connection Check test case fails. Keystone in Rally also gives an error. (jose_lausuch, 08:39:28)
    41. rally fails the keystone scenario due to lack of v3 support in 0.7.0 (jose_lausuch, 08:43:07)
    42. ACTION: jose_lausuch test connection_check on a fuel env (jose_lausuch, 08:45:16)
    43. Daisy (jose_lausuch, 08:46:22)
    44. no functest runs so far (jose_lausuch, 08:46:28)
    45. https://build.opnfv.org/ci/job/daisy-deploy-baremetal-daily-master (morgan_orange, 08:47:37)

  3. Lab availability (jose_lausuch, 08:48:53)
    1. jose_lausuch troubleshoot functest-fuel issues (jose_lausuch, 08:49:42)
    2. morgan_orange: compass/colorado (Orange Paris), fuel/colorado (Orange Paris), joid/Danube? (when available on Orange Lannion) and access to LF pod1 and LF POD2 shall still be OK (but not used for a long time and troubleshooting on CI pod is not easy...) (morgan_orange, 08:50:31)
    3. juhak apex/colorado (Nokia pod) (morgan_orange, 08:52:08)
    4. HelenYao compass/colorado and compass/danube (Huawei pod) (morgan_orange, 08:54:21)

  4. Gerrit gate (jose_lausuch, 08:58:17)
    1. https://gerrit.opnfv.org/gerrit/#/c/26499/ (SerenaFeng, 09:07:38)
    2. https://gerrit.opnfv.org/gerrit/#/c/26695/ (HelenYao, 09:08:11)


Meeting ended at 09:10:14 UTC (full logs).

Action items

  1. jose_lausuch contact Copper PTL to see what happens with Copper test case
  2. jose_lausuch contact Doctor PTL for Doctor test case
  3. juhak troubleshoot on Apex error
  4. talk to trozet about openstack version vs keystone version. Can we use v3 as all the others?
  5. review all https://gerrit.opnfv.org/gerrit/#/c/27015/
  6. SerenaFeng get an status update about Compass deployment problems
  7. HelenYao get an status update about Compass deployment problems
  8. jose_lausuch talk to jmorgan1 about intel pods status
  9. morgan_orange contact narinder to get visibility...would be hard to troubleshoot if no run before the end of january
  10. jose_lausuch test connection_check on a fuel env


Action items, by person

  1. HelenYao
    1. HelenYao get an status update about Compass deployment problems
  2. jose_lausuch
    1. jose_lausuch contact Copper PTL to see what happens with Copper test case
    2. jose_lausuch contact Doctor PTL for Doctor test case
    3. jose_lausuch talk to jmorgan1 about intel pods status
    4. jose_lausuch test connection_check on a fuel env
  3. juhak
    1. juhak troubleshoot on Apex error
  4. morgan_orange
    1. morgan_orange contact narinder to get visibility...would be hard to troubleshoot if no run before the end of january
  5. SerenaFeng
    1. SerenaFeng get an status update about Compass deployment problems
  6. UNASSIGNED
    1. talk to trozet about openstack version vs keystone version. Can we use v3 as all the others?
    2. review all https://gerrit.opnfv.org/gerrit/#/c/27015/


People present (lines said)

  1. jose_lausuch (227)
  2. morgan_orange (103)
  3. HelenYao (46)
  4. SerenaFeng (28)
  5. juhak (8)
  6. collabot (8)
  7. jvidal (1)
  8. LindaWang (1)
  9. rohitsakala (1)


Generated by MeetBot 0.1.4.