#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 14:59:55 UTC (full logs).

Meeting summary

  1. roll call (ChrisPriceAB, 15:00:00)
    1. Chris Price (ChrisPriceAB, 15:00:05)
    2. Dirk Kutscher (dku, 15:00:29)
    3. Uli Kleber (uli_, 15:01:38)
    4. dlenrow (dlenrow, 15:01:57)
    5. Pranav Mehta (Pranav, 15:02:22)
    6. Ashiq Khan (Ashiq, 15:02:33)
    7. palani (Palani, 15:03:34)
    8. Bryan Sullivan (bryan_att, 15:03:43)
    9. Julien (julien_ZTE, 15:04:02)
    10. Tapio Tallgren (TapioT, 15:04:04)
    11. Wenjing (Wenjing, 15:04:45)

  2. Approval of Minutes (ChrisPriceAB, 15:05:36)
    1. AGREED: previous minutes approved (ChrisPriceAB, 15:06:15)

  3. Agenda Bashing (ChrisPriceAB, 15:06:23)
    1. Uli discusses the need to review the schedule for release 2, upstream timelines and how they contribute to our release 2. (ChrisPriceAB, 15:07:08)

  4. OPNFV tracks at upcoming events (ChrisPriceAB, 15:09:21)
    1. Bin and I will be there (NFV World), so we could have any OPNFV mini-discussions on projects in common with others attending. (bryan_att, 15:12:52)
    2. there will be an OPNFV track / mini summit at the NFV World Congress in San Jose (ChrisPriceAB, 15:14:12)
    3. Chris Wright (cdub, 15:15:08)
    4. the ONS has offered OPNFV a dev track at the summit in in June (ChrisPriceAB, 15:15:33)
    5. participants from the community will be provided with conference passes. (ChrisPriceAB, 15:15:56)
    6. Julien (julien_ZTE, 15:16:17)
    7. I will volunteer to help plan/organize these events for OPNFV (dlenrow, 15:23:26)
    8. A call for volunteers to help set the agenda and even call for speakers is stated, reach out to Ray and Brandon to participate (ChrisPriceAB, 15:24:10)

  5. Release 1 update (ChrisPriceAB, 15:27:10)
    1. octopus update from Uli: the octopus project has been discussing a structure for CI and a method of rolling in BGS outputs. (ChrisPriceAB, 15:28:04)
    2. Uli describes that the CI structure will impact the development process for release 2 (ChrisPriceAB, 15:28:50)
    3. https://wiki.opnfv.org/_media/octopus/octopus_diagram_v2.pdf (uli_, 15:29:18)
    4. Uli walks through the diagram linked above (ChrisPriceAB, 15:30:29)
    5. Frank Brockners (frankbrockners, 15:37:42)
    6. there are a number of questions around the input components and the deployment tools in the diagram (ChrisPriceAB, 15:43:51)
    7. Palani provides an update of BGS (ChrisPriceAB, 15:53:35)
    8. BGS has a plan for how to progress, to use the first committs into BGS which contains a suite of puppet scripts. (ChrisPriceAB, 15:54:14)
    9. BGS will focus on bringing up this puppet framework on the current infrastructure, available on the wiki and in the repository (ChrisPriceAB, 15:54:56)
    10. https://wiki.opnfv.org/get_started (ChrisPriceAB, 15:55:53)

  6. Confirming the OPNFV Release 1 date (ChrisPriceAB, 16:04:48)
    1. The draft release plan for BGS is a draft release on February 15th and a second release on February 28th. (ChrisPriceAB, 16:08:51)
    2. the BGS team is working toward these dates currently (ChrisPriceAB, 16:09:15)
    3. Palani, Bun Hui, fbrockners have ageed to spend some time on establishing a timeline for the first release. (ChrisPriceAB, 16:14:38)

  7. Test project structure and relationships overview (ChrisPriceAB, 16:16:14)
    1. During the test call during last week the questions from the previous TSC call were discussed. (ChrisPriceAB, 16:16:40)
    2. The Pharos project intends to define the Test-Bed itself, morgan has been updating the wiki with diagrams and descriptions (ChrisPriceAB, 16:17:55)
    3. https://wiki.opnfv.org/pharos (ChrisPriceAB, 16:18:12)
    4. Bun Hui is me Bin Hu :) (bin_, 16:19:23)
    5. The Qtip project is being discussed if it is intended as an umbrella project for performance testing or as a performance testing project itself. (ChrisPriceAB, 16:19:33)
    6. morgan summarises that Pharos is definining the test bed infractrscture, including access, governance, time scheduling, test deployment across envinroments. (ChrisPriceAB, 16:21:05)
    7. this should work with both the functional testing projects, and the peformance testing projects. (ChrisPriceAB, 16:22:02)
    8. Parviz Yegani (Parviz, 16:22:40)

  8. Creation review of Qtip (ChrisPriceAB, 16:24:26)
    1. https://wiki.opnfv.org/platform_performance_benchmarking (ChrisPriceAB, 16:24:40)
    2. Wenjing has spent some time clarifying the scope of Qtip and priority activities for the project as described on the linked WiKi (ChrisPriceAB, 16:27:18)
    3. some use cases have been included on the WiKi to demonstrate the type of test case to be exercised. (ChrisPriceAB, 16:27:41)
    4. Parviz Yegani (Parviz, 16:31:54)
    5. Uli asks if qtip is an umbrella project (ChrisPriceAB, 16:35:04)
    6. Wenjing explains that there may be more work items in the defined scope in future release, and that other projects may leverage the qtip infrastructure (ChrisPriceAB, 16:36:47)
    7. VOTE: Voted on "To create the project Qtip?" Results are, +1: 13 (ChrisPriceAB, 16:42:09)
    8. AGREED: TSC approved the creation of the Qtip project (ChrisPriceAB, 16:42:30)

  9. Development process development and description for release 2 (ChrisPriceAB, 16:43:09)
    1. Uli raises some concerns that following the OpenStack release milestones our requirement projects need to be done in time to comply to those requirements. (ChrisPriceAB, 16:43:58)


Meeting ended at 17:03:39 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. ChrisPriceAB (52)
  2. dneary (7)
  3. collabot` (7)
  4. dlenrow (6)
  5. rprakash_ (6)
  6. frankbrockners (5)
  7. cdub (4)
  8. TapioT (4)
  9. bryan_att (3)
  10. uli_ (3)
  11. Parviz (3)
  12. julien_ZTE (3)
  13. rpaik (3)
  14. dku (2)
  15. Ashiq (2)
  16. AndreaPinnola (2)
  17. Wenjing (2)
  18. Pranav (1)
  19. Palani (1)
  20. margaret__ (1)
  21. bin_ (1)


Generated by MeetBot 0.1.4.