#opnfv-meeting: Octopus Weekly Call

Meeting started by ulik at 14:00:54 UTC (full logs).

Meeting summary

  1. Walk through CI workflows (ulik, 14:12:27)
    1. https://gerrit.opnfv.org/gerrit/gitweb?p=releng.git;a=tree (ulik, 14:13:17)
    2. .. brings to the directory showing the jjb jobs (ulik, 14:13:44)
    3. Jerry asks about the connection between Jira and Gerrit (ulik, 14:14:05)
    4. Aric explains that it's not yet connected via the plugin (ulik, 14:14:46)
    5. Let's create Jira task for Aric to implement that (ulik, 14:15:27)
    6. ACTION: jerryz to create Jira story for this (ulik, 14:15:58)
    7. Fatih Degirmenci (fdegir, 14:16:36)
    8. Proposal for basic flow to work with Jenkins Jobs is: create a story in JIRA Octopus Project -> Do your changes in git repo -> commit & push your changes -> get it verified by automatic verification job -> add reviewers and get it verified -> get it submitted and deployed (fdegir, 14:18:50)
    9. Fatih explains that our script could already call scripts from genesis, as soon as those scripts are there (ulik, 14:25:02)

  2. Jira introduction (ulik, 14:25:09)
    1. https://jira.opnfv.org/i#issues/?jql=project%20%3D%20OCTO (ulik, 14:25:20)
    2. Fatih shows that there is Jira story and epic already for this dependency to genesis (ulik, 14:27:07)
    3. see there for instance OCTO-3 (ulik, 14:27:37)
    4. Fatih encourages to create jobs for everything we have to do in R1 (ulik, 14:28:23)
    5. also encourage to take one of the stories and work on it. (ulik, 14:28:47)
    6. Stories should contain good description and DOD (Definition of Done) so any of us can take and work on stories. (fdegir, 14:30:08)
    7. ACTION: to all: take on topics from Jira, assign yourself and work on it (ulik, 14:30:16)

  3. aob (ulik, 14:37:25)
    1. Iben asks about the exact scope of Octopus (ulik, 14:38:13)
    2. Question: are other projects (that are not in R1) able to use CI? Answer: Yes (ulik, 14:39:01)
    3. ACTION: ulik to raise in TSC that we will enable connection between Jira and Gerrit. Then every commit will need reference to Jira, but dummy reference will be possible (ulik, 14:43:16)
    4. Question about the number of repos for build scripts from the different BGS experiments (ulik, 14:45:04)
    5. Answer We can create saltstack, OpenSteak in the same way. (ulik, 14:47:47)
    6. We had a look at the directory structure (ulik, 14:48:28)
    7. question to script for merge, daily etc. (ulik, 14:49:56)
    8. Answer: daily and merge from jenkins will call the build.sh script (ulik, 14:50:23)
    9. There is no 1:1 mapping in the names between jenkins and the scripts in projects' repos (ulik, 14:51:39)
    10. Jerry remarks that there should be separate genesis-fuel-build etc. Fatih says this can be done later. (ulik, 14:54:40)
    11. question how to address the different environments, including that there are multiple PODs in one environment. (ulik, 14:57:14)
    12. Fatih explains the difference between epic (highest), story (medium), task (smallest) (ulik, 14:59:36)
    13. Every new topic should start with a story. If necessary they can be combined to an epic. (ulik, 15:00:21)


Meeting ended at 15:01:58 UTC (full logs).

Action items

  1. jerryz to create Jira story for this
  2. to all: take on topics from Jira, assign yourself and work on it
  3. ulik to raise in TSC that we will enable connection between Jira and Gerrit. Then every commit will need reference to Jira, but dummy reference will be possible


Action items, by person

  1. jerryz
    1. jerryz to create Jira story for this
  2. ulik
    1. ulik to raise in TSC that we will enable connection between Jira and Gerrit. Then every commit will need reference to Jira, but dummy reference will be possible


People present (lines said)

  1. ulik (33)
  2. collabot (4)
  3. fdegir (3)
  4. ChrisPriceAB (2)
  5. jerryz (1)


Generated by MeetBot 0.1.4.