#opnfv-meeting: OPNFV BGS weekly meeting

Meeting started by frankbrockners at 15:02:47 UTC (full logs).

Meeting summary

    1. will add minutes in irc (rprakash, 15:06:26)

  1. Agenda bashing (ChrisPriceAB, 15:07:14)
    1. https://wiki.opnfv.org/meetings/bgs#mar232015 (frankbrockners, 15:07:46)
    2. no changes proposed to the agenda (ChrisPriceAB, 15:08:14)

  2. Support OPNFV HW setup at the Linux Foundation (Trevor from the Pharos project will lead this discussion) (ChrisPriceAB, 15:08:19)
    1. Linuxfoundation hardware is in place, it is not yet cabled and configured for release 1 needs. (ChrisPriceAB, 15:08:48)
    2. Pharos has the ball on ensuring the LinuxFoundation labs are consistent with our release 1 needs (ChrisPriceAB, 15:09:17)
    3. trevor_intel trevor explains there is a POD set up based on the current BGS requirement. (ChrisPriceAB, 15:10:19)
    4. wrt test beds from Intels perspective 6 nodes, 1 Jump server(landing server), VPN access into development env (no security beyond access) (rprakash, 15:10:49)
    5. Redhat used Foreman to get into devlopment env in lab (rprakash, 15:11:44)
    6. POD2 - use for test env, test tools, Morgan has succesfully access env., Trevor have sent credential this morning to other peoples (pbandzi, 15:12:47)
    7. Other two PODs requested are to follow similar except Vswitch perf POD and one POD for Fuel track (rprakash, 15:13:32)
    8. How many VLAS, what kind of Security, who controls , these questions came up for UCS install, not sure reasons for these requiremenst (rprakash, 15:14:48)
    9. need to develop policies as to who and how do we manage this and Pharos should look at these questions / requirments to configure (rprakash, 15:16:05)
    10. POD1 is exclusively used by Redhat (rprakash, 15:16:36)
    11. POD4 Fueal needs multiple users , how do we move forward on managing this (rprakash, 15:17:06)
    12. Linux Foundation lab should have limited access -pretty much based on Jenkins (rprakash, 15:17:57)
    13. limited people with vendor lab interaction with Linux Lab should be given access to be able to serve the needs of community beyond tool access (rprakash, 15:21:11)
    14. LF will do admin is different from other vendors like UCS admin being managed, so we need skills, so till phase 1 we need some volunteers to keep linkage is kept with BGS to lab for time being (rprakash, 15:23:54)
    15. BGS will not be involved post Rel 1 but untill then BGS requires some access to LF facility for now (rprakash, 15:25:27)
    16. decision on using Baremetal was made at the start in LF (rprakash, 15:27:15)
    17. ACTION: need a volunteer to help Trevor in LF setup (rprakash, 15:27:57)
    18. Frank seeking someone with UCS experience for one BGS (rprakash, 15:28:59)
    19. Iben says there are other VM approaches who also need similar help (rprakash, 15:29:45)
    20. constatntly rebuild and deploy like Foreman, Fuel, Salt different BGS stacks , mostly kvm /Vagarant etc (rprakash, 15:30:56)

  3. Status check on BGS tracks (rprakash, 15:32:30)
    1. on network topology (rprakash, 15:33:01)
    2. https://wiki.opnfv.org/get_started_experiment1 (rprakash, 15:33:47)
    3. Dan is working on details listed Foreman track but will not work for all tracks (rprakash, 15:35:32)
    4. we are seeing convergence in evolving different tracks (rprakash, 15:37:50)
    5. Tim on Foreman track - Test scripts are ready, will open by end of week, Deploy scripts too ready (rprakash, 15:38:37)
    6. session about Foreman/Quickstaxk tomorrow (pbandzi, 15:39:19)
    7. https://bluejeans.com/930297667 (pbandzi, 15:39:24)
    8. Puppet HA issues on Openstack and tie in ODL into HA config , showing good progress (rprakash, 15:39:39)
    9. Tim used Khalisi to run test on Intel PODs using Tempest (rprakash, 15:40:50)
    10. Fuel is opposite compared with respect to quickstack (rprakash, 15:41:41)
    11. pbandzi excuted robottest from integration odl test suite, will provide more info on wiki/jira (pbandzi, 15:42:29)
    12. Builds are ready but virualization deployment is in process and Itel to Ericsson to LF labs in that order as it appears (rprakash, 15:42:36)
    13. one install procedure for ODL , need to involve CI to ensure this with common lib and touch points to expose to CI (rprakash, 15:43:53)
    14. https://etherpad.opnfv.org/p/bgs (frankbrockners, 15:44:05)
    15. how do we go about for BGS from now to next exact one month - drop schedule in etherpad of BGS (rprakash, 15:44:31)
    16. Frank looking for feedback on this etherpad to pace the BGS in the last 4 weeks, if every one can chime in by next week as how it looks like (rprakash, 15:45:32)
    17. when do we do code freeze sometimes to Baremetal say April 2nd and say what works for us into LF/Jenkis etc (rprakash, 15:47:39)
    18. Getting base install and getting release docs thetas the message from Frank and rest to edit and correct what things appear to be for Rel 1 from BGS to CI (rprakash, 15:49:30)
    19. Iben says what help do we need from BGS and other teams to complete this and some tweaks/trade off can be made (rprakash, 15:55:16)
    20. deploy scripts are key (rprakash, 15:55:27)
    21. TIm says from BGS perspective about code freez when we do not have network topology , how do we freeze (rprakash, 15:56:24)
    22. We try agree on network toplogy and then we can come to commonly agreed and code complete may be in a week or two (rprakash, 15:57:14)
    23. priority is getting topology agreement is key (rprakash, 15:58:09)
    24. for OPNFV how are we going to use Cinder how to set it up, should that not be standard and documented - seeking Cinder teams tempest team help (rprakash, 16:00:58)
    25. how do we organize within the limited PODs with two drives outside - lets have a proposal on thisa (rprakash, 16:02:03)


Meeting ended at 16:04:00 UTC (full logs).

Action items

  1. need a volunteer to help Trevor in LF setup


People present (lines said)

  1. rprakash (39)
  2. collabot (8)
  3. frankbrockners (7)
  4. ChrisPriceAB (7)
  5. pbandzi (6)
  6. dfarrell07 (4)
  7. radez (2)


Generated by MeetBot 0.1.4.