#opnfv-meeting: Octopus Weekly Meeting

Meeting started by ulik at 14:01:07 UTC (full logs).

Meeting summary

    1. https://wiki.opnfv.org/meetings/octopus (iben_, 14:05:30)
    2. agenda bashing (fdegir, 14:06:27)
    3. https://wiki.opnfv.org/meetings/octop (fdegir, 14:06:35)

  1. Welcome to new committers (ulik, 14:06:52)
    1. https://wiki.opnfv.org/meetings/octopus (rprakash, 14:07:24)
    2. Uli reports from the voting (7 +1 votes for the new committers) (ulik, 14:09:25)
    3. Uli encourages to document in Jira when doing contributions (ulik, 14:10:03)
    4. https://jira.opnfv.org/issues/?jql=project%20%3D%20OCTO (fdegir, 14:12:01)

  2. Meeting format (ulik, 14:12:33)
    1. https://wiki.opnfv.org/octopus/jenkins_wow (fdegir, 14:13:08)
    2. Uli proposes to move to pure IRC meetings (ulik, 14:13:24)
    3. it is difficult tpo co-ordinate without voice calls (rprakash, 14:13:42)
    4. AGREED: to try IRC only meetings. (ulik, 14:17:41)
    5. if we want to add voice we can do so quickly. (ulik, 14:18:00)

  3. Status update: connected labs (ulik, 14:18:19)
    1. Connected labs are ATT, Huawei, Dell, Ericsson, Intel, Orange (fdegir, 14:18:27)
    2. https://build.opnfv.org/ci/computer/ (fdegir, 14:18:45)
    3. "Connected labs" means one or more servers from these labs are connected to OPNFV Jenkins as slaves (fdegir, 14:20:01)
    4. and these slaves are currently doing different things building or testing depending on the lab/server configuration (fdegir, 14:20:34)
    5. Intel had Firewall problems for Jenkins slave to communicate two way with Jenkin Master (rprakash, 14:20:42)
    6. https://wiki.opnfv.org/wiki/jenkins#jenkins_slaves <— a list maintained on the wiki (iben_, 14:20:50)
    7. https://build.opnfv.org/ci/computer/ (fdegir, 14:21:13)
    8. Work with connecting slave(s) from Spirent lab is curently ongoing (fdegir, 14:22:33)

  4. status update artifact repository (ulik, 14:22:45)
    1. Google storage is in use now (ulik, 14:22:56)
    2. using Google storage with Fuel and Foreman (rprakash, 14:23:06)
    3. https://build.opnfv.org/ci/computer/ (fdegir, 14:23:27)
    4. https://wiki.opnfv.org/wiki/artifactrepos (iben_, 14:23:35)
    5. http://artifacts.opnfv.org/ (fdegir, 14:23:38)
    6. Artifiact Resource Manager (ARM) (rprakash, 14:23:49)
    7. Example build metadata is (fdegir, 14:24:12)
    8. http://artifacts.opnfv.org/genesis/fuel/opnfv-35.properties (fdegir, 14:24:14)
    9. How to get files to ARM (fdegir, 14:24:52)
    10. Slave specific tokens are needed (fdegir, 14:25:04)
    11. Request access/permission by opening ticket to LF helpdesk (fdegir, 14:25:18)
    12. need upload permision and can be obtained from Artic Garner for ARM update (rprakash, 14:25:29)
    13. We need clear instructions for how to work with documentation and what to do with produced documents/artifacts (fdegir, 14:28:11)
    14. ACTION: We need clear instructions for how to work with documentation and what to do with produced documents/artifacts (fdegir, 14:28:48)
    15. Main source information should be the repo (fdegir, 14:30:41)
    16. the wiki will be updated automatically from HTML (fdegir, 14:30:52)
    17. https://wiki.opnfv.org/exampledoc (iben_, 14:31:02)
    18. RST files are created in document directory corresponding to PDFs (rprakash, 14:31:07)
    19. uby automatically generating documentation using the documentation source in Gerrit (fdegir, 14:31:13)

  5. Documentation (ulik, 14:31:42)
    1. Is Octopus expected to provide documentation for R1? (fdegir, 14:32:20)
    2. ACTION: Uli to clarify in TSC whether Octopus documentation is part of Arno (ulik, 14:32:46)
    3. Octopus should provide documentation for R1 even though it is not expected based on what is written on Wiki (fdegir, 14:32:51)
    4. https://wiki.opnfv.org/documentation_projects (iben_, 14:33:05)
    5. https://wiki.opnfv.org/documentation_projects (fdegir, 14:33:39)
    6. Scope of Octopus documentation needs to be decided (fdegir, 14:34:20)
    7. Octopus should document current loops/jobs (fdegir, 14:34:35)
    8. https://wiki.opnfv.org/octopus/flows#candidates_for_release_1 (fdegir, 14:34:50)
    9. Octopus should provide information regarding how to work with jobs using JJB (fdegir, 14:35:41)
    10. https://wiki.opnfv.org/octopus/flows#candidates_for_release_1 (fdegir, 14:35:44)
    11. Documentation regarding Artifact Repository (fdegir, 14:35:56)
    12. Documentation regarding how to connect external labs to OPNFV Jenkins (fdegir, 14:36:17)
    13. https://build.opnfv.org/ci/job/genesis-fuel-daily-att-master/ (iben_, 14:36:20)
    14. This list is the bare minimum for R1 (fdegir, 14:37:27)
    15. releng not found (rprakash, 14:39:05)
    16. story for Ocotpus documentation (fdegir, 14:39:13)
    17. https://jira.opnfv.org/browse/OCTO-33 (fdegir, 14:39:14)
    18. https://gerrit.opnfv.org/gerrit/#/admin/projects/releng (iben_, 14:39:41)
    19. confirmed https://gerrit.opnfv.org/gerrit/#/admin/projects/releng works (rprakash, 14:40:44)
    20. 4 documents (rprakash, 14:41:11)
    21. We need help with documenting (fdegir, 14:41:24)
    22. How to connect labs to OPNFV Jenkins (fdegir, 14:41:25)
    23. How to use JJB (fdegir, 14:41:30)
    24. How to use Artifact Repository (fdegir, 14:41:37)
    25. fdegir is working with documenting current jobs (fdegir, 14:41:50)

  6. Achieving RC2 (ulik, 14:42:49)
    1. LF hardware not yet fully functional (ulik, 14:43:26)
    2. LF hardware is not fully fucntional yet (rprakash, 14:43:30)
    3. waht time do we need once LF hardware is ready (rprakash, 14:44:03)
    4. what is the topo of test env. jenkins master->jump server(slave)->LF hardware? (jerryz, 14:44:46)
    5. we connect Jenkins Slave server that's not enough will need automation and that takes a day least (rprakash, 14:44:52)
    6. Have a deploy script ready but need to test (rprakash, 14:45:17)
    7. Scripts are already prepared, so we can easily move forward as soon as the hardware is ready. (ulik, 14:45:51)
    8. Foreman deploy scripts are ready (fdegir, 14:46:09)
    9. Foreman deploy script are ready not for Fuel (rprakash, 14:46:21)
    10. We need to check Fuel deploy script (fdegir, 14:46:22)
    11. compass has vm-based deploy.sh ready (jerryz, 14:46:22)
    12. The requirement is to have bare metal deployment for R1 (fdegir, 14:47:03)
    13. concluding statement: Octopus is fine for RC2. About one day after hardware is ready. (ulik, 14:50:12)
    14. Hardware ready means that they are connected to Jenkins as slaves (fdegir, 14:50:39)
    15. for rc2 deployment scripts once ready need a day or two to test once LF harware is ready with Jenkins Mater /Salve connected to labs (rprakash, 14:50:56)

  7. starting to think about release 2 (ulik, 14:51:54)
    1. release 1 is just basic (rprakash, 14:52:38)
    2. We need to go through the R1 CI setup and evaluate it (fdegir, 14:52:52)
    3. Improve the CI moving forward (fdegir, 14:53:12)
    4. workflow needs to be im[roved and Zool may be a good idea to investigate (rprakash, 14:53:29)
    5. s/Zool/Zuul (jerryz, 14:53:51)
    6. Project needs are important for CI to improve its workflow (rprakash, 14:54:05)
    7. Jeera story for CI example (rprakash, 14:54:37)
    8. https://jira.opnfv.org/browse/OCTO-31 (fdegir, 14:54:45)
    9. ACTION: Uli to start discussion on etherpad and send email to all projects (ulik, 14:55:24)
    10. We need input from people who have experience with different tools upstream projects use (fdegir, 14:55:33)
    11. Then we need to evaluate these tools to determine if they add value (fdegir, 14:55:44)
    12. or if they increase the complexity (fdegir, 14:55:52)
    13. get agreement for inputs to CI from other projects to feed the etherpad that will be setup by Uli (rprakash, 14:56:23)
    14. build priority list of requirments for CI in etherpad and go over them weekly yo agree on what to do (rprakash, 14:57:39)

  8. AoB (ulik, 14:57:53)


Meeting ended at 14:58:54 UTC (full logs).

Action items

  1. We need clear instructions for how to work with documentation and what to do with produced documents/artifacts
  2. Uli to clarify in TSC whether Octopus documentation is part of Arno
  3. Uli to start discussion on etherpad and send email to all projects


People present (lines said)

  1. iben_ (127)
  2. fdegir (82)
  3. ulik (34)
  4. rprakash (29)
  5. jerryz (12)
  6. collabot (5)
  7. frankbrockners (2)
  8. radez (2)


Generated by MeetBot 0.1.4.