#opnfv-meeting: Second Arno adjusted target release plan planning meeting :D

Meeting started by ChrisPriceAB at 07:01:49 UTC (full logs).

Meeting summary

  1. roll call (ChrisPriceAB, 07:01:55)
    1. Uli (ulik, 07:02:06)

  2. Release readiness update (ChrisPriceAB, 07:04:07)
    1. https://wiki.opnfv.org/releases/arno/releasereadiness release readiness task list (ChrisPriceAB, 07:04:25)
    2. we discussed last night beginning to put dependancies in this task list, I also had an action to update the opnfvdocs pieces. (ChrisPriceAB, 07:04:49)
    3. these did not start last night after the meeting, we can do so today. (ChrisPriceAB, 07:05:03)
    4. we agreed to use "themes" as a way or organising activities into dependancies, rather than trying ot use the numbered list. (ChrisPriceAB, 07:05:36)
    5. Frank Brockners (frankbrockners, 07:05:54)
    6. we also agreed to provide some project planning on the wiki and develop that during today. (ChrisPriceAB, 07:06:14)
    7. Themes = high-level categories/groups (frankbrockners, 07:06:29)
    8. have a look at the wiki (frankbrockners, 07:06:39)
    9. The themes we to be idetifyable activities that might contain sub-tasks that are easily refferable as depenadancies on the other items (like a story) (ChrisPriceAB, 07:07:03)
    10. first column is the category - things that naturally belong together (frankbrockners, 07:07:08)
    11. a theme is like SYS.READY which requires all system readiness activities to be complete prior to the theme itself being ready (ChrisPriceAB, 07:07:40)
    12. we additional articulated the task dependancy that forms the process required to achieve Arno completion (ChrisPriceAB, 07:08:48)
    13. Time to release readiness: max{TEST.READY, SYS.READY} + max{SYS.AUTOMATED,TEST.EXEC} + SYS.RELEASE + DOCS.READY (ChrisPriceAB, 07:08:51)
    14. this provides us with a way of combining tasks and pending time into an equation that gives an indicative release date (ChrisPriceAB, 07:09:26)
    15. we still have not begun to work with functest, morgan is back in the office today. (ChrisPriceAB, 07:10:42)
    16. and there are themes/categories which have an "unknown" time for now - true for SYS.RELEASE, SYS.READY and TEST.READY (frankbrockners, 07:11:33)
    17. in parallel jose_lausuch will work on Tempest automation, pbandzi will work on robot automation, the app deploy teams are working in parallel. (ChrisPriceAB, 07:11:38)
    18. no timelines have been developed for these activities yet. (ChrisPriceAB, 07:11:50)
    19. ACTION: all project leads to ensure we have time estimates for remaining tasks and that the dependancies are defined on other tasks (ChrisPriceAB, 07:12:45)
    20. this will provide a method of estimating parallelism and the critical path for the remaining project activities (ChrisPriceAB, 07:13:11)
    21. we need to work in parallel on the WiKi during the day and will agree between the project leads on the final pre-TSC meeting today on the proposed plan (ChrisPriceAB, 07:14:28)

  3. activities to be completed prior to Final pre-TSC Arno planning meeting. (ChrisPriceAB, 07:20:31)
    1. fill in column 7 (dependancies) where needed to be drawn out (ChrisPriceAB, 07:21:05)
    2. fill in column 6 (time to completion) with estimates on task completion timelines (ChrisPriceAB, 07:21:27)
    3. only add dependancies were there cannot be parallelism (that includes resources) (ChrisPriceAB, 07:21:50)
    4. for tasks "almost complete" where we will be troubleshooting when a dependant task tries to use it, it may be better to dfactor that cost in to the dependant task. opinions? (ChrisPriceAB, 07:22:39)
    5. ACTION: functest team to complete the project with best known estimates (ChrisPriceAB, 07:23:28)
    6. ACTION: opnfvdocs team to compete actions outlined in the previous meeting (ChrisPriceAB, 07:23:45)
    7. ACTION: PL's to work on the project plan text on the wiki. We can add a description of our tasks in simple language there which we can edit after lunch today into a singular Arno text (ChrisPriceAB, 07:24:39)


Meeting ended at 07:26:52 UTC (full logs).

Action items

  1. all project leads to ensure we have time estimates for remaining tasks and that the dependancies are defined on other tasks
  2. functest team to complete the project with best known estimates
  3. opnfvdocs team to compete actions outlined in the previous meeting
  4. PL's to work on the project plan text on the wiki. We can add a description of our tasks in simple language there which we can edit after lunch today into a singular Arno text


People present (lines said)

  1. ChrisPriceAB (51)
  2. ulik (14)
  3. frankbrockners (11)
  4. collabot (3)


Generated by MeetBot 0.1.4.