#opnfv-meeting: OPNFV TSC meeting

Meeting started by frankbrockners at 13:59:10 UTC (full logs).

Meeting summary

    1. Uli Kleber (ulik, 13:59:25)
    2. Gerald Kunzmann (DOCOMO) (GeraldK, 13:59:41)
    3. Dave Neary (proxy for Chris Wright) (dneary, 14:00:56)
    4. Jonas Bjurel ([1]JonasB, 14:02:25)
    5. Julien (julien_ZTE, 14:02:48)
    6. Dirk Kutscher (dku, 14:02:59)
    7. Wenjing Chu (Wenjing, 14:03:01)
    8. morgan (morgan_orange, 14:03:13)
    9. https://global.gotomeeting.com/join/798898261 (ulik, 14:03:52)
    10. agenda for today: https://wiki.opnfv.org/wiki/tsc#april_28_2015 (frankbrockners, 14:05:49)

  1. approval of previous minutes (frankbrockners, 14:07:01)
    1. Tapio Tallgren (tallgren, 14:07:14)
    2. previous minutes approved (frankbrockners, 14:07:32)

  2. agenda bashing (frankbrockners, 14:07:39)
    1. Trevor Cooper (trevor_intel1, 14:07:42)
    2. Bryan Sullivan (bryan_att, 14:09:04)
    3. agenda agreed (frankbrockners, 14:11:11)

  3. Arno Project plans & tracking (frankbrockners, 14:11:29)
    1. Manuel Rebellon (ManuelR_Sandvine, 14:11:57)
    2. I would like to put somethign on the backlog: We should talk about how to deal with the requirement documents that were shared for review already. (ulik, 14:12:53)
    3. Ui tpo discussion on requirement for requirment documents beyond Arno (rprakash, 14:13:23)
    4. requirement docs for Doctor and Promise; both are available in Gerrit (GeraldK, 14:13:26)
    5. ACTION: Uli to prepare the discussion on requirement projects document approval and further proceeding in the next TSC meeting (ulik, 14:14:14)
    6. Gerald will help (ulik, 14:14:29)
    7. Gerald asks if links to Doctor & Promise documents can be included in Arno documentations (rpaik, 14:14:58)
    8. https://wiki.opnfv.org/releases/arno/releasereadiness (frankbrockners, 14:15:21)

  4. Arno project plans & tracking (rpaik, 14:15:57)
    1. How do we make requirement documents of projects and proposal for release of it and its dependency (rprakash, 14:16:01)
    2. Pharos update: waiting for finalization/documentation of LF HW POD deployments (frankbrockners, 14:17:10)
    3. Pharos requires another "couple of days" to complete the overall work for Arno (frankbrockners, 14:17:39)
    4. Dirk Kutscher (dku, 14:18:16)
    5. There is still deployment in devlopment lbas, migration to LF is continuing (rprakash, 14:18:31)
    6. Parviz (Parviz, 14:19:19)
    7. Getting things operational on LF is pending but both teams have a made a good progress like IPMI filtered on Firewall etc (rprakash, 14:19:22)
    8. Dave Neary is proxy for me (Chris Wright) today (cdub, 14:19:27)
    9. BGS: Work still progressing to get things deployed on LF lab (progress made - but still work to be done). (frankbrockners, 14:20:47)
    10. At the same point awaiting Automation on LF, but good progress on Octopus documentation (rprakash, 14:20:49)
    11. Octopus: Docs progressing. Automatic build working. Automatic deploy pending BGS work (frankbrockners, 14:21:19)
    12. Functest: Manual installs of tools (Rally, Robot) available. (frankbrockners, 14:22:02)
    13. Functest: vIMS still pending (working in Metaswitch lab only). Requires features (e.g. Heat) originally not planned for Arno - but considered as a stretch addition. (frankbrockners, 14:22:46)
    14. Functest: Documentation progressing. (frankbrockners, 14:22:58)
    15. func_test working on scripts and some use cases and good work on meta switch lab , manual test on Ericsson lab, ODL being in pipeline today, before end of week will have better results (rprakash, 14:23:13)
    16. is it possible to use func_test in BGS for Smoke test? Ericcson is close and on Intel depends on resource available after LF , excluding IMS may be a week (rprakash, 14:25:28)
    17. BSG stack on Ericsson works and able to run Sanity checks, about 70 error from 300 in Fuel, some anaysis to be done to clear the tets and missing modules, may take few more days (rprakash, 14:26:46)
    18. Functest: Rough estimate: "couple of days to have smoke testing available" - "vIMS - unsure about required time to complete work". (frankbrockners, 14:27:59)
    19. Docs Iban - lot for progress, document guidelines, more comfortable with MS word, can use RST formats to be able to deploy to iso, pdf ad wiki formats (rprakash, 14:28:40)
    20. Docs: Team is there to help with converting proprietary file formats (like MSFT) to .rst (frankbrockners, 14:28:56)
    21. Iben reports that documentation pipeline coming along. If people are more comfrtable with MS Word, that can be converted to .rst (rpaik, 14:29:12)
    22. 4 projects using this docs formats in ci (rprakash, 14:29:29)
    23. staus and state of items per projct readme, lincense etc listed , some may require Architecture Guide, Installation Guide etc. is Customer consumable (rprakash, 14:31:32)
    24. ACTION: Iben to provide an invventory of what is required for documentation (rpaik, 14:31:47)
    25. across the project with contents may help as per Iben (rprakash, 14:32:08)
    26. for outgoing documents etc logo etc may be good and so some cleanup required (rprakash, 14:33:21)
    27. checklist of documents is defined as basic minimum and each project can add as and when there is seen addition al requirements (rprakash, 14:34:41)
    28. some templates are lsited in documents projects and feed back sought in Gitrepo (rprakash, 14:36:20)
    29. https://wiki.opnfv.org/documents MS Word template (rpaik, 14:37:05)
    30. please review +1 or -1 as one uses it (rprakash, 14:37:20)
    31. https://gerrit.opnfv.org/gerrit/#/c/356/ ([1]JonasB, 14:38:41)
    32. suggestion is to setup a meeting between Arno project leads and the documentation team so that documentation questions can be addressed (rpaik, 14:40:46)
    33. ACTION: Iben to create a "documentation happy hour" where people can meet on IRC and get their docs questions answered (frankbrockners, 14:41:18)
    34. can we devide code review and documentation review in to diffrent links or can we use some filter? (julien_ZTE, 14:42:11)
    35. we need Arno users to check the documents whether they provide the necessary information (ulik, 14:45:10)
    36. agree with Uli (julien_ZTE, 14:45:52)
    37. Target release date: Still kept at 2nd half of May. (frankbrockners, 14:47:38)
    38. We are further along in terms of release readiness, but not able to narrow down the Arno release target date (rpaik, 14:47:43)

  5. Ratify updates to Section 7 of TSC Charter - https://www.opnfv.org/developers/technical-project-governance/tsc-charter (frankbrockners, 14:48:30)
    1. AGREED: For internal project decisions where no consensus can be reached, a majority vote among all Committers of the project via +1 voting should be used. (rpaik, 14:55:04)
    2. AGREED: Updated verbiage as presented by Ray was agreed. (frankbrockners, 14:55:11)
    3. voting process agreed (dneary, 14:56:10)

  6. OPNFV Day at OpenStack Summit (dneary, 14:56:18)
    1. https://etherpad.opnfv.org/p/Vancouver_OpenStack for preparation of Vancouver OpenStack summit (ulik, 14:57:56)
    2. Looking through BP submitted , no design summit sessions are there for BP , so make few sessions of VNFFG , IPv6, Doctor, Multi-site for hashing out opnfv use cases (rprakash, 14:59:09)
    3. should the breakout sessions simultaneous or go one after another or divide 270 preople room in to partition or request facility to split (rprakash, 15:00:45)
    4. so post lunch can be split in 2 or 4 sessions tec (rprakash, 15:01:18)
    5. have agenda and then plan out 2 is better than 4 (rprakash, 15:02:08)
    6. 3 slots 2 in paralle with say 20-40 min each etc (rprakash, 15:03:14)
    7. add to etherpad sessions and requirements for projects etc and with telcowg etc. 3 weeks from now so time is premium (rprakash, 15:04:55)
    8. ACTION: dneary/rpaik/hkirksey to schedule an IRC session to discuss OpenStack Summit agenda (rpaik, 15:05:30)
    9. nfv global world no specific ther than opnfv day session details (rprakash, 15:06:51)

  7. Project Proposal & Creation Review Checklist (frankbrockners, 15:07:06)
    1. https://wiki.opnfv.org/developers/project_proposal_creation_review_checklist (frankbrockners, 15:07:22)
    2. Bin Hui mentiones difference between maturity verses two weeks as mimimum and depending on project review and mailing list , prefer agree to maturity level (rprakash, 15:13:50)
    3. Frank would like updtae the page with this suggessions made earlier and get this suggested by Bin and finally voted to get into the new process (rprakash, 15:16:57)
    4. ACTION: ChrisPriceAB bring this topic back to next week’s TSC call to come to a consensus (rpaik, 15:18:02)

  8. Project Approvals (frankbrockners, 15:18:06)
    1. Yardstick - https://wiki.opnfv.org/project_proposals/yardstick (frankbrockners, 15:18:35)
    2. Yardstick: test framework, including test cases and test stimuli, to verify the infrastructure compliance when running VNF applications (frankbrockners, 15:19:50)
    3. anac, I'm interested in this project, please add me to the contributor list, 3x. (julien_ZTE, 15:27:04)
    4. to rally for #info on benchmarking https://wiki.openstack.org/wiki/Rally#Use_Cases (iben_, 15:29:02)
    5. - trevor Cooper representing Rajeev Koodli (trevor_intel, 15:39:13)
    6. Jonas Bjurel representing Chris Price ([1]JonasB, 15:39:35)
    7. GeraldK representing Ashiq Khan (GeraldK, 15:39:48)
    8. VOTE: Voted on "TSC to vote to create the project yardstick?" Results are, +1: 8 (frankbrockners, 15:40:08)
    9. Trevor Cooper (trevor_intel, 15:40:56)
    10. late +1 vote from Dave Neary (frankbrockners, 15:41:20)
    11. Project yardstick got approved by TSC majority vote over IRC (frankbrockners, 15:41:42)
    12. OPNFV Service Function Chaining project approval review (frankbrockners, 15:42:21)
    13. https://wiki.opnfv.org/network_function_chaining (frankbrockners, 15:42:25)
    14. no representative of OPNFV Service Function Chaining was on the TSC call to present the project. Project will be up for review at the next TSC meeting. (frankbrockners, 15:44:47)
    15. https://wiki.opnfv.org/onosfw (rpaik, 15:45:14)
    16. ONOS framework project review (frankbrockners, 15:45:36)
    17. https://wiki.opnfv.org/onosfw (frankbrockners, 15:45:45)
    18. to re-visit the project review next week (rpaik, 16:02:27)
    19. re-visit first on agenda. (ulik, 16:02:58)


Meeting ended at 16:03:06 UTC (full logs).

Action items

  1. Uli to prepare the discussion on requirement projects document approval and further proceeding in the next TSC meeting
  2. Iben to provide an invventory of what is required for documentation
  3. Iben to create a "documentation happy hour" where people can meet on IRC and get their docs questions answered
  4. dneary/rpaik/hkirksey to schedule an IRC session to discuss OpenStack Summit agenda
  5. ChrisPriceAB bring this topic back to next week’s TSC call to come to a consensus


Action items, by person

  1. dneary
    1. dneary/rpaik/hkirksey to schedule an IRC session to discuss OpenStack Summit agenda
  2. rpaik
    1. dneary/rpaik/hkirksey to schedule an IRC session to discuss OpenStack Summit agenda
  3. UNASSIGNED
    1. Uli to prepare the discussion on requirement projects document approval and further proceeding in the next TSC meeting
    2. Iben to provide an invventory of what is required for documentation
    3. Iben to create a "documentation happy hour" where people can meet on IRC and get their docs questions answered
    4. ChrisPriceAB bring this topic back to next week’s TSC call to come to a consensus


People present (lines said)

  1. frankbrockners (48)
  2. rprakash (26)
  3. dneary (25)
  4. rpaik (15)
  5. collabot (14)
  6. ulik (14)
  7. GeraldK (8)
  8. bryan_att (7)
  9. fdegir (7)
  10. [1]JonasB (5)
  11. julien_ZTE (5)
  12. dku (4)
  13. trevor_intel (3)
  14. tallgren (2)
  15. LouisF (2)
  16. ManuelR_Sandvine (2)
  17. Parviz (2)
  18. aricg (1)
  19. morgan_orange (1)
  20. iben_ (1)
  21. trevor_intel1 (1)
  22. cdub (1)
  23. Wenjing (1)


Generated by MeetBot 0.1.4.