#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 14:02:32 UTC (full logs).

Meeting summary

  1. roll call (ChrisPriceAB, 14:02:36)
    1. Uli (ulik, 14:02:40)
    2. Gerald Kunzmann (DOCOMO) (Gerald_K, 14:03:05)
    3. brady.allen.johnson@ericsson.com (SFC) (ebrjohn, 14:03:11)
    4. Dirk Kutscher (dku, 14:03:15)
    5. Frank Brockners (frankbrockners, 14:03:30)
    6. Tapio Tallgren (tallgren, 14:03:32)
    7. Tim Rozet (trozet, 14:05:17)
    8. rajeev (rajeev, 14:05:21)
    9. Rajeev Koodli (rajeev, 14:05:36)

  2. Approval of previous minutes (ChrisPriceAB, 14:05:38)
    1. lack of quorum to approve minutes (ChrisPriceAB, 14:06:05)
    2. Trevor Cooper (trevor_intel1, 14:06:25)

  3. Agenda Bashing (ChrisPriceAB, 14:06:28)
    1. Jonas Bjurel ([1]JonasB, 14:07:01)
    2. Julien (julien_ZTE, 14:07:34)
    3. https://wiki.opnfv.org/wiki/tsc (frankbrockners, 14:08:53)
    4. no addition to the Agenda (ChrisPriceAB, 14:09:00)

  4. Arno Project plans & tracking (ChrisPriceAB, 14:09:29)
    1. OPNFV docs is moving quite well (Gerald_K, 14:09:31)
    2. documentation has graphics etc, needs reviewing (Gerald_K, 14:09:55)
    3. Uli questiosn which part of Octopus should be included in Arno release documentation (Gerald_K, 14:12:17)
    4. development process is not part of Arno, but the capability to do automatic deplyoment should be part of Arno (Gerald_K, 14:13:27)
    5. release docs should not have a "timestamp", otherwise release docs must be associated (forever) with a specific release (Gerald_K, 14:16:26)
    6. Frank wants to see the docs being announced and release so that folks can hookup their lab (Gerald_K, 14:17:47)
    7. Frank proposes Octopus team should come up with a proposal what docs they would add to the release (Gerald_K, 14:19:12)
    8. currently 4 documents from Octopus. "Artifacts" and "Jenkins job builder" are not required as part of Arno (Gerald_K, 14:19:55)
    9. ACTION: octopus (ulik) to add a Jira to opnfvdocs to include the Lab integration doc in the Arno release. (ChrisPriceAB, 14:21:38)
    10. Uli summarizes that 1 document from Octopus should be made part of Arno such that people know how to hookup their lab (Gerald_K, 14:21:59)

  5. Release readiness report (Gerald_K, 14:23:05)
    1. Foreman working on LF lab. Work in progress to move Fuel work from Ericsson lab to LF. (rpaik, 14:24:15)
    2. there are still uncertainties making it difficult to fix a release date (Gerald_K, 14:29:26)
    3. In the LF infrastructure, need autodeploy to work, hooked up to Jenkins, and requreed Functest tests are passing (rpaik, 14:31:32)
    4. Arno is not yet ready to be announced as ready in one week. (ChrisPriceAB, 14:33:45)
    5. ACTION: rpaik to set up a release readiness review on this Thursday. (ChrisPriceAB, 14:34:29)

  6. Media and WiKi content and management responsibilities (ChrisPriceAB, 14:34:54)
    1. we need to be aware media releases will publish our wiki links. our WiKi will need to be maintained accurately. (ChrisPriceAB, 14:43:03)
    2. https://etherpad.opnfv.org/p/Vancouver_OpenStack (rpaik, 14:47:40)
    3. ACTION: Pharos team to propose and present to the TSC on the lab definitions and tracking (ChrisPriceAB, 14:48:05)

  7. Update on OPNFV Day agenda at OpenStack Summit (ChrisPriceAB, 14:48:09)
    1. https://etherpad.opnfv.org/p/Vancouver_OpenStack openstack planning etherpad (ChrisPriceAB, 14:48:27)

  8. Wrap-up discussion on the Project Proposal & Creation Review Checklist (ChrisPriceAB, 14:54:09)
    1. https://wiki.opnfv.org/developers/project_proposal_creation_review_checklist proposed checklist (ChrisPriceAB, 14:54:27)
    2. Chris reminds people that the TSC voted against requiring proposal review in the Technical Community calls but encouraged people to take advantage of input during @the Technical Community (rpaik, 15:08:30)
    3. ACTION: chrispricab, rpaik, bin to return next week with a proposal (ChrisPriceAB, 15:15:40)

  9. Requirements project document approvals and next steps: Uli (ChrisPriceAB, 15:15:45)
    1. ACTION: postponed to next week. (ChrisPriceAB, 15:18:44)
    2. Goal is to make selected requirement documents public before OpenStack Summit (Gerald_K, 15:18:56)
    3. ulik to take over as chair of the call for the remainder (ChrisPriceAB, 15:19:41)
    4. questions are 1) any formal process required, 2) how to publish; HTML; which server?, 3) link with Release (Gerald_K, 15:19:55)

  10. Project reviews (ChrisPriceAB, 15:20:11)
  11. Project creation review of the ONOS Framework (ONOSFW) project (ChrisPriceAB, 15:21:05)
    1. https://wiki.opnfv.org/onosfw link to the project proprosal (ChrisPriceAB, 15:21:24)
    2. Mike Young presents the ONOSFW starting with the checklist (ulik, 15:22:39)
    3. Mike uses slides that can be found on wiki (ulik, 15:23:14)
    4. feedback about installers has been added according to last week's discussion (ulik, 15:23:41)
    5. question about ONOS being a trademark, answer it isn't (ulik, 15:26:53)
    6. question whether we need to check other lists of trademarks beside US. Answer, ONOS is the first project doing the check (ulik, 15:27:57)
    7. Chris clarifies that trademark check will be done at proper time and at the moment not mandatory (ulik, 15:29:01)
    8. Mike clarifies that potential clash with the ONOS project should be clear since ON.lab people are participating. (ulik, 15:30:33)
    9. question about committers from other companies - Answer others didn't step up. (ulik, 15:30:54)
    10. Bin appreciates to add the diversity via this project (ulik, 15:31:36)
    11. Mike invites people to join as committers (ulik, 15:32:38)
    12. Daniel Smith stepping up and volunteering as committer (ulik, 15:33:09)
    13. - Daniel echoing for Rajiv +1 (lmcdasm, 15:35:11)
    14. +1 Dave Neery (Tom___, 15:35:25)
    15. VOTE: Voted on "Approve the ONOSFW project?" Results are, +1: 8 (ulik, 15:36:37)
    16. ONOSFW project is approved - Congratulation (ulik, 15:37:28)
    17. Brady Johnson introducing the Service Function Chaining Project (ulik, 15:38:13)
    18. Brady using slides and showing checklist (ulik, 15:39:02)
    19. There is a very good overlap between the ODL project and the OPNFV collaborative development project (ulik, 15:41:43)
    20. walking through the project proposal in wiki (ulik, 15:42:31)
    21. Question about NSH /VXLAN focus, what is the preference? Answer NSH supports service chaining by the new header (ulik, 15:47:44)
    22. question: is it transparent to physical hardware? Answer should be transparent (ulik, 15:49:14)
    23. also there are more options, MPLS, GRE (ulik, 15:50:07)
    24. some explanation about the relationship of SFC with GBP (ulik, 15:50:57)
    25. question: How much of the project is related to policies in GBP? Answer: SFC transparent to GBP (ulik, 15:52:18)
    26. question: what is additional in OPNFV? Will it bring addtional requirements to ODL? Answer yes, details we will need to see (ulik, 15:53:58)
    27. Ray proxy for Rajeev (rpaik, 15:56:50)
    28. VOTE: Voted on "Approve the creation of the SFC project?" Results are, +1: 7 (ulik, 15:57:14)
    29. project SFC approved (ulik, 15:57:51)


Meeting ended at 15:58:28 UTC (full logs).

Action items

  1. octopus (ulik) to add a Jira to opnfvdocs to include the Lab integration doc in the Arno release.
  2. rpaik to set up a release readiness review on this Thursday.
  3. Pharos team to propose and present to the TSC on the lab definitions and tracking
  4. chrispricab, rpaik, bin to return next week with a proposal
  5. postponed to next week.


Action items, by person

  1. rpaik
    1. rpaik to set up a release readiness review on this Thursday.
    2. chrispricab, rpaik, bin to return next week with a proposal
  2. ulik
    1. octopus (ulik) to add a Jira to opnfvdocs to include the Lab integration doc in the Arno release.
  3. UNASSIGNED
    1. Pharos team to propose and present to the TSC on the lab definitions and tracking
    2. postponed to next week.


People present (lines said)

  1. ChrisPriceAB (37)
  2. ulik (30)
  3. collabot (22)
  4. Gerald_K (20)
  5. Tom___ (14)
  6. frankbrockners (10)
  7. rpaik (9)
  8. lmcdasm (6)
  9. dneary (4)
  10. julien_ZTE (3)
  11. tallgren (3)
  12. ebrjohn (2)
  13. dku (2)
  14. rajeev (2)
  15. [1]JonasB (1)
  16. fdegir (1)
  17. icbts (1)
  18. trevor_intel1 (1)
  19. trozet (1)


Generated by MeetBot 0.1.4.