#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 13:58:03 UTC (full logs).

Meeting summary

  1. roll call (TSC members announce) (ChrisPriceAB, 13:58:23)
    1. Chris Price (ChrisPriceAB, 13:58:28)
    2. Narinder Gupta (narindergupta, 13:58:44)
    3. Gerald Kunzmann (DOCOMO) (Gerald_K, 13:58:52)
    4. Peter Bandzi (pbandzi, 13:59:03)
    5. Tapio Tallgren (tallgren, 13:59:49)
    6. dlenrow (dlenrow, 13:59:54)
    7. Morgan Richomme (morgan_orange, 14:00:22)
    8. Bryan Sullivan (bryan_att, 14:00:33)
    9. Jose Lausuch (jose_lausuch, 14:00:55)
    10. Larry Lamers (ljlamers, 14:01:22)
    11. Wenjing (Wenjing, 14:01:23)
    12. Uli Kleber (uli-k, 14:01:34)

  2. Approval of previous minutes (ChrisPriceAB, 14:02:47)
    1. AGREED: TSC approves the previous minutes of meeting. (ChrisPriceAB, 14:03:13)

  3. Agenda Bashing (ChrisPriceAB, 14:03:18)
    1. Rajeev Koodli (rajeev, 14:05:20)

  4. OpenStack summit activity summary (ChrisPriceAB, 14:05:42)
    1. Standing room only at the OpenStack summit OPNFV day. The morning session was completely full. (ChrisPriceAB, 14:06:44)
    2. requirements project sessions were well attended overall and well received. (ChrisPriceAB, 14:07:11)
    3. Steve Gordon from the Telco Working group closed the day, this session was completely full also. (ChrisPriceAB, 14:07:39)
    4. approximately 270 people showed up to the OPNFV evening reception of the (ChrisPriceAB, 14:08:00)
    5. Trevor Cooper (trevor_intel, 14:09:53)
    6. Chris Wright (cdub, 14:10:52)
    7. Thinh Nguyenphu (Thinh_, 14:10:54)
    8. ChrisPriceAB/HKirksey/Jim Zemlin also attended the OpenStack Board meeting on Sunday prior to the summit (rpaik, 14:10:59)
    9. Dirk Kutscher (dku, 14:11:42)
    10. Ari Pietikainen (Ericsson) (aripie, 14:12:15)
    11. https://www.opnfv.org/sites/opnfv/files/pages/files/opnfv_overview_deck_05112015.pdf generic OPNFV presentation (ChrisPriceAB, 14:13:14)

  5. OPNFV Board meeting summary (ChrisPriceAB, 14:13:56)
    1. ChrisPriceAB discussed some of the Arno learnings with the board during the meeting but the technical community will have to do a formal post-mortem (rpaik, 14:18:36)

  6. Project Approvals (ChrisPriceAB, 14:19:12)
    1. BOD will provide oversight on major theme's/capabilities for OPNFV release. Proposal coming in future BOD meeting. Release committee from BOD. (dlenrow, 14:21:56)
    2. BOD expected to have interactive discussion with TSC on this topic (dlenrow, 14:23:43)
    3. rajeev adds that working upstream topic got lots of discussion in BOD mtg. (dlenrow, 14:24:54)
    4. bryan_att describes how doctor is trying to document best practices from their successfl initial upstream work (dlenrow, 14:25:33)

  7. committer and contributor review of the inspector project (ChrisPriceAB, 14:26:00)
    1. https://wiki.opnfv.org/requirements_projects/inspector updated proposal page (ChrisPriceAB, 14:26:08)
    2. VOTE: Voted on "TSC vote to approve the creation of the inspector project?" Results are, +1: 11 (ChrisPriceAB, 14:28:34)

  8. committer and contributor review of the JOID project (ChrisPriceAB, 14:28:55)
    1. https://wiki.opnfv.org/project_proposals/joid updated wiki (ChrisPriceAB, 14:29:22)
    2. VOTE: Voted on "TSC vote to approve the creation of the JOID project?" Results are, +1: 13 (ChrisPriceAB, 14:30:37)

  9. Requirements projects and next steps (ChrisPriceAB, 14:31:39)
    1. uli-k reports that requirements projects cannot be seen to be finishd until the requirements are implemented. (ChrisPriceAB, 14:32:37)
    2. this is not reflected in our lifecycle document today (ChrisPriceAB, 14:32:52)
    3. proposals have been made on potential changes/amendments to the lifecycle document (ChrisPriceAB, 14:33:31)
    4. I volunteer for that team (bryan_att, 14:34:18)
    5. uli-k proposes that we start a sub-team to propose amendments to the lifecycle document or requirements projects (ChrisPriceAB, 14:34:21)
    6. http://www.openstack.org/blog/2015/02/tc-update-project-reform-progress/ (RayNugent, 14:36:24)
    7. ChrisPriceAB also suggests having discussions among testing & integration teams on our learning to-date (parallel to requirements projects) (rpaik, 14:41:22)
    8. ACTION: uli-k to recruit a team from our requirements project community to further develop the requirement projects development process. (ChrisPriceAB, 14:43:58)
    9. Ildiko reccommends this be done as a retrospective of what is going well. (ChrisPriceAB, 14:44:25)
    10. Ildiko Vancsa (ildikov, 14:45:00)
    11. ildokov, bryan_att and Gerald_K have volunteered to participate in the requirements project process review with uli-k (ChrisPriceAB, 14:46:01)
    12. suggestion to develop metrics for upstream acceptance of OPNFV proposals (i.e. accepted BPs, projects etc) (RayNugent, 14:48:30)

  10. Arno Project plans & tracking (ChrisPriceAB, 14:49:28)
    1. Release tagging and maintenance structure (ChrisPriceAB, 14:49:52)
    2. uli-k mentions that in order to move trunk to the latest upstream versions we would need a maintenance branch (ChrisPriceAB, 14:51:51)
    3. Jonas describes the question is if we want to do stable releases at all (ChrisPriceAB, 14:52:16)
    4. bryan_att indicates that we will want to be able to release a stable version for issues. (ChrisPriceAB, 14:52:49)
    5. uli-k would like to keep the bug-fixing of Arno to a minimum. (ChrisPriceAB, 14:53:03)
    6. providing some stability to our consumers and standing behind our release is important to our community, and for our credibility. (ChrisPriceAB, 14:54:34)
    7. bryan_att asks how we will provide support for Arno once we do release (ChrisPriceAB, 14:57:44)
    8. suggest a discussion on what "maintenance" of a release means (RayNugent, 14:57:45)
    9. ACTION: ChrisPriceAB start dialog on the lists regarding support structure for Arno. (ChrisPriceAB, 15:01:32)
    10. EOL for Arno shoukd no be before B-release (rprakash, 15:02:15)
    11. AGREED: There is a need to support and potentially provide stable releases on the Arno release with a minimum maintenance effort. (ChrisPriceAB, 15:03:21)
    12. Release activities - flag raising (ChrisPriceAB, 15:03:35)
    13. morgan_orange reports that in functional testing we are unable to run a complete sequence. refactoring is ongoing however issues remain on networking. (ChrisPriceAB, 15:05:07)
    14. morgan_orange is confident that the full sequence will contain some errors at Arno release however these are able to be explained. (ChrisPriceAB, 15:06:20)
    15. ACTION: morgan_orange to report to the TSC on next weeks meeting on the status and stability of Arno and the automated test suite. (ChrisPriceAB, 15:08:28)
    16. https://wiki.opnfv.org/r1_tempest (morgan_orange, 15:09:59)
    17. https://wiki.opnfv.org/r1_rally_bench (morgan_orange, 15:10:41)
    18. https://wiki.opnfv.org/r1_odl_suite (morgan_orange, 15:10:50)
    19. https://wiki.opnfv.org/documentation/Arno current Arno documentation status (ChrisPriceAB, 15:12:50)

  11. Release 2 planning (ChrisPriceAB, 15:13:44)
    1. Working on the development process (ChrisPriceAB, 15:13:56)
    2. bryan_att describes that cross project discussions will be necessary to ensure we have concistency in our activities. (ChrisPriceAB, 15:18:29)
    3. Prakash indicates that requirements should map to upstream development sources, this could be streamlined in cross project activities. (ChrisPriceAB, 15:19:02)
    4. would this be a OPNFV design summitt? (RayNugent, 15:19:05)
    5. That would be a good place to do it. is it on the agenda yet? (RayNugent, 15:20:32)
    6. Release dates and upstream dependencies (ChrisPriceAB, 15:26:08)
    7. If we based on openstack Liberty, Liberty itself may not be stable on Nov. (julien_ZTE, 15:30:01)
    8. There is expectation that B-Release would support Openstack Liberty (uli-k, 15:30:07)
    9. TSC should decide whether we want to accomodate this expectation. (uli-k, 15:30:37)
    10. ildikov 2 month at least (julien_ZTE, 15:32:38)
    11. Liberty target Oct 15. 2015 (julien_ZTE, 15:34:32)
    12. https://wiki.openstack.org/wiki/Releases (julien_ZTE, 15:34:44)
    13. OpenStack has 4 release prior to GA in Oct. Liberty will be pretty stable when released (RayNugent, 15:35:05)
    14. june 4 to dec 4, 6-months we can target and define packages and installrs for ci/cd (rprakash, 15:38:05)
    15. ONOS, OpenContrail, ODL, OpenStack, Open vSwitch as starting points for upstream communties for release 2 (rpaik, 15:38:29)
    16. ACTION: dneary to provide a release map for upstream comunities as input in to the B-Release planning discussion. (ChrisPriceAB, 15:38:50)
    17. would lik to work with dneary on this action item above (rprakash, 15:39:32)
    18. add DPDK to the list above :-) (rpaik, 15:39:42)
    19. AGREED: The TSC agrees thet the accommodation of our current upstream efforts as important when setting a target release date. (ChrisPriceAB, 15:39:52)
    20. michael young expects concerns about sprawl and so answer was that markee features in rel 2 should drive the upstream engagement (rprakash, 15:43:56)
    21. the ETSI NFV has a working group that will be establishing a roadmap of community releases including features. The idea is to understand the cadence and pipeline of community activity. (ChrisPriceAB, 15:46:54)
    22. prakash add me to that (rprakash, 15:47:20)
    23. uli-k asks if we can refer to the Liberty release of OpenStack for our OPNFV B-Release (ChrisPriceAB, 15:51:26)
    24. AGREED: the TSC would like to accomodate the OpenStack liberty release in our B-release planning (ChrisPriceAB, 15:56:27)
    25. will also review project release map of upstrem communities prior to setting the date for a B-release next week (rpaik, 15:56:40)


Meeting ended at 15:57:43 UTC (full logs).

Action items

  1. uli-k to recruit a team from our requirements project community to further develop the requirement projects development process.
  2. ChrisPriceAB start dialog on the lists regarding support structure for Arno.
  3. morgan_orange to report to the TSC on next weeks meeting on the status and stability of Arno and the automated test suite.
  4. dneary to provide a release map for upstream comunities as input in to the B-Release planning discussion.


Action items, by person

  1. ChrisPriceAB
    1. ChrisPriceAB start dialog on the lists regarding support structure for Arno.
  2. dneary
    1. dneary to provide a release map for upstream comunities as input in to the B-Release planning discussion.
  3. morgan_orange
    1. morgan_orange to report to the TSC on next weeks meeting on the status and stability of Arno and the automated test suite.
  4. uli-k
    1. uli-k to recruit a team from our requirements project community to further develop the requirement projects development process.


People present (lines said)

  1. ChrisPriceAB (70)
  2. dlenrow (20)
  3. bryan_att (20)
  4. collabot (15)
  5. dneary (9)
  6. uli-k (9)
  7. tallgren (7)
  8. julien_ZTE (7)
  9. rprakash (7)
  10. RayNugent (6)
  11. rpaik (6)
  12. morgan_orange (5)
  13. rajeev (5)
  14. pbandzi (5)
  15. ildikov (4)
  16. jaosorior (4)
  17. Gerald_K (4)
  18. Wenjing (4)
  19. TomNadeau (3)
  20. cdub (3)
  21. zhiheng (3)
  22. dku (3)
  23. Thinh_ (2)
  24. narindergupta (2)
  25. jose_lausuch (2)
  26. aricg (1)
  27. ljlamers (1)
  28. aripie (1)
  29. trevor_intel (1)
  30. ulik (0)


Generated by MeetBot 0.1.4.